Bug 961520 - fatal: unable to make sense of XML-RPC response from server. XML-RPC response too large.
fatal: unable to make sense of XML-RPC response from server. XML-RPC response...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 15:37 EDT by Reartes Guillermo
Modified: 2013-09-14 20:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-14 20:54:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot of the abrt screen (71.47 KB, image/png)
2013-05-09 15:37 EDT, Reartes Guillermo
no flags Details
screen-shot of the abrt screen (new bug 962031) (155.92 KB, image/png)
2013-05-10 23:58 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-09 15:37:35 EDT
Created attachment 745804 [details]
screen-shot of the abrt screen

Description of problem:

I encountered a crash with anaconda and automatic partitioning, i reported it.
The reporting process ended with the bug 961515 being reported and its attachments upload, or at least it seems so.


Version-Release number of selected component (if applicable):
F19b TC3 (19.24-1)

How reproducible:
once

Steps to Reproduce:
1. get a crash (bug 961515)
2. report it
  
Actual results:
unknown, got this error. the bug-report was generated.

Expected results:
no error.

Additional info:

Processing failed:
fatal: unable to make sense of XML-RPC response from server. XML-RPC response too large. Our limit... (off screen)
exited with #1.
Comment 1 Jiri Moskovcak 2013-05-10 03:08:57 EDT
this error is comming from xmlrpc-c library -> reassigning
Comment 2 Reartes Guillermo 2013-05-10 23:58:32 EDT
Created attachment 746472 [details]
screen-shot of the abrt screen (new bug 962031)

A new happening, now with F19b TC4 (19.25-1)
Comment 3 Mikolaj Izdebski 2013-05-14 08:27:38 EDT
Due to security reasons xmlrpc-c rejects server responses that are larger than certain predefined limit. Otherwise one could exhaust memory available for client application and cause DoS.

By default, XML data from the network may be no larger than 512K (XMLRPC_XML_SIZE_LIMIT_DEFAULT). It is up to caller of xmlrpc-c library to define a different limit if the standard 512K is too small. This can be done by calling xmlrpc_limit_set with appropriate arguments, for example xmlrpc_limit_set(XMLRPC_XML_SIZE_LIMIT_ID, 44L*1024*1024) to set the limit to 64M.

This is not a bug in xmlrpc-c, so I am reassigning back to abrt.
Comment 4 Denys Vlasenko 2013-08-21 08:02:56 EDT
(In reply to Reartes Guillermo from comment #0)
> Processing failed:
> fatal: unable to make sense of XML-RPC response from server. XML-RPC
> response too large. Our limit... (off screen)

Too bad you didn't use scroll bar at the bottom of the textbox
to get to the crucial information -  the text off-screen was
"...Our limit is NNN characters.  We got MMM characters..."

It would be very helpful to know what NNN and MMM equals to.
Comment 5 Denys Vlasenko 2013-08-21 08:56:59 EDT
(In reply to Mikolaj Izdebski from comment #3)
> Due to security reasons xmlrpc-c rejects server responses that are larger
> than certain predefined limit. Otherwise one could exhaust memory available
> for client application and cause DoS.
> 
> By default, XML data from the network may be no larger than 512K
> (XMLRPC_XML_SIZE_LIMIT_DEFAULT). It is up to caller of xmlrpc-c library to
> define a different limit if the standard 512K is too small. This can be done
> by calling xmlrpc_limit_set with appropriate arguments, for example
> xmlrpc_limit_set(XMLRPC_XML_SIZE_LIMIT_ID, 44L*1024*1024) to set the limit
> to 64M.

We already increased the limit twice. Currently it is 2M. Bumping it to 4M:

commit f8d2d7570c54e999df731866488c837a031c999a
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Wed Aug 21 14:55:50 2013 +0200

    abrt_xmlrpc: increase XML_SIZE_LIMIT to 4 mbytes. rhbz#961520.

    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Comment 6 Fedora Update System 2013-09-13 09:09:38 EDT
gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
Comment 7 Fedora Update System 2013-09-13 22:39:33 EDT
Package gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc19 abrt-2.1.7-1.fc19 libreport-2.1.7-1.fc19 satyr-0.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16707/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-09-14 20:54:33 EDT
gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.