This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961788 - Signing in after logging out throws exception
Signing in after logging out throws exception
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0.0
Assigned To: Alexandre Porcelli
Jiri Locker
:
: 980374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 07:59 EDT by Jiri Locker
Modified: 2014-08-06 16:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception stack trace (5.21 KB, text/plain)
2013-05-10 07:59 EDT, Jiri Locker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-4091 Major Resolved Error logging out 2015-09-09 09:16:10 EDT

  None (edit)
Description Jiri Locker 2013-05-10 07:59:33 EDT
Created attachment 746134 [details]
exception stack trace

Description of problem:
After logging out of kie-ide, user is redirected to login page. If you sign in again on that page, uncaught exception is presented. Accessing http://localhost:8080/kie-ide/ lets you back into kie-ide like if you haven't logged out at all.

Successful logout can be achieved by refreshing (hitting F5 on) the login page that you were redirected to after logging out.

Version-Release number of selected component (if applicable):
D4 (doesn't manifest in DR3)

How reproducible:


Steps to Reproduce:
1. sign in at http://localhost:8080/kie-ide/
2. log out
3. sign in again
  
Actual results:
uncaught NullPointerException

Expected results:
no exception

Additional info:
Comment 1 Rajesh Rajasekaran 2013-08-01 16:03:40 EDT
*** Bug 980374 has been marked as a duplicate of this bug. ***
Comment 3 JBoss JIRA Server 2013-08-23 21:08:21 EDT
Alexandre Porcelli <porcelli@redhat.com> updated the status of jira JBPM-4091 to Resolved
Comment 4 Jiri Locker 2013-09-19 08:59:18 EDT
Fixed in ER3.

Note You need to log in before you can comment on or make changes to this bug.