Bug 961890 - [abrt] mate-file-manager-1.6.1-1.fc19: button_data_file_changed: Process /usr/bin/caja was killed by signal 6 (SIGABRT)
[abrt] mate-file-manager-1.6.1-1.fc19: button_data_file_changed: Process /usr...
Status: CLOSED DUPLICATE of bug 753882
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
https://github.com/mate-desktop/mate-...
abrt_hash:e5631e2787453f18eb85a903109...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 12:15 EDT by satellitgo
Modified: 2014-01-15 16:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-29 04:38:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (46.14 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: cgroup (140 bytes, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: dso_list (8.47 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: environ (1.32 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: maps (30.88 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: open_fds (3.42 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: proc_pid_status (786 bytes, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
File: xsession_errors (1.25 KB, text/plain)
2013-05-10 12:15 EDT, satellitgo
no flags Details
backtrace (21.82 KB, text/plain)
2013-09-19 18:57 EDT, Nivag
no flags Details
library list? (10.05 KB, text/plain)
2013-09-19 19:01 EDT, Nivag
no flags Details
environment (2.18 KB, text/plain)
2013-09-19 19:02 EDT, Nivag
no flags Details
maps (50.15 KB, text/plain)
2013-09-19 19:03 EDT, Nivag
no flags Details
open file descriptors (3.33 KB, text/plain)
2013-09-19 19:05 EDT, Nivag
no flags Details
proc pid status (941 bytes, text/plain)
2013-09-19 19:06 EDT, Nivag
no flags Details
X session errors (8.59 KB, text/plain)
2013-09-19 19:10 EDT, Nivag
no flags Details

  None (edit)
Description satellitgo 2013-05-10 12:15:39 EDT
Description of problem:
called caja from menu of mate 1.6.0

Version-Release number of selected component:
mate-file-manager-1.6.1-1.fc19

Additional info:
backtrace_rating: 4
cmdline:        caja
core_backtrace: 
crash_function: button_data_file_changed
executable:     /usr/bin/caja
kernel:         3.9.0-301.fc19.i686
runlevel:       N 5
uid:            1000
ureports_counter: 1
var_log_messages: May 10 09:02:07 localhost abrt[2633]: Saved core dump of pid 2352 (/usr/bin/caja) to /var/tmp/abrt/ccpp-2013-05-10-09:02:06-2352 (116568064 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #5 button_data_file_changed at caja-pathbar.c:1859
 #11 caja_file_emit_changed at caja-file.c:7391
 #12 caja_directory_emit_change_signals at caja-directory.c:809
 #13 emit_change_signals_for_all_files at caja-directory.c:259
 #14 async_state_changed_one at caja-directory.c:309
 #15 g_hash_table_foreach at ghash.c:1526
 #16 async_data_preference_changed_callback at caja-directory.c:321
 #17 g_cclosure_marshal_VOID__STRING at gmarshal.c:964
 #22 g_settings_real_change_event at gsettings.c:288
 #23 ffi_call_SYSV at ../src/x86/sysv.S:65

Potential duplicate: bug 905232
Comment 1 satellitgo 2013-05-10 12:15:42 EDT
Created attachment 746239 [details]
File: backtrace
Comment 2 satellitgo 2013-05-10 12:15:44 EDT
Created attachment 746240 [details]
File: cgroup
Comment 3 satellitgo 2013-05-10 12:15:46 EDT
Created attachment 746241 [details]
File: dso_list
Comment 4 satellitgo 2013-05-10 12:15:48 EDT
Created attachment 746242 [details]
File: environ
Comment 5 satellitgo 2013-05-10 12:15:49 EDT
Created attachment 746243 [details]
File: limits
Comment 6 satellitgo 2013-05-10 12:15:51 EDT
Created attachment 746244 [details]
File: maps
Comment 7 satellitgo 2013-05-10 12:15:53 EDT
Created attachment 746245 [details]
File: open_fds
Comment 8 satellitgo 2013-05-10 12:15:55 EDT
Created attachment 746246 [details]
File: proc_pid_status
Comment 9 satellitgo 2013-05-10 12:15:56 EDT
Created attachment 746247 [details]
File: xsession_errors
Comment 10 Dan Mashal 2013-05-14 23:12:45 EDT
Opened issue with upstream.
Comment 11 Wolfgang Ulbrich 2013-07-26 07:29:16 EDT
Did this issue sill exits with current mate-file-manager-1.6.2-1.fc19 from updates-testing?
Comment 12 Nivag 2013-09-19 01:18:08 EDT
This happened with:
mate-file-manager-1.6.2-3.fc19.x86_64.rpm
immediately after I logged in, after rebooting.

I had to reboot, because I had an attack of the x-caja-desktop's after a few hours.

The 2 reboots prior to that, were caused by attacks of the x-caja-desktop's, after about a day, and several days respectively.

I am running Fedora 19
32 GB RAM
Haswell CPU

Please re-open this bug.
Comment 13 Wolfgang Ulbrich 2013-09-19 03:44:50 EDT
Why do you think this is the right place for your issue?
better https://bugzilla.redhat.com/show_bug.cgi?id=886029
Comment 14 Nivag 2013-09-19 05:06:07 EDT
abrt told  me, and I always believe what my computer says!  :-)

I suspect that the hash that abrt generated matched this bug, as 'show log' gave:
"--- Running report_uReport ---
A bug was already filed about this problem:
Bugzilla: URL=https://bugzilla.redhat.com/show_bug.cgi?id=961890"

I'll make a comment on the bug you suggested.
Comment 15 Wolfgang Ulbrich 2013-09-19 05:24:10 EDT
Than please add the necessary files which are created by abrt, like backtrace, etc, tho help us.
You will find those in /var/tmp/abrt/   .
Comment 16 Nivag 2013-09-19 06:44:48 EDT
not anymore, sorry
Comment 17 Wolfgang Ulbrich 2013-09-19 14:38:43 EDT
Don't understand me wrong but i wanna be shure that the issue is the same from the original reporter, without a backtrace + other files i can't confirm that.
The orginal reporter didn't say anything about the x-caja-windows issue.
So pls, don't delete the report in aprt if it ocours again and see for the folder in /var/tmp/abrt/ .
If there is no backtrace ask me how to create them.
Any information is welcome to fix this MATE MOST WANTED!

Thank you
Comment 18 Nivag 2013-09-19 17:52:41 EDT
No worries mate!  :-)

I can assure you, that I too very much want these attacks of x-caja-desktop's terminated.

The only thing I can add, is that in each case I was up-to-date wrt yum updates, within a few hours - I do a yum update at least once a day.
Comment 19 Nivag 2013-09-19 18:57:39 EDT
Created attachment 800198 [details]
backtrace

An attack of x-caja-desktop's started over an hour after logging in after a reboot, and had done a yum update which included the new kernel 3.11.2.

I'll keep the other files, so if you want any of them, please let me know.
Comment 20 Nivag 2013-09-19 19:01:39 EDT
Created attachment 800199 [details]
library list?

I'll load any files that I think might be useful, let me know if you need any more...
Comment 21 Nivag 2013-09-19 19:02:46 EDT
Created attachment 800200 [details]
environment
Comment 22 Nivag 2013-09-19 19:03:57 EDT
Created attachment 800201 [details]
maps
Comment 23 Nivag 2013-09-19 19:05:07 EDT
Created attachment 800203 [details]
open file descriptors
Comment 24 Nivag 2013-09-19 19:06:55 EDT
Created attachment 800212 [details]
proc pid status
Comment 25 Nivag 2013-09-19 19:10:05 EDT
Created attachment 800213 [details]
X session errors
Comment 26 Nivag 2013-09-19 19:54:23 EDT
$ rpm -qa |grep mat
imsettings-mate-1.6.3-1.fc19.x86_64
mate-desktop-1.6.1-11.fc19.x86_64
mate-terminal-debuginfo-1.6.1-11.fc19.x86_64
mate-calc-debuginfo-1.6.0-1.fc19.x86_64
foomatic-filters-4.0.9-3.fc19.x86_64
mate-media-1.6.0-2.fc19.x86_64
mate-keyring-pam-1.6.0-2.fc19.x86_64
mate-file-manager-sendto-1.6.0-2.fc19.x86_64
mate-image-viewer-debuginfo-1.6.1-1.fc19.x86_64
jsmath-fonts-20090708-6.fc19.noarch
libRmath-3.0.1-2.fc19.x86_64
mate-icon-theme-1.6.2-1.fc19.noarch
mate-power-manager-debuginfo-1.6.2-3.fc19.x86_64
mate-media-debuginfo-1.6.0-2.fc19.x86_64
mate-search-tool-1.6.0-8.fc19.x86_64
mate-window-manager-1.6.2-3.fc19.x86_64
libmatewnck-1.6.1-1.fc19.x86_64
mate-settings-daemon-debuginfo-1.6.1-2.fc19.x86_64
mate-system-log-1.6.0-8.fc19.x86_64
mate-file-manager-sendto-debuginfo-1.6.0-2.fc19.x86_64
mate-file-manager-extensions-1.6.2-3.fc19.x86_64
mate-system-monitor-1.6.1-1.fc19.x86_64
mate-file-manager-open-terminal-debuginfo-1.6.0-3.fc19.x86_64
mate-calc-1.6.0-1.fc19.x86_64
mate-window-manager-debuginfo-1.6.2-3.fc19.x86_64
boost-math-1.53.0-14.fc19.x86_64
texlive-pst-math-svn20176.0.61-0.1.fc19.noarch
mate-terminal-1.6.1-11.fc19.x86_64
libreoffice-math-4.1.1.2-4.fc19.x86_64
mate-dictionary-1.6.0-8.fc19.x86_64
mate-dialogs-1.6.0-1.fc19.x86_64
mate-menus-libs-1.6.0-4.fc19.x86_64
texlive-lm-math-svn29044.1.958-0.1.fc19.noarch
mate-polkit-1.6.0-1.fc19.x86_64
mate-notification-daemon-1.6.0-2.fc19.x86_64
mate-character-map-1.6.0-4.fc19.x86_64
libmatewnck-debuginfo-1.6.1-1.fc19.x86_64
mate-screensaver-debuginfo-1.6.1-2.fc19.x86_64
python-mpmath-0.17-8.fc19.noarch
mate-file-manager-image-converter-1.6.0-1.fc19.x86_64
mate-text-editor-1.6.0-5.fc19.x86_64
foomatic-db-filesystem-4.0-38.20130604.fc19.noarch
libmatekeyring-debuginfo-1.6.0-1.fc19.x86_64
mate-backgrounds-1.6.0-1.fc19.noarch
mate-power-manager-1.6.2-3.fc19.x86_64
mate-keyring-debuginfo-1.6.0-2.fc19.x86_64
mate-control-center-filesystem-1.6.1-2.fc19.x86_64
mate-file-manager-1.6.2-3.fc19.x86_64
foomatic-4.0.9-3.fc19.x86_64
texlive-sansmath-svn17997.1.1-0.1.fc19.noarch
libmatekbd-1.6.1-1.fc19.x86_64
python-matplotlib-1.2.0-14.fc19.x86_64
texlive-mathpazo-svn15878.1.003-0.1.fc19.noarch
mate-utils-debuginfo-1.6.0-8.fc19.x86_64
mate-polkit-debuginfo-1.6.0-1.fc19.x86_64
mate-file-manager-image-converter-debuginfo-1.6.0-1.fc19.x86_64
mate-control-center-1.6.1-2.fc19.x86_64
mate-utils-1.6.0-8.fc19.x86_64
mate-dialogs-debuginfo-1.6.0-1.fc19.x86_64
mate-desktop-debuginfo-1.6.1-11.fc19.x86_64
mate-menus-debuginfo-1.6.0-4.fc19.x86_64
mate-file-manager-schemas-1.6.2-3.fc19.x86_64
mate-panel-libs-1.6.1-2.fc19.x86_64
sagemath-doc-en-5.9-6.fc19.noarch
mate-session-manager-1.6.1-1.fc19.x86_64
texlive-tex-gyre-math-svn29045.0-0.1.fc19.noarch
mate-character-map-debuginfo-1.6.0-4.fc19.x86_64
libmatekbd-debuginfo-1.6.1-1.fc19.x86_64
mate-disk-usage-analyzer-1.6.0-8.fc19.x86_64
libquadmath-4.8.1-1.fc19.x86_64
libmatekeyring-1.6.0-1.fc19.x86_64
mate-screensaver-1.6.1-2.fc19.x86_64
stix-math-fonts-1.1.0-4.fc19.noarch
mate-menu-editor-1.6.0-1.fc19.noarch
libRmath-devel-3.0.1-2.fc19.x86_64
nodejs-minimatch-0.2.12-2.fc19.noarch
mate-sensors-applet-1.6.0-3.fc19.x86_64
libmateweather-1.6.2-3.fc19.x86_64
texlive-amsmath-svn30645.2.14-0.1.fc19.noarch
mate-applets-1.6.1-4.fc19.x86_64
mate-file-manager-open-terminal-1.6.0-3.fc19.x86_64
mate-desktop-libs-1.6.1-11.fc19.x86_64
mate-applets-debuginfo-1.6.1-4.fc19.x86_64
mate-file-archiver-debuginfo-1.6.0-2.fc19.x86_64
libmateweather-data-1.6.2-3.fc19.noarch
texlive-lualatex-math-svn29346.1.2-0.1.fc19.noarch
python-backports-ssl_match_hostname-3.4.0.1-1.fc19.noarch
mate-utils-common-1.6.0-8.fc19.noarch
mate-menus-1.6.0-4.fc19.x86_64
mate-screenshot-1.6.0-8.fc19.x86_64
mate-settings-daemon-1.6.1-2.fc19.x86_64
mate-file-manager-debuginfo-1.6.2-3.fc19.x86_64
mate-session-manager-debuginfo-1.6.1-1.fc19.x86_64
mate-panel-debuginfo-1.6.1-2.fc19.x86_64
texlive-unicode-math-svn30504.0.7d-0.1.fc19.noarch
libmatthew-java-0.8-6.fc19.x86_64
foomatic-db-4.0-38.20130604.fc19.noarch
schroedinger-cat-backgrounds-animated-18.91.0-1.fc19.noarch
mate-system-monitor-debuginfo-1.6.1-1.fc19.x86_64
mate-image-viewer-1.6.1-1.fc19.x86_64
mate-control-center-debuginfo-1.6.1-2.fc19.x86_64
libmateweather-debuginfo-1.6.2-3.fc19.x86_64
vecmath-0-5.20090922cvs.fc18.noarch
mate-themes-1.6.2-0.2.git3fc43dd.fc19.noarch
libmatroska-1.4.0-1.fc19.x86_64
mate-panel-1.6.1-2.fc19.x86_64
libquadmath-devel-4.8.1-1.fc19.x86_64
mate-text-editor-debuginfo-1.6.0-5.fc19.x86_64
mate-notification-daemon-debuginfo-1.6.0-2.fc19.x86_64
mate-keyring-1.6.0-2.fc19.x86_64
gtkmathview-0.8.0-12.fc19.x86_64
sagemath-doc-5.9-6.fc19.noarch
mate-file-archiver-1.6.0-2.fc19.x86_64
foomatic-db-ppds-4.0-38.20130604.fc19.noarch
$
Comment 27 Nivag 2013-09-20 01:05:42 EDT
The 'attack' happened again spontaneously, several hours into a session. I tried killing the caja process, but it was only restarted again immediately by mate-session, and immediately began to open an infinite number of windows again every time.

Even after going into the MATE Preferences menu and disabling Caja in the session management options, it was still be automatically restarted.

Eventually I sent SIGSTOP to caja to prevent it from opening any more windows. I was then able to apply the workaround that has been suggested in:

https://bugzilla.redhat.com/show_bug.cgi?id=886029#c85

I then killed caja again, it restarted, this time without an attack. So it looks like this worked around the issue.

This might be unrelated, but a few minutes ago I noticed that mate-panel was using over 100% CPU, and its menus were not responding. Killing mate-panel, simply got another instance of mate-panel with the same behaviour.
Comment 28 Wolfgang Ulbrich 2013-09-20 03:29:07 EDT
Thanks for your information.
Comment 29 Nivag 2013-09-20 07:55:40 EDT
A correction to Comment 19, it was the 3.11.1 (not the 3.11.2) kernel!

uname -a
Linux saturn 3.11.1-200.fc19.x86_64 #1 SMP Sat Sep 14 15:04:51 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 30 Wolfgang Ulbrich 2013-09-21 05:28:39 EDT
I send your informations to upstream.
https://github.com/mate-desktop/mate-file-manager/issues/170
Comment 31 Nivag 2013-09-21 18:25:52 EDT
The problem with mate-panel in Comment 27, has a solution mentioned in:
https://bugzilla.redhat.com/show_bug.cgi?id=886029#c106
Comment 32 Nivag 2013-10-01 04:17:39 EDT
(from comment #27)
[...]
> windows. I was then able to apply the workaround that has been suggested in:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=886029#c85
[...]

About 10 days later, I had another attack of the x-caja-desktop's!

The 2 files mentioned still had 'Exec=caja -n --sync' lines (I just checked).  So looks like adding '--sync' is either, only a partial answer, or at least not as relevant as hoped for!
Comment 33 Wolfgang Ulbrich 2013-10-01 05:15:24 EDT
It seems that we have 2 issues.
1. x-caja-windows at session startup
2. x-caja-windows during session.
I think, and also one mate dev, that the '--sync' workaround helps for (2).
So was the last attack at session startup or in a running session?
Comment 34 Nivag 2013-10-01 06:39:58 EDT
A massive attack of x-caja-desktops, I also noted mate-panel going to 100+% & being unresponsive.

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        caja -n
crash_function: button_data_file_changed
executable:     /usr/bin/caja
kernel:         3.11.1-200.fc19.x86_64
package:        mate-file-manager-1.6.2-3.fc19
reason:         Process /usr/bin/caja was killed by signal 6 (SIGABRT)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 35 Nivag 2013-10-01 06:52:50 EDT
Note that: The attack of Comment #32 was in the same session as Comment #27, but several days later - AFTER '--sync' had been applied to the 2 files. 

This time I rebooted.
Comment 36 Wolfgang Ulbrich 2013-12-18 11:08:27 EST
mate-file-manager-1.6.3-1.fc19 from updates testing should fix the attack of the x-caja-desktop window. Pls can you test this update and leve karma at
https://admin.fedoraproject.org/updates/FEDORA-2013-23505/mate-file-manager-1.6.3-1.fc19?_csrf_token=63d791a12b8c0f0e0c7c2f83d132571d1ffb740a  ?
Comment 37 Nivag 2014-01-14 15:25:17 EST
I have twice had caja crash over the last day or so, but no sign of any attack of x-caja-desktop's!

Abrt says the issue has already been reported, and gives this URL as evidence!

When I attempt to start caja in a terminal, I get lots of error messages like:
(caja:21970): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
$ 


The system had been up for over a day, and my session had been up almost as long.  Plus I had sucessfully used caja many times.

Is there any work-around?

Are there any more diagnostics I can provide?
Comment 38 Nivag 2014-01-14 17:57:45 EST
Linux saturn 3.12.7-200.fc19.x86_64 #1 SMP Fri Jan 10 15:32:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

crashed again, when I went to delete a file

(note previous crash was with kernel 3.12.6, since the I've applied a yum update)
Comment 39 Wolfgang Ulbrich 2014-01-15 10:26:14 EST
@ Nivag
I did closed this bug because of 'x-caja-window' issue is fixed.
So your new issue is a different bug.
For the unwriteable /run/user/1000/dconf/user we could nothing do, because it is a systemd bug.
https://bugzilla.redhat.com/show_bug.cgi?id=753882
We all waiting for systemd guys that they apply their commits from systemd devel to fix this.
If you run in this issue check/and correct permissions for /run/user/1000/dconf/.

Could you please open a new report for the new issue?
Comment 40 Wolfgang Ulbrich 2014-01-15 10:30:52 EST
see also https://bugzilla.redhat.com/show_bug.cgi?id=1044542
same prob with unwriteable /run/user/1000/dconf/user
Comment 41 Nivag 2014-01-15 15:07:38 EST
(In reply to Wolfgang Ulbrich from comment #39)
> @ Nivag
> I did closed this bug because of 'x-caja-window' issue is fixed.
> So your new issue is a different bug.
> For the unwriteable /run/user/1000/dconf/user we could nothing do, because
> it is a systemd bug.
> https://bugzilla.redhat.com/show_bug.cgi?id=753882
> We all waiting for systemd guys that they apply their commits from systemd
> devel to fix this.
> If you run in this issue check/and correct permissions for
> /run/user/1000/dconf/.
> 
> Could you please open a new report for the new issue?

I suspect my basic problem is covered by 
https://bugzilla.redhat.com/show_bug.cgi?id=753882
so is there any point in raising another issue on this?

More significant is that abrt is saying the issue has been reported, yet I would have thought that this is a distinctly different problem to the attack of x-caja-desktop's!  Not sure how to characterise that in a bug report for abrt, or even to search to see if it has been raised against abrt!

Thanks for the work-around.
Comment 42 Wolfgang Ulbrich 2014-01-15 16:17:01 EST
Thanks for info.
I'm not shure that abrt is working correct in this point, because yesterday a abrt alarm in rawhide pointed me to a closed bug in f19 which has a complete different cause ;)
Anyway, you're are the only active supporter for this issue and you issue is currently the dconf directory.
So i will move this report to https://bugzilla.redhat.com/show_bug.cgi?id=753882

*** This bug has been marked as a duplicate of bug 753882 ***

Note You need to log in before you can comment on or make changes to this bug.