Bug 961924 - RHQ Control - Storage cannot be started if data directory is changed by configuration - windows
RHQ Control - Storage cannot be started if data directory is changed by confi...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
x86_64 Windows
urgent Severity high
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-05-10 14:47 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 04:35:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-05-10 14:47:57 EDT
Description of problem:
RHQ Control - Storage cannot be started if data directory is changed by configuration - windows

Version-Release number of selected component (if applicable):
jenkins build 198

How reproducible:
2 out of 2

Steps to Reproduce:
1. run rhqctl.bat install --storage giving --config=rhq-storage.properties
2.
3.
  
Actual results:
storage cannot be started

Expected results:
storage is started and data is saved in directory given in properties file

Additional info:
properties file -> http://d.pr/f/QqfQ
log screenshot -> http://d.pr/i/xUtC
Comment 1 Jay Shaughnessy 2013-05-10 17:24:18 EDT
OK, this basically works but it's sensitive..

1) I'm sure this was just a typo in the BZ, but the option is:

"--storage-config <properties file>"

The BZ description has "--storage"

2) It expects a full filepath for the option, or a relative path from the
   rhq home dir (the parent of the bin dir, not the bin dir itself). So:

> rhqctl install --storage --storage-config bin\rhq-storage.properties

   or something like:

> rhqctl install --storage --storage-config c:\some\rhqinstall\path\bin\rhq-storage.properties

3) Finally, the properties file itself is sensitive.  Here is the property
   file used in the bz:

data=C:\Users\dayana\Desktop
saved-caches=C:\Users\dayana\Desktop

   * Not required, but typically you'd also want a commitlog directory
   * You would not want the same directory for each
   * Most importantly, the values are treated like Java strings, so you need
     either double-backslash or (recommended) forward slashes.

   This should work:

data=C:/Users/dayana/Desktop/rhq/storage/data
saved-caches=C:/Users/dayana/Desktop/rhq/storage/saved_caches
commitlog=C:/Users/dayana/Desktop/rhq/storage/commitlog


Please try this and if it works as expected we'll beef up the documentation.
Comment 2 Armine Hovsepyan 2013-05-14 04:35:21 EDT
verified (not a bug)

The issue was not with the slashes, but with the data directories. data, saved-caches and commitlog should be saved in a directory/file which is not used by another config property. In my config file both data and saved-caches leaded to the same Desktop directory.

closing as "not a bug"

Note You need to log in before you can comment on or make changes to this bug.