This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961992 - mate-file-manager doesn't own directories correctly
mate-file-manager doesn't own directories correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
19
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 924310
  Show dependency treegraph
 
Reported: 2013-05-10 17:59 EDT by Wolfgang Ulbrich
Modified: 2013-05-24 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-file-manager-1.6.1-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 01:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Ulbrich 2013-05-10 17:59:45 EDT
Description of problem:
 $ yum provides /usr/lib64/caja/
 No Matches found
 $ yum provides /usr/lib/caja/
 No Matches found

Please change under %files:
%{_libdir}/caja/extensions-2.0
to
%dir %{_libdir}/caja
%dir %{_libdir}/caja/extensions-2.0

see http://fedoraproject.org/wiki/Packaging:UnownedDirectories

Version-Release number of selected component (if applicable):
all versions: rawhide, f19, f18, f17

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=924310

Dan, i know this was a miskake from me in my first review of mate-file-manager.
Sorry for that noise.
Pls, make me happy and fix it.
Wolfgang
Comment 1 Dan Mashal 2013-05-14 01:04:02 EDT
*confused*

%{_libdir}/caja/extensions-2.0

owns this 

check: 'yum provides "*/lib*caja*"'
Comment 2 Wolfgang Ulbrich 2013-05-14 05:10:15 EDT
It seems that it differ how to use the yum provide command.

yum provides "*/lib*caja*"
<snip>

mate-file-manager-1.5.5-1.fc18.i686 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib/caja/extensions-2.0

mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib64/caja/extensions-2.0

<snip>

mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : @updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib64/caja/



[root@localhost ~]# yum provides */lib*caja*
<snip>

mate-file-manager-1.5.5-1.fc18.i686 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib/caja/extensions-2.0

mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib64/caja/extensions-2.0

<snip>

mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : @updates
Übereinstimmung von:
Dateiname     : /usr/libexec/caja-convert-metadata
Dateiname     : /usr/lib64/caja/



[root@localhost ~]# yum provides /usr/lib*/caja/
Geladene Plugins: langpacks, presto, refresh-packagekit, refresh-updatesd
No Matches found

[root@localhost ~]# yum provides /usr/*/caja/
Geladene Plugins: langpacks, presto, refresh-packagekit, refresh-updatesd
<snip>
mate-file-manager-1.5.5-1.fc18.i686 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/share/caja/

mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : updates
Übereinstimmung von:
Dateiname     : /usr/share/caja/


[root@localhost ~]# yum provides "/usr/*/caja/"
Geladene Plugins: langpacks, presto, refresh-packagekit, refresh-updatesd
mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : @updates
Übereinstimmung von:
Dateiname     : /usr/share/caja/
Dateiname     : /usr/share/pixmaps/caja/
Dateiname     : /usr/lib64/caja/


[root@localhost ~]# yum provides "/usr/lib*/caja/"
Geladene Plugins: langpacks, presto, refresh-packagekit, refresh-updatesd
mate-file-manager-1.5.5-1.fc18.x86_64 : File manager for MATE
Repo        : @updates
Übereinstimmung von:
Dateiname     : /usr/lib64/caja/

I'm still wondering why using quotation marks makes a different in yum.
Maybe we should ask Rex about this issue.
Comment 3 Alex G. 2013-05-14 12:29:35 EDT
> Dateiname     : /usr/lib64/caja/
Wolfgang, I can't reproduce your result.

[mrnuke@nuclearis1 ~]$ yum provides "*/lib*/caja/*"
[yada yada yada]
Filename    : /usr/lib/caja/extensions-2.0
[yada yada yada]


[mrnuke@nuclearis1 ~]$ yum provides "*/lib*/caja/"
[yada yada yada]
No Matches found

mate-file-manager owns /usr/lib*/caja/extensions, but that's not enough. No one  owns /usr/lib*/caja/
Comment 4 Fedora Update System 2013-05-14 22:34:31 EDT
mate-file-manager-1.6.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.1-2.fc19
Comment 5 Wolfgang Ulbrich 2013-05-15 03:21:40 EDT
I did installed the update locally for giving quick karma, but sorry i can't do this.

yum provides /usr/lib64/caja/

mate-file-manager-1.6.1-2.fc19.x86_64 : File manager for MATE
Quelle      : @/mate-file-manager-1.6.1-2.fc19.x86_64
Übereinstimmung von:
Dateiname     : /usr/lib64/caja/


yum provides /usr/lib64/caja/extensions-2.0/

mate-file-manager-1.6.0-1.fc19.x86_64 : File manager for MATE
Quelle      : fedora
Übereinstimmung von:
Dateiname     : /usr/lib64/caja/extensions-2.0/

mate-file-manager-1.6.1-1.fc19.x86_64 : File manager for MATE
Quelle      : updates-testing
Übereinstimmung von:
Dateiname     : /usr/lib64/caja/extensions-2.0/

Now you did owned /usr/lib64/caja/ but not /usr/lib64/caja/extensions-2.0/.
It's necessary that caja also own this directory, because if a extension own this directory it is possible that a user don't install this package but maybe a other extension.
In result no package own this directory.

Pls use
%dir %{_libdir}/caja
%dir %{_libdir}/caja/extensions-2.0

http://fedoraproject.org/wiki/Packaging:UnownedDirectories
Comment 6 Fedora Update System 2013-05-15 12:44:08 EDT
Package mate-file-manager-1.6.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.6.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8245/mate-file-manager-1.6.1-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-05-15 13:06:28 EDT
mate-file-manager-1.6.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.1-3.fc19
Comment 8 Fedora Update System 2013-05-24 16:34:29 EDT
mate-file-manager-1.6.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.