Bug 962173 - Cannot boot into graphic mode
Cannot boot into graphic mode
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 05:44 EDT by Jean-Pierre André
Modified: 2015-02-17 10:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:13:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (9.47 KB, application/octet-stream)
2013-05-12 05:44 EDT, Jean-Pierre André
no flags Details
lspci (1.69 KB, text/plain)
2013-05-12 05:46 EDT, Jean-Pierre André
no flags Details
Output of Xorg -configure (1.35 KB, text/plain)
2013-05-12 05:47 EDT, Jean-Pierre André
no flags Details
Xorg.0.log from Fedora 18 when booting from a live-dvd (79.37 KB, text/plain)
2013-05-12 06:10 EDT, Jean-Pierre André
no flags Details
Xorg.log when rebooting after full install (29.84 KB, text/plain)
2013-05-15 10:32 EDT, Jean-Pierre André
no flags Details

  None (edit)
Description Jean-Pierre André 2013-05-12 05:44:52 EDT
Created attachment 746796 [details]
Xorg.0.log

Description of problem:

Cannot install Fedora 19 (alpha) as setting graphic mode fails

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Boot into Fedora 19 (alpha, live-dvd)
2.
3.
  
Actual results:

Fedora fails to switch to graphic mode, the screen goes white to maximum brightness. Cannot see what happens.

Expected results:

Fedora should switch to graphic mode (possibly showing some logo or splash screen) and display a desktop.

Additional info:

Up to Fedora 18, this computer could be used with some fallback graphic settings. On Fedora 19, I have tried several boot options to no avail (nomodeset, xdriver=vesa, xdriver=intel, acpi_backlight=vendor, acpi_osi=linux)

Booting to level 2 and starting "Xorg -configure" leads to a strange error for a laptop with a single screen and graphical card ("Number of created screens does not match number of detected devices").

Attaching lspci, Xorg.0.log and "Xorg -configure" output, more on request.

Note : the Xorg.0.log is the one resulting from booting into level 2 and requesting "Xorg -configure". Upon a normal reboot I cannot see what happens or get any information from the ramdisk.
Comment 1 Jean-Pierre André 2013-05-12 05:46:47 EDT
Created attachment 746797 [details]
lspci
Comment 2 Jean-Pierre André 2013-05-12 05:47:54 EDT
Created attachment 746798 [details]
Output of Xorg -configure
Comment 3 Jean-Pierre André 2013-05-12 06:10:10 EDT
Created attachment 746820 [details]
Xorg.0.log from Fedora 18 when booting from a live-dvd

I cannot get the Xorg.log when booting on Fedora 19, and I cannot see what happens. This is the one when booting on a Fedora 18 live-dvd, so it might give a clue to what happens. Errors are also shown, but some fallback mode can be used.
Comment 4 Dave Airlie 2013-05-14 22:08:50 EDT
can you try booting f19 with nomodeset and getting the X logs?

though it should work fine with modesetting enabled, it looks like a fairly normal Intel GPU.
Comment 5 Jean-Pierre André 2013-05-15 00:55:18 EDT
Please describe how I could do what you ask for. How could I get a shell ?

When I boot a Fedora 19 alpha live-dvd into level 5 either with nomodeset, and either with xdriver=intel or without xdriver=intel from a live dvd, I end up with a white screen with no way to start a shell. I can boot into level 2, and do an Xorg -configure leading to what I have already attached. Then, if I init level 5 I get the white screen and I am stuck the same way.

I can also boot into the full installation Fedora 19 alpha with xdriver=intel and acpi_backlight=vendor *without* nomodeset, getting a screen with brighness set to maximum and not tunable. I will post the corresponding Xorg.0.log later.
Comment 6 Jean-Pierre André 2013-05-15 10:32:07 EDT
Created attachment 748331 [details]
Xorg.log when rebooting after full install

This is the Xorg.log after installing Fedora 19 from the full installation dvd (not the live one), and rebooting. Nothing special in it, apart from not being able to reduce the brightness. I now think the freeze with blank screen is related to an oops while initializing the network (reported as bug 962827). Better try again when this other issue is solved.
Comment 7 Fedora End Of Life 2015-01-09 13:06:41 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-02-17 10:13:51 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.