Bug 962827 - Network manager hangs at startup
Network manager hangs at startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John Greene
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 10:12 EDT by Jean-Pierre André
Modified: 2013-10-08 14:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 14:00:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of /var/log/messages related to the issue (11.92 KB, application/octet-stream)
2013-05-14 10:12 EDT, Jean-Pierre André
no flags Details
brcmsmac dma map error patch (5.20 KB, patch)
2013-09-12 09:44 EDT, John Greene
no flags Details | Diff

  None (edit)
Description Jean-Pierre André 2013-05-14 10:12:22 EDT
Created attachment 747715 [details]
Part of  /var/log/messages related to the issue

Description of problem:

Network manager hangs at startup of Fedora 19 alpha

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Boot into Fedora 19
2. Login (into account defined at initial installation)
3. Wait for the desktop
  
Actual results:

No desktop (only splash screen)

Expected results:

The desktop is displayed, and the network can be configured

Additional info:

Configuring the WiFi network while installing Fedora is not possible (cf https://bugzilla.redhat.com/show_bug.cgi?id=962485). After skipping this step and installing, the desktop manager hangs as an apparent consequence of some issue (unclear to me) within NetworkManager.
Comment 1 Dan Williams 2013-05-14 13:07:23 EDT
Looks like kernel problems in the bcma driver or rfkill stack block in the kernel with an oops.
Comment 2 Josh Boyer 2013-05-15 09:16:03 EDT
May 14 13:10:02 localhost kernel: [   61.624259] ------------[ cut here ]------------
May 14 13:10:02 localhost kernel: [   61.624400] WARNING: at lib/dma-debug.c:937 check_unmap+0x47d/0x930()
May 14 13:10:02 localhost kernel: [   61.624533] Hardware name: HP ENVY 4 Notebook PC
May 14 13:10:02 localhost kernel: [   61.624640] bcma-pci-bridge 0000:02:00.0: DMA-API: device driver failed to check map error[device address=0x00000000a6f53000] [size=191 bytes] [mapped as single]
May 14 13:10:02 localhost kernel: [   61.624944] Modules linked in: nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables arc4 brcmsmac cordic brcmutil mac80211 iTCO_wdt cfg80211 iTCO_vendor_support rtsx_pci_sdmmc mmc_core rtsx_pci_ms memstick hp_wmi sparse_keymap mperf coretemp kvm_intel kvm crc32_pclmul crc32c_intel ghash_clmulni_intel uvcvideo videobuf2_vmalloc btusb videobuf2_memops videobuf2_core microcode bluetooth videodev media rfkill snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel r8169 snd_hda_codec rtsx_pci mii bcma snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc mei snd_timer snd hp_accel lpc_ich soundcore wmi lis3lv02d i2c_i801 input_polldev mfd_core i915 i2c_algo_bit drm_kms_helper drm i2c_core video uinput
May 14 13:10:02 localhost kernel: [   61.627465] Pid: 36, comm: kworker/0:1 Not tainted 3.9.0-0.rc6.git2.3.fc19.x86_64 #1
May 14 13:10:02 localhost kernel: [   61.627645] Call Trace:
May 14 13:10:02 localhost kernel: [   61.627710]  <IRQ>  [<ffffffff81069106>] warn_slowpath_common+0x66/0x80
May 14 13:10:02 localhost kernel: [   61.627907]  [<ffffffff8106916c>] warn_slowpath_fmt+0x4c/0x50
May 14 13:10:02 localhost kernel: [   61.628070]  [<ffffffff8138151d>] check_unmap+0x47d/0x930
May 14 13:10:02 localhost kernel: [   61.628207]  [<ffffffff81381a2f>] debug_dma_unmap_page+0x5f/0x70
May 14 13:10:02 localhost kernel: [   61.628384]  [<ffffffffa062d855>] dma_getnexttxp+0xd5/0x260 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.628565]  [<ffffffffa05f9da6>] brcms_c_dpc+0x466/0x9e0 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.628736]  [<ffffffffa05ee9af>] brcms_dpc+0x3f/0xd0 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.628886]  [<ffffffff81072df7>] tasklet_action+0x97/0x210
May 14 13:10:02 localhost kernel: [   61.629025]  [<ffffffff8107374f>] __do_softirq+0xff/0x400
May 14 13:10:02 localhost kernel: [   61.629161]  [<ffffffff81073c15>] irq_exit+0xb5/0xc0
May 14 13:10:02 localhost kernel: [   61.629287]  [<ffffffff81727396>] do_IRQ+0x56/0xc0
May 14 13:10:02 localhost kernel: [   61.629413]  [<ffffffff813c7eb6>] ? acpi_os_release_object+0xe/0x12
May 14 13:10:02 localhost kernel: [   61.629570]  [<ffffffff8171c6b2>] common_interrupt+0x72/0x72
May 14 13:10:02 localhost kernel: [   61.629704]  <EOI>  [<ffffffff8171ba2b>] ? _raw_spin_unlock_irqrestore+0x3b/0x70
May 14 13:10:02 localhost kernel: [   61.629917]  [<ffffffff81711bed>] __slab_free+0x58/0x38b
May 14 13:10:02 localhost kernel: [   61.630053]  [<ffffffff810d8b3d>] ? trace_hardirqs_on+0xd/0x10
May 14 13:10:02 localhost kernel: [   61.630200]  [<ffffffff8137446e>] ? debug_check_no_obj_freed+0x14e/0x250
May 14 13:10:02 localhost kernel: [   61.630363]  [<ffffffff811bb787>] ? kmem_cache_free+0xb7/0x380
May 14 13:10:02 localhost kernel: [   61.630509]  [<ffffffff813c7eb6>] ? acpi_os_release_object+0xe/0x12
May 14 13:10:02 localhost kernel: [   61.630661]  [<ffffffff811bba42>] kmem_cache_free+0x372/0x380
May 14 13:10:02 localhost kernel: [   61.630803]  [<ffffffff81401390>] ? acpi_ut_trace_ptr+0x2e/0x7c
May 14 13:10:02 localhost kernel: [   61.630946]  [<ffffffff813c7eb6>] acpi_os_release_object+0xe/0x12
May 14 13:10:02 localhost kernel: [   61.631096]  [<ffffffff814041b7>] acpi_ut_delete_object_desc+0x84/0xa4
May 14 13:10:02 localhost kernel: [   61.631254]  [<ffffffff81401ed3>] acpi_ut_delete_internal_obj+0x4eb/0x511
May 14 13:10:02 localhost kernel: [   61.631423]  [<ffffffff814020e8>] acpi_ut_update_ref_count+0x1ef/0x23f
May 14 13:10:02 localhost kernel: [   61.637036]  [<ffffffff81401390>] ? acpi_ut_trace_ptr+0x2e/0x7c
May 14 13:10:02 localhost kernel: [   61.642563]  [<ffffffff814022a3>] acpi_ut_update_object_reference+0x16b/0x1df
May 14 13:10:02 localhost kernel: [   61.647073]  [<ffffffff814019ac>] acpi_ut_remove_reference+0x7c/0x81
May 14 13:10:02 localhost kernel: [   61.650193]  [<ffffffff813d930a>] acpi_ds_clear_operands+0x4d/0x81
May 14 13:10:02 localhost kernel: [   61.653316]  [<ffffffff813da115>] acpi_ds_exec_end_op+0x1b1/0x6e4
May 14 13:10:02 localhost kernel: [   61.656404]  [<ffffffff813f980d>] ? acpi_ps_complete_op+0x405/0x413
May 14 13:10:02 localhost kernel: [   61.659495]  [<ffffffff813f8db8>] acpi_ps_parse_loop+0x794/0x838
May 14 13:10:02 localhost kernel: [   61.662561]  [<ffffffff813dcbfe>] ? acpi_ds_delete_walk_state+0x11b/0x13d
May 14 13:10:02 localhost kernel: [   61.665623]  [<ffffffff811bdd00>] ? kfree+0x2b0/0x2e0
May 14 13:10:02 localhost kernel: [   61.668634]  [<ffffffff813fa06b>] acpi_ps_parse_aml+0x1bd/0x4ca
May 14 13:10:02 localhost kernel: [   61.671601]  [<ffffffff813fad25>] acpi_ps_execute_method+0x27d/0x3b4
May 14 13:10:02 localhost kernel: [   61.674584]  [<ffffffff813f2386>] acpi_ns_evaluate+0x25e/0x404
May 14 13:10:02 localhost kernel: [   61.677546]  [<ffffffff813f69c4>] acpi_evaluate_object+0x127/0x363
May 14 13:10:02 localhost kernel: [   61.680516]  [<ffffffffa012c8ff>] wmi_evaluate_method+0x11f/0x130 [wmi]
May 14 13:10:02 localhost kernel: [   61.683460]  [<ffffffff810d8924>] ? mark_held_locks+0xb4/0x130
May 14 13:10:02 localhost kernel: [   61.686315]  [<ffffffffa02ed091>] hp_wmi_perform_query+0x91/0x170 [hp_wmi]
May 14 13:10:02 localhost kernel: [   61.689094]  [<ffffffffa02ed5ad>] hp_wmi_rfkill2_refresh+0x3d/0xf0 [hp_wmi]
May 14 13:10:02 localhost kernel: [   61.691748]  [<ffffffffa02ed82a>] ? hp_wmi_notify+0x7a/0x2e8 [hp_wmi]
May 14 13:10:02 localhost kernel: [   61.694304]  [<ffffffff811bdd00>] ? kfree+0x2b0/0x2e0
May 14 13:10:02 localhost kernel: [   61.696766]  [<ffffffffa012c077>] ? wmi_get_event_data+0x77/0x80 [wmi]
May 14 13:10:02 localhost kernel: [   61.699123]  [<ffffffffa02eda45>] hp_wmi_notify+0x295/0x2e8 [hp_wmi]
May 14 13:10:02 localhost kernel: [   61.701364]  [<ffffffffa012ceca>] acpi_wmi_notify+0x8a/0xf0 [wmi]
May 14 13:10:02 localhost kernel: [   61.703580]  [<ffffffff810d53fd>] ? trace_hardirqs_off+0xd/0x10
May 14 13:10:02 localhost kernel: [   61.705785]  [<ffffffff813cb269>] acpi_device_notify+0x19/0x1b
May 14 13:10:02 localhost kernel: [   61.707987]  [<ffffffff813df6e1>] acpi_ev_notify_dispatch+0x49/0x61
May 14 13:10:02 localhost kernel: [   61.710181]  [<ffffffff813c6c63>] acpi_os_execute_deferred+0x25/0x32
May 14 13:10:02 localhost kernel: [   61.712381]  [<ffffffff8108e9ea>] process_one_work+0x20a/0x690
May 14 13:10:02 localhost kernel: [   61.714545]  [<ffffffff8108e97e>] ? process_one_work+0x19e/0x690
May 14 13:10:02 localhost kernel: [   61.717227]  [<ffffffff8108f1f1>] worker_thread+0x111/0x3c0
May 14 13:10:02 localhost kernel: [   61.719526]  [<ffffffff8108f0e0>] ? rescuer_thread+0x270/0x270
May 14 13:10:02 localhost kernel: [   61.721717]  [<ffffffff81094bad>] kthread+0xed/0x100
May 14 13:10:02 localhost kernel: [   61.723914]  [<ffffffff81094ac0>] ? insert_kthread_work+0x80/0x80
May 14 13:10:02 localhost kernel: [   61.726137]  [<ffffffff817255ec>] ret_from_fork+0x7c/0xb0
May 14 13:10:02 localhost kernel: [   61.728360]  [<ffffffff81094ac0>] ? insert_kthread_work+0x80/0x80
May 14 13:10:02 localhost kernel: [   61.730581] ---[ end trace b97b109165d482b9 ]---
May 14 13:10:02 localhost kernel: [   61.732810] Mapped at:
May 14 13:10:02 localhost kernel: [   61.735006]  [<ffffffff81380c61>] debug_dma_map_page+0x91/0x140
May 14 13:10:02 localhost kernel: [   61.737220]  [<ffffffffa062c085>] dma_txenq+0x125/0x2d0 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.739451]  [<ffffffffa062d62b>] dma_txfast+0xdb/0x1a0 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.741661]  [<ffffffffa05f6f21>] brcms_c_txfifo+0x31/0xb0 [brcmsmac]
May 14 13:10:02 localhost kernel: [   61.743875]  [<ffffffffa05f80bc>] brcms_c_sendpkt_mac80211+0xefc/0x1cd0 [brcmsmac]
Comment 3 John Greene 2013-09-11 11:32:47 EDT
There is a patch upstream for this: v3.11-rc1-400-g67d0cf5

67d0cf50bd32b66eab709871714e55725ee30ce4

[jogreene@jgpicker linux]$ git show 67d0cf50
commit 67d0cf50bd32b66eab709871714e55725ee30ce4
Author: John W. Linville <linville@tuxdriver.com>
Date:   Fri Aug 9 13:36:21 2013 -0400

    brcmsmac: Fix WARNING caused by lack of calls to dma_mapping_error()
    
    The driver fails to check the results of DMA mapping in twp places,
    which results in the following warning:
    
Should be available in fedora in a couple weeks organically I hear.

Can you look into this and see if it fits your need?
Comment 4 Jean-Pierre André 2013-09-11 16:19:45 EDT
> Can you look into this and see if it fits your need?

Thank you for examining this issue.

Can you be more precise about what you would expect from me ? I can probably compile a kernel module from source (kernel headers installed), and make a try on a Fedora 19 standard release. Is there a tar source (or srpm) available ? Or shall I just wait for a kernel update ?

I have been able to install Fedora 19 by not configuring the network during the install phase, and doing it afterwards. However brcmsmac behaved badly and I have had to blacklist it and use the Broadcom driver.
Comment 5 John Greene 2013-09-12 09:43:18 EDT
The WARNING should be fixed by the patch listed.  Fedora will pull this in to it's mainstream kernels in a few weeks, so if you can wait, you'll get this as part of the 3.11 or 3.12 release in Fedora I expect.  If you can wait, you can do nothing now.  

If you have a pressing need and the ability to build your kernel yourself, you can apply the patch to your kernel and fix the warning.
If you elect this, I'll attach the patch will be attached to this BZ in next comment.
Comment 6 John Greene 2013-09-12 09:44:21 EDT
Created attachment 796866 [details]
brcmsmac dma map error patch
Comment 7 Josh Boyer 2013-09-12 10:11:24 EDT
That patch was added to the current 3.12 merge window.  It will be a while before F18/F19/F20 get 3.12.  Should already be in rawhide though.
Comment 8 Josh Boyer 2013-09-18 16:27:38 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 9 Josh Boyer 2013-10-08 14:00:18 EDT
This was included in 3.11.2.  Yay!

Note You need to log in before you can comment on or make changes to this bug.