Bug 962176 - [abrt] nemo-1.8.1-1.fc19: _gdk_x11_display_error_event: Process /usr/bin/nemo was killed by signal 5 (SIGTRAP)
[abrt] nemo-1.8.1-1.fc19: _gdk_x11_display_error_event: Process /usr/bin/nemo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nemo (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:d9fd1798815eba91354eb85190c...
:
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-05-12 06:13 EDT by atlee
Modified: 2013-05-16 01:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: nemo-1.8.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 01:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.08 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: cgroup (140 bytes, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: core_backtrace (2.38 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: dso_list (10.29 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: environ (1.36 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: maps (53.23 KB, text/plain)
2013-05-12 06:13 EDT, atlee
no flags Details
File: open_fds (2.66 KB, text/plain)
2013-05-12 06:14 EDT, atlee
no flags Details
File: proc_pid_status (926 bytes, text/plain)
2013-05-12 06:14 EDT, atlee
no flags Details
File: var_log_messages (1.22 KB, text/plain)
2013-05-12 06:14 EDT, atlee
no flags Details

  None (edit)
Description atlee 2013-05-12 06:13:37 EDT
Description of problem:
Just happened after logging into Cinammon.

Version-Release number of selected component:
nemo-1.8.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        nemo -n
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/nemo
kernel:         3.9.1-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 _gdk_x11_display_error_event at gdkdisplay-x11.c:2556
 #5 handle_error at xcb_io.c:212
 #6 handle_response at xcb_io.c:324
 #9 gdk_flush at gdkdisplay.c:478
 #10 make_root_pixmap at gnome-bg.c:1165
 #11 gnome_bg_create_surface at gnome-bg.c:1061
 #12 nemo_desktop_background_ensure_realized at nemo-desktop-background.c:240
 #13 nemo_desktop_background_set_up_widget at nemo-desktop-background.c:305
 #14 background_changed_cb at nemo-desktop-background.c:329
 #18 g_main_context_iteration at gmain.c:3762

Potential duplicate: bug 863296
Comment 1 atlee 2013-05-12 06:13:41 EDT
Created attachment 746821 [details]
File: backtrace
Comment 2 atlee 2013-05-12 06:13:44 EDT
Created attachment 746822 [details]
File: cgroup
Comment 3 atlee 2013-05-12 06:13:46 EDT
Created attachment 746823 [details]
File: core_backtrace
Comment 4 atlee 2013-05-12 06:13:49 EDT
Created attachment 746824 [details]
File: dso_list
Comment 5 atlee 2013-05-12 06:13:52 EDT
Created attachment 746825 [details]
File: environ
Comment 6 atlee 2013-05-12 06:13:54 EDT
Created attachment 746826 [details]
File: limits
Comment 7 atlee 2013-05-12 06:13:57 EDT
Created attachment 746827 [details]
File: maps
Comment 8 atlee 2013-05-12 06:14:00 EDT
Created attachment 746828 [details]
File: open_fds
Comment 9 atlee 2013-05-12 06:14:03 EDT
Created attachment 746829 [details]
File: proc_pid_status
Comment 10 atlee 2013-05-12 06:14:06 EDT
Created attachment 746830 [details]
File: var_log_messages
Comment 11 leigh scott 2013-05-12 07:31:43 EDT
Try this update as it fixes this issue (nemo-desktop-background.c has been removed https://github.com/linuxmint/nemo/pull/263 ).



https://admin.fedoraproject.org/updates/cinnamon-1.8.2-4.fc19,nemo-1.8.1-2.fc19
Comment 12 Fedora Update System 2013-05-12 07:32:42 EDT
nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.8.2-4.fc19,nemo-1.8.1-2.fc19
Comment 13 leigh scott 2013-05-12 07:35:03 EDT
Also if nautilus is installed you will need to disable it in

gnome-session-properties


Uncheck Files
Comment 14 atlee 2013-05-12 08:26:31 EDT
Hi Leigh,

I have installed nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 and seems to be fine so far :)

atlee
Comment 15 atlee 2013-05-12 08:33:49 EDT
(In reply to comment #14)
> Hi Leigh,
> 
> I have installed nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 and seems to be
> fine so far :)
> 
> atlee

Also my background can be changed and also when i goto change backgrounds, all the images display, before it showed nothing. tks
Comment 16 atlee 2013-05-12 08:50:21 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > Hi Leigh,
> > 
> > I have installed nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 and seems to be
> > fine so far :)
> > 
> > atlee
> 
> Also my background can be changed and also when i goto change backgrounds,
> all the images display, before it showed nothing. tks

not sure if its related but if I have programs open, cinnamon toolbar down bottom, I cannot select anything on the bar. But I can alt+tab through programs. It was working before update.
Comment 17 satellitgo 2013-05-12 13:44:30 EDT
tried to change backgrounds

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        nemo -n
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/nemo
kernel:         3.9.1-301.fc19.x86_64
package:        nemo-1.8.1-1.fc19
reason:         Process /usr/bin/nemo was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
Comment 18 Fedora Update System 2013-05-12 13:50:52 EDT
Package nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nemo-1.8.1-2.fc19 cinnamon-1.8.2-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7963/cinnamon-1.8.2-4.fc19,nemo-1.8.1-2.fc19
then log in and leave karma (feedback).
Comment 19 satellitgo 2013-05-12 13:55:36 EDT
on f19 live desktop x86_64 HD installs using dd USB with gnome; gnome-classic-session; mate; cinnamon; KDE; sugar-desktop installed
all but gnome3 were yum @xxxxx-desktop installs
Comment 20 Fedora Update System 2013-05-14 04:56:44 EDT
muffin-1.8.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/muffin-1.8.1-2.fc19
Comment 21 leigh scott 2013-05-14 07:10:07 EDT
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #14)
> > > Hi Leigh,
> > > 
> > > I have installed nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 and seems to be
> > > fine so far :)
> > > 
> > > atlee
> > 
> > Also my background can be changed and also when i goto change backgrounds,
> > all the images display, before it showed nothing. tks
> 
> not sure if its related but if I have programs open, cinnamon toolbar down
> bottom, I cannot select anything on the bar. But I can alt+tab through
> programs. It was working before update.

I believe muffin-1.8.1-2.fc19 will fix the dnd panel freeze.

https://github.com/linuxmint/muffin/issues/79

https://github.com/linuxmint/muffin/pull/83
Comment 22 Adam Williamson 2013-05-14 17:11:28 EDT
I've let Dan know this, but as a state-of-play update: we're frozen for Beta. The last update for Cinnamon that made it in under the wire was:

https://admin.fedoraproject.org/updates/FEDORA-2013-7912/nemo-1.8.1-1.fc19,cinnamon-1.8.2-2.fc19,muffin-1.8.0-3.fc19

the updates since then - cinnamon-1.8.2-4.fc19, nemo-1.8.1-2.fc19 and muffin-1.8.1-2.fc19 - are not in stable and will not get there for Beta unless there are relevant freeze exception bugs:

https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

so if the fixes in those updates are to critical functionality (it kinda sounds like they are), this and/or other bugs should be nominated as BetaFreezeException.

Right now this report seems to be a bit of a confused jumble of issues affecting different people and components and fixed in different updates. It would make things clearer, perhaps, if the issues were separated from each other.

I'll nominate this bug as BetaFreezeException for the crash initially reported by 'atlee', expected to be fixed by https://admin.fedoraproject.org/updates/FEDORA-2013-7963/cinnamon-1.8.2-4.fc19,nemo-1.8.1-2.fc19 . If the issue fixed by https://admin.fedoraproject.org/updates/muffin-1.8.1-2.fc19 is also critical, it would be best to have a separate report for that bug, marked as being fixed by that update, and also nominated as BetaFreezeException.
Comment 23 Dan Mashal 2013-05-14 17:14:55 EDT
+1 freeze exception
Comment 24 leigh scott 2013-05-14 17:28:31 EDT
(In reply to comment #22)
> I've let Dan know this, but as a state-of-play update: we're frozen for
> Beta. The last update for Cinnamon that made it in under the wire was:
> 
> https://admin.fedoraproject.org/updates/FEDORA-2013-7912/nemo-1.8.1-1.fc19,
> cinnamon-1.8.2-2.fc19,muffin-1.8.0-3.fc19
> 
> the updates since then - cinnamon-1.8.2-4.fc19, nemo-1.8.1-2.fc19 and
> muffin-1.8.1-2.fc19 - are not in stable and will not get there for Beta
> unless there are relevant freeze exception bugs:
> 
> https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process
> 
> so if the fixes in those updates are to critical functionality (it kinda
> sounds like they are), this and/or other bugs should be nominated as
> BetaFreezeException.
> 
> Right now this report seems to be a bit of a confused jumble of issues
> affecting different people and components and fixed in different updates. It
> would make things clearer, perhaps, if the issues were separated from each
> other.
> 
> I'll nominate this bug as BetaFreezeException for the crash initially
> reported by 'atlee', expected to be fixed by
> https://admin.fedoraproject.org/updates/FEDORA-2013-7963/cinnamon-1.8.2-4.
> fc19,nemo-1.8.1-2.fc19 . If the issue fixed by
> https://admin.fedoraproject.org/updates/muffin-1.8.1-2.fc19 is also
> critical, it would be best to have a separate report for that bug, marked as
> being fixed by that update, and also nominated as BetaFreezeException.

Hi Adam,

muffin-1.8.1-2.fc19 is critical, it fixes the panel freeze/crash cause by drag n drop on any app.
Comment 25 Adam Williamson 2013-05-14 17:36:32 EDT
leigh: in that case, as I said, can you separate that bug out into another report, and mark that one as BetaFreezeException too? It makes it much simpler to keep track of things if there's one bug report per bug and one update per bug report.
Comment 26 leigh scott 2013-05-14 18:16:00 EDT
(In reply to comment #25)
> leigh: in that case, as I said, can you separate that bug out into another
> report, and mark that one as BetaFreezeException too? It makes it much
> simpler to keep track of things if there's one bug report per bug and one
> update per bug report.

Will this do?

https://bugzilla.redhat.com/show_bug.cgi?id=962989
Comment 27 Adam Williamson 2013-05-15 19:34:33 EDT
Discussed at 2013-05-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Accepted as a freeze exception bug as a major issue in a non-blocking (but shipped) desktop.
Comment 28 Fedora Update System 2013-05-16 01:23:00 EDT
nemo-1.8.1-2.fc19, cinnamon-1.8.2-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.