Bug 962385 - Update Networking to 2013.1.2 stable/grizzly
Update Networking to 2013.1.2 stable/grizzly
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 3.0
Assigned To: Terry Wilson
yfried
: Rebase, Triaged
: 972360 972701 (view as bug list)
Depends On: 972701
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 06:35 EDT by Gary Kotton
Modified: 2016-04-26 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.2-1.el6ost
Doc Type: Rebase: Bug Fixes Only
Doc Text:
Rebase package(s) to version: 2013.1.2 Highlights, important fixes, or notable enhancements: https://wiki.openstack.org/wiki/ReleaseNotes/2013.1.2
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 13:15:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1080846 None None None Never
Launchpad 1171727 None None None Never
Launchpad 1172922 None None None Never
Launchpad 1173463 None None None Never
Launchpad 1176570 None None None Never
Launchpad 1178003 None None None Never
Launchpad 1178419 None None None Never

  None (edit)
Description Gary Kotton 2013-05-13 06:35:29 EDT
Description of problem:
Since the last freeze there are a number of additional patches that need to be backported:
https://review.openstack.org/#/c/28146/
https://review.openstack.org/#/c/28350/
https://review.openstack.org/#/c/28352/
https://review.openstack.org/#/c/28353/
https://review.openstack.org/#/c/28408/
https://review.openstack.org/#/c/28699/
https://review.openstack.org/#/c/28772/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Alan Pevec 2013-06-06 10:56:45 EDT
Above patches are all merged to upstream stable/grizzly and should be picked up in 2013.1.2 rebase
Comment 4 yfried 2013-06-10 01:49:38 EDT
TO TERRY: I got latest puddle (2013-06-07.1) and the version is openstack-quantum-2013.1.1-10.el6ost

where do i get the "fixed in" version, to verify the bug?
(openstack-quantum-2013.1.2-1.el6ost)
Comment 6 Alan Pevec 2013-06-10 06:46:59 EDT
git log 2013.1.1..2013.1.2

f431117 Enable quantum-netns-cleanup to receive force as cli parameter
    Reviewed-on: https://review.openstack.org/29905
1359767 relax amqplib and kombu version requirements
    Reviewed-on: https://review.openstack.org/28504
e88a22f Add l3 attribute to network
    Reviewed-on: https://review.openstack.org/29686
db36434 Add _usr variants for iptables rootwraps
    Reviewed-on: https://review.openstack.org/29645
3339f96 Add support for dnsmasq version 2.48
    Reviewed-on: https://review.openstack.org/29630
120c166 Log a warning if dnsmasq version is below the minimum required
    Reviewed-on: https://review.openstack.org/29631
bc8e9f9 Allow admin to delete default security groups
    Reviewed-on: https://review.openstack.org/29150
c7a02b2 get_security_groups now creates default security group
    Reviewed-on: https://review.openstack.org/29146
b2c658c make default transport type configurable nvp
    Reviewed-on: https://review.openstack.org/29142
cd102c3 Correct NVP plugin path for folsom to grizzly migration
    Reviewed-on: https://review.openstack.org/29126
c9f640a update-port error if port does not exist in nvp
    Reviewed-on: https://review.openstack.org/28936
e97fdc4 Don't run metadata proxy when it is not needed
    Reviewed-on: https://review.openstack.org/28938
cd06e21 Fetch routers ports for metadata access from DB
    Reviewed-on: https://review.openstack.org/28937
83eae03 Change Daemon class to better match process command lines.
    Reviewed-on: https://review.openstack.org/28934
59410e6 Fix 500 raised on disassociate_floatingips when out of sync
    Reviewed-on: https://review.openstack.org/28933
cee43fb Validate that netaddr does not receive a string with whitespace
    Reviewed-on: https://review.openstack.org/28507
d1f1217 Add kill-metadata rootwrap filter to support RHEL.
    Reviewed-on: https://review.openstack.org/28772
a2e24d0 Bump stable/grizzly next version to 2013.1.2
    Reviewed-on: https://review.openstack.org/28740
1841ea5 in dhcp_agent, always use quantum.conf root_helper
    Reviewed-on: https://review.openstack.org/28699
6b5c713 Create veth peer in namespace.
    Reviewed-on: https://review.openstack.org/28408
aabb62f Duplicate line in Brocade plugin
    Reviewed-on: https://review.openstack.org/28353
abf3288 Treat unbound port
    Reviewed-on: https://review.openstack.org/28352
5a86b4e OSLO updates for stable
    Reviewed-on: https://review.openstack.org/28350
7addf41 Do not attempt to kill already-dead dnsmasq
    Reviewed-on: https://review.openstack.org/28146
Comment 9 yfried 2013-06-19 03:30:19 EDT
version
openstack-quantum-2013.1.2-3.el6ost.noarch
openstack-nova-api-2013.1.2-2.el6ost.noarch
openstack-nova-compute-2013.1.2-2.el6ost.noarch
qpid-cpp-server-0.14-22.el6_3.x86_64

bug:

1172922 - still exists - changing password in nova.conf and counting open qpid session (port 5672) shows a rise in open sessions (netstat -n |grep 5672) that stops only when stopping the nova command (ie - "boot"). some sessions only close when password is restored

rest of the issues - verified
Comment 10 Gary Kotton 2013-06-19 06:30:42 EDT
Why in nova conf? This is Quantum. Please clarify.Thanks
Gary
Comment 11 yfried 2013-06-19 09:38:22 EDT
(In reply to yfried from comment #9)
> version
> openstack-quantum-2013.1.2-3.el6ost.noarch
> openstack-nova-api-2013.1.2-2.el6ost.noarch
> openstack-nova-compute-2013.1.2-2.el6ost.noarch
> qpid-cpp-server-0.14-22.el6_3.x86_64
> 
> bug:
> 
> 1172922 - still exists - changing password in nova.conf and counting open
> qpid session (port 5672) shows a rise in open sessions (netstat -n |grep
> 5672) that stops only when stopping the nova command (ie - "boot"). some
> sessions only close when password is restored
> 
> rest of the issues - verified

1172922 - solved in quantum.conf but not in nova
Comment 12 Alan Pevec 2013-06-19 10:01:18 EDT
> 1172922 - solved in quantum.conf but not in nova

Please open RHOS openstack-nova rhbz for this, upstream stable review is https://review.openstack.org/33476
Comment 13 Perry Myers 2013-06-19 15:41:18 EDT
*** Bug 972360 has been marked as a duplicate of this bug. ***
Comment 14 Perry Myers 2013-06-19 15:41:25 EDT
*** Bug 972701 has been marked as a duplicate of this bug. ***
Comment 15 Alan Pevec 2013-06-19 15:44:09 EDT
nova bug 975882
Comment 17 errata-xmlrpc 2013-06-27 13:15:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.