Bug 962394 - [xfsprogs] Update xfs_io man page to include chproj, lsproj and setfl
[xfsprogs] Update xfs_io man page to include chproj, lsproj and setfl
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsprogs (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Eric Sandeen
Boris Ranto
:
Depends On:
Blocks: 968426
  Show dependency treegraph
 
Reported: 2013-05-13 06:51 EDT by Boris Ranto
Modified: 2013-11-21 16:19 EST (History)
3 users (show)

See Also:
Fixed In Version: xfsprogs-3.1.1-11.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 968426 (view as bug list)
Environment:
Last Closed: 2013-11-21 16:19:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1657 normal SHIPPED_LIVE xfsprogs bug fix update 2013-11-20 16:53:13 EST

  None (edit)
Description Boris Ranto 2013-05-13 06:51:30 EDT
Description of problem:
Please, update xfs_io man page to include documentation for the following commands:
chproj
lsproj
setfl

Version-Release number of selected component (if applicable):
xfsprogs-3.1.1-10.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run xfstests test no. 293 that checks for this behaviour.
2.
3.
  
Actual results:
The test fails reporting the missing documentation for the threee commands.

Expected results:
The commands are documented.

Additional info:
The test case seems to be written by Eric Sandeen. Hence, I searched the bugzilla for a similar report. However, I didn't find any RHEL 6 report for this lack of documentation.

xfs_io -c help already provides basic documentation for the three commands:

chproj [-D | -R] projid -- change project identifier on the currently open file
lsproj [-D | -R] -- list project identifier set on the currently open file
setfl [-adx] -- set/clear append/direct flags on the open file
Comment 1 Eric Sandeen 2013-05-13 12:57:08 EDT
commit 83c324088f8e60133016409752b08f74e19e8b37
Author: Eric Sandeen <sandeen@sandeen.net>
Date:   Sat Dec 8 20:55:18 2012 +0000

    xfsprogs: document all commands in xfs_io
    
    Add missing command documentation to xfs_io(8) manpage.
    fiemap, fpunch, chproj, lsproj, and setfl are all missing.
    
    setfl seems to not work today in any case, and nothing
    in xfstests uses it; I will send another patch to simply
    remove it from xfs_io, as I don't think it's terribly useful,
    and hasn't worked forever anyway.
    
    Also fix references to the fallocate manpage, which is (now?)
    in section 2, not section 3 of the man pages.  (Since it's
    a syscall, not a library function).
    
    Signed-off-by: Eric Sandeen <sandeen@sandeen.net>

commit 618e842d3553d24e7ba2c740a080ab6f972868c6
Author: Eric Sandeen <sandeen@sandeen.net>
Date:   Sat Dec 8 21:03:10 2012 +0000

    xfsprogs: remove setfl from xfs_io
    
    Doesn't seem to have worked for ages, and is (therefore)
    apparently not ever used:
    
    xfs_io> setfl
    xfs_io> help setfl
    setfl [-adx] -- set/clear append/direct flags on the open file
    xfs_io> setfl -a
    bad argument count 1 to setfl, expected 0 arguments
    xfs_io> setfl -d
    bad argument count 1 to setfl, expected 0 arguments
    xfs_io> setfl
    xfs_io>
    
    At best, it seems intended to toggle the flag state, but
    gives no feedback about current state.  -x is in help but
    not implemented, etc.
    
    Just remove it.
    
    Signed-off-by: Eric Sandeen <sandeen@redhat.com>
    Reviewed-by: Carlos Maiolino <cmaiolino@redhat.com>
    Signed-off-by: Mark Tinguely <tinguely@sgi.com>


If we are allowed to update xfsprogs in 6.5 it'd be easy to include these 2 commits.
Comment 8 errata-xmlrpc 2013-11-21 16:19:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1657.html

Note You need to log in before you can comment on or make changes to this bug.