Bug 968426 - [xfsprogs] Update xfs_io man page to include chproj, lsproj and setfl - rhel5
[xfsprogs] Update xfs_io man page to include chproj, lsproj and setfl - rhel5
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xfsprogs (Show other bugs)
5.10
All Linux
low Severity low
: rc
: ---
Assigned To: Eric Sandeen
Filesystem QE
:
Depends On: 962394
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 13:24 EDT by Eryu Guan
Modified: 2014-01-24 10:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962394
Environment:
Last Closed: 2014-01-24 10:02:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2013-05-29 13:24:18 EDT
clone for rhel5

+++ This bug was initially created as a clone of Bug #962394 +++

Description of problem:
Please, update xfs_io man page to include documentation for the following commands:
chproj
lsproj
setfl

Version-Release number of selected component (if applicable):
xfsprogs-3.1.1-10.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run xfstests test no. 293 that checks for this behaviour.
2.
3.
  
Actual results:
The test fails reporting the missing documentation for the threee commands.

Expected results:
The commands are documented.

Additional info:
The test case seems to be written by Eric Sandeen. Hence, I searched the bugzilla for a similar report. However, I didn't find any RHEL 6 report for this lack of documentation.

xfs_io -c help already provides basic documentation for the three commands:

chproj [-D | -R] projid -- change project identifier on the currently open file
lsproj [-D | -R] -- list project identifier set on the currently open file
setfl [-adx] -- set/clear append/direct flags on the open file

--- Additional comment from Eric Sandeen on 2013-05-13 12:57:08 EDT ---

commit 83c324088f8e60133016409752b08f74e19e8b37
Author: Eric Sandeen <sandeen@sandeen.net>
Date:   Sat Dec 8 20:55:18 2012 +0000

    xfsprogs: document all commands in xfs_io
    
    Add missing command documentation to xfs_io(8) manpage.
    fiemap, fpunch, chproj, lsproj, and setfl are all missing.
    
    setfl seems to not work today in any case, and nothing
    in xfstests uses it; I will send another patch to simply
    remove it from xfs_io, as I don't think it's terribly useful,
    and hasn't worked forever anyway.
    
    Also fix references to the fallocate manpage, which is (now?)
    in section 2, not section 3 of the man pages.  (Since it's
    a syscall, not a library function).
    
    Signed-off-by: Eric Sandeen <sandeen@sandeen.net>

commit 618e842d3553d24e7ba2c740a080ab6f972868c6
Author: Eric Sandeen <sandeen@sandeen.net>
Date:   Sat Dec 8 21:03:10 2012 +0000

    xfsprogs: remove setfl from xfs_io
    
    Doesn't seem to have worked for ages, and is (therefore)
    apparently not ever used:
    
    xfs_io> setfl
    xfs_io> help setfl
    setfl [-adx] -- set/clear append/direct flags on the open file
    xfs_io> setfl -a
    bad argument count 1 to setfl, expected 0 arguments
    xfs_io> setfl -d
    bad argument count 1 to setfl, expected 0 arguments
    xfs_io> setfl
    xfs_io>
    
    At best, it seems intended to toggle the flag state, but
    gives no feedback about current state.  -x is in help but
    not implemented, etc.
    
    Just remove it.
    
    Signed-off-by: Eric Sandeen <sandeen@redhat.com>
    Reviewed-by: Carlos Maiolino <cmaiolino@redhat.com>
    Signed-off-by: Mark Tinguely <tinguely@sgi.com>


If we are allowed to update xfsprogs in 6.5 it'd be easy to include these 2 commits.
Comment 1 Eric Sandeen 2014-01-24 10:02:26 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification. Issue is already fixed in RHEL-6/7.

Note You need to log in before you can comment on or make changes to this bug.