Bug 962418 - Backport of HHH-6813 to EAP 6.0.1
Backport of HHH-6813 to EAP 6.0.1
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: One-off release
Assigned To: Martin Simka
Martin Simka
:
Depends On:
Blocks: 962421
  Show dependency treegraph
 
Reported: 2013-05-13 08:25 EDT by Adam Kovari
Modified: 2015-08-31 23:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
PATCH NAME: bz-962418 PRODUCT NAME: JBoss EAP VERSION: 6.0.1 SHORT DESCRIPTION: EAP 6.0.1 - Backport of HHH-6813 - @Id @OneToOne cause NullPointerException during query LONG DESCRIPTION: EAP 6.0.1 Backport of HHH-6813 to EAP 6.0.1 @Id @OneToOne cause NullPointerException during query https://hibernate.atlassian.net/browse/HHH-6813 MANUAL INSTALL INSTRUCTIONS: Backup and remove the following files: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml Extract the patched files by either: Using unzip: unzip -d $JBOSS_HOME/ bz-962418.zip Or by extracting the files from the zip to the following locations: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3-bz-962418.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml Instructions to uninstall: Restore the following files that were backed up before the patch was installed: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml COMPATIBILITY: None DEPENDENCIES: JBoss EAP 6.0.1 SUPERSEDES: None SUPERSEDED BY: JBoss EAP 6.2.0 CREATOR: Brett Meyer DATE: 13th May 2013
Story Points: ---
Clone Of:
: 962421 (view as bug list)
Environment:
Last Closed: 2013-06-17 13:35:05 EDT
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patched hibernate module (3.85 MB, application/download)
2013-05-13 17:02 EDT, Brett Meyer
no flags Details
patched hibernate module (3.85 MB, application/download)
2013-05-17 12:30 EDT, Brett Meyer
no flags Details
patched hibernate module (3.85 MB, application/zip)
2013-05-20 11:48 EDT, Brett Meyer
no flags Details
bz-962418.zip (3.85 MB, application/octet-stream)
2013-06-07 18:31 EDT, Brad Maxwell
no flags Details

  None (edit)
Description Adam Kovari 2013-05-13 08:25:19 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Brett Meyer 2013-05-13 17:01:27 EDT
PATCH NAME:
        BZ-962418
PRODUCT NAME:
        JBoss Enterprise Application Server
VERSION:
        6.0.1
SHORT DESCRIPTION:
        EAP 6.0.1  Backport of HHH-6813 to EAP 6.0.1
        
LONG DESCRIPTION:
        EAP 6.0.1  Backport of HHH-6813 to EAP 6.0.1

        @Id @OneToOne cause NullPointerException during query
        https://hibernate.atlassian.net/browse/HHH-6813

MANUAL INSTALL INSTRUCTIONS:
        
         Backup and remove the following files:
            
            $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final.jar
            $JBOSS_HOME/modules/org/hibernate/main/module.xml
                   
        Extract the patched files by either:
        
        Using unzip:
            unzip -d $JBOSS_HOME/ BZ-962418.zip
            
        Or by extracting the files from the zip to the following locations:
         
            $JBOSS_HOME/modules/org/hibernate/main/hibernate-core_BZ-962418_4.1.6.Final.jar
            $JBOSS_HOME/modules/org/hibernate/main/module.xml

COMPATIBILITY:
        None
DEPENDENCIES:
        JBoss EAP 6.0.1
SUPERSEDES:
        None
SUPERSEDED BY:
        JBoss EAP 6.1.0
CREATOR:
        Brett Meyer
DATE:
        13th May 2013
Comment 2 Brett Meyer 2013-05-13 17:02:05 EDT
Created attachment 747444 [details]
patched hibernate module
Comment 3 Adam Kovari 2013-05-14 05:17:00 EDT
Hey Brett,

the module.xml needs to have:
 29         <resource-root path="hibernate-entitymanager-4.1.6.Final-redhat-3.jar"/>
 30         <resource-root path="hibernate-infinispan-4.1.6.Final-redhat-3.jar"/>

Otherwise, it works for me.
Comment 4 Brett Meyer 2013-05-14 23:44:44 EDT
Reopening – found an additional issue causing a stackoverflow
Comment 5 Brett Meyer 2013-05-17 12:30:42 EDT
Created attachment 749415 [details]
patched hibernate module
Comment 6 Brett Meyer 2013-05-17 12:31:17 EDT
Corrected -- ready for QA
Comment 7 Brett Meyer 2013-05-20 11:48:39 EDT
Created attachment 750637 [details]
patched hibernate module
Comment 8 Brad Maxwell 2013-06-07 18:31:18 EDT
Created attachment 758350 [details]
bz-962418.zip
Comment 9 Martin Simka 2013-06-11 04:35:55 EDT
EAP test suite is without regression
Hibernate test suite is without regression
Issue was verified using reproducer supplied by customer

QA passed

MD5 sum for the tested file:
4663c95b0a5290c75fb8877c87c7b9a2  hibernate-core-4.1.6.Final-redhat-3-bz-962418.jar
213e76c300d18dcbbc51b4428225b1bc  module.xml
Comment 10 Adam Kovari 2013-06-14 04:56:51 EDT
The instructions have an error:

SUPERSEDED BY:
        JBoss EAP 6.1.0

is not true, EAP 6.1.0 still contains the bug and the plan is to have this fixed in 6.2.0.
Comment 11 Martin Simka 2013-06-14 05:07:00 EDT
thanks Adam, my fault, I didn't notice

Note You need to log in before you can comment on or make changes to this bug.