Bug 962421 - Permanent fix for HHH-6813 in EAP 6
Permanent fix for HHH-6813 in EAP 6
Status: CLOSED DUPLICATE of bug 981720
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.0.1
Unspecified Unspecified
urgent Severity urgent
: ER3
: EAP 6.1.1
Assigned To: Brett Meyer
:
Depends On: 962418
Blocks: 979103
  Show dependency treegraph
 
Reported: 2013-05-13 08:29 EDT by Adam Kovari
Modified: 2015-09-01 00:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962418
Environment:
Last Closed: 2013-08-29 14:01:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Kovari 2013-05-13 08:29:20 EDT
Permanent fix for HHH-6813 in EAP 6
@Id @OneToOne cause NullPointerException during query - https://hibernate.atlassian.net/browse/HHH-6813
Comment 1 Brett Meyer 2013-05-13 16:39:18 EDT
Pushed to the eap61-cp-updates branch:  http://git.app.eng.bos.redhat.com/?p=hibernate/hibernate-core.git;a=shortlog;h=refs/heads/eap61-cp-updates
Comment 2 Brett Meyer 2013-05-14 23:44:50 EDT
Reopening – found an additional issue causing a stackoverflow
Comment 3 Brett Meyer 2013-05-17 12:45:04 EDT
Additional fix pushed
Comment 13 Martin Simka 2013-08-06 09:02:20 EDT
the fix is in Hibernate ORM 4.2.0.SP1 (BZ981720)
verified on EAP 6.1.1.ER3 and verified again on EAP 6.1.1.ER4 jtbs
Comment 14 Brett Meyer 2013-08-29 14:01:01 EDT
As we did with 979098, closing this and marking as duplicate.  Release notes will go on 979098.  Sorry for having it QA'd already.  If this is incorrect, please say so.

*** This bug has been marked as a duplicate of bug 981720 ***

Note You need to log in before you can comment on or make changes to this bug.