Bug 962485 - Cannot skip past a network error when installing
Cannot skip past a network error when installing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 11:48 EDT by Jean-Pierre André
Modified: 2013-05-18 00:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 00:54:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Pierre André 2013-05-13 11:48:16 EDT
Description of problem:

Cannot skip past a network error when installing

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Boot on a Fedora 19 (alpha) live-dvd
2. Select your language when requested
3. Configure the network (WiFi)
  
Actual results:

a) The configure button has no effect
b) You can select a network in the drop-down menu, but this triggers an error.
c) You can either quit the installation or report the bug.
d) Guess what : reporting the bug fails because the network is not configured.
e) No way to proceed with the installation

Expected results:

a) The error should happen, but that is probably not related to anaconda, and this is an alpha release anyway.
b) There should be a possibility to not report the bug (or delay it) and proceed with the installation. And anaconda has something to do with it.

Additional info:

The original error is unclear to me. At this stage there is no possibility to save anything to a file (no permanent file system is configured).
Comment 1 Jean-Pierre André 2013-05-13 11:51:34 EDT
Expected results: please read "a) The error should NOT happen, but that is probably not related to anaconda, and this is an alpha release anyway."
Comment 2 Radek Vykydal 2013-05-14 08:11:14 EDT
I am not able to reproduce the bug so I'd need details on the error you are seeing and log files. They can be found in /tmp directory, /tmp/anaconda-tb-* file should contain all informations we need. Could you please attach the file to the report? You can copy the file to USB or try to set up network connection in live environment (instead of anaconda). Thanks.
Comment 3 Radek Vykydal 2013-05-14 08:41:06 EDT
This issue will be probably fixed by not requiring network connection in installer on Live DVD (skipping the network configuration screen). The connection can be established in Live environment itself if needed.
Comment 4 Jean-Pierre André 2013-05-14 10:58:37 EDT
First, I have to correct one point : this was not with a live-dvd, but with the full installation dvd for fedora 19 alpha.

Then I discovered I could skip this screen without configuring anything at all, but I get trapped later, probably for the same reason (unrelated to anaconda and reported as a network manager bug 962827).

Back to anaconda, I think I should have an official way to skip past a network error with only shows the two possibilities to report (impossible in this case) and to quit. There is a possibility to start a debug process, but I am far from being able to get anything useful from it.

Now, getting the files you want seems to me an impossible task. This is the second screen of installing. How could I start a shell, and mount some permanent device to which copy files from the ramdisk or configure the network ? Well, I finally got this step through, but, doing so I have no error logged.
Comment 5 Radek Vykydal 2013-05-15 04:46:14 EDT
(In reply to comment #4)
 
> Back to anaconda, I think I should have an official way to skip past a
> network error with only shows the two possibilities to report (impossible in
> this case) and to quit. There is a possibility to start a debug process, but
> I am far from being able to get anything useful from it.
> 

Only fatal errors (crashes) should trigger bug reporting dialog in Anaconda. Network connection fail doesn't belong among them. Nevertheless, to investigate why the crash happened I need the log files.

> Now, getting the files you want seems to me an impossible task. This is the
> second screen of installing. How could I start a shell, and mount some
> permanent device to which copy files from the ramdisk or configure the
> network ? Well, I finally got this step through, but, doing so I have no
> error logged.

You can switch to shell on tty2 (Ctrl-Alt F2) and copy files to USB disk (if possible). The hint to configure network assumed you are in Live environment which is not the case as showed up.
Comment 6 Jean-Pierre André 2013-05-15 10:53:47 EDT
> Only fatal errors (crashes) should trigger bug reporting dialog in Anaconda

This is probably what happens : the issue cannot be a failed network connection (because the network is not even configured, no SSID defined, etc.), but more likely results from a crash while initializing the network driver (similar to the bug reported as bug 962827).

Better try again when this other issue is solved, and I take note of the tty2 suggestion.
Comment 7 Fedora Update System 2013-05-15 18:25:00 EDT
anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
Comment 8 Fedora Update System 2013-05-16 01:21:21 EDT
Package anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.27-1.fc19 pykickstart-1.99.31-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-05-17 18:18:52 EDT
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-05-18 00:54:47 EDT
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.