Bug 962600 - in text mode install, filesystem choice has no default
in text mode install, filesystem choice has no default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 22:17 EDT by Andre Robatino
Modified: 2013-05-18 00:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 00:54:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of 19 Beta TC4 text install, "Install Destination" spoke (13.60 KB, image/png)
2013-05-13 22:17 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2013-05-13 22:17:43 EDT
Created attachment 747485 [details]
screenshot of 19 Beta TC4 text install, "Install Destination" spoke

Description of problem:
As of 19 Beta TC4, during a text install, under the "Installation Destination" spoke, the choice of filesystem has no default (screenshot attached). In a graphical install, LVM is the default.

Version-Release number of selected component (if applicable):
anaconda-19.25-1
Comment 1 Samantha N. Bueno 2013-05-14 08:23:00 EDT
If a filesystem isn't selected, installation will automatically default to using LVM (as in the graphical install).

That is completely non-obvious to users though, so you're right, and LVM should be selected from the outset to be consistent with graphical behavior.
Comment 2 Samantha N. Bueno 2013-05-14 08:43:24 EDT
Patch posted to anaconda-patches list.
Comment 3 Samantha N. Bueno 2013-05-14 09:57:20 EDT
Patch pushed, commit 2a35b969b2312d8a994def92cc8a91369416de87
Comment 4 Fedora Update System 2013-05-15 18:25:04 EDT
anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
Comment 5 Fedora Update System 2013-05-16 01:21:26 EDT
Package anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.27-1.fc19 pykickstart-1.99.31-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
then log in and leave karma (feedback).
Comment 6 Andre Robatino 2013-05-17 05:36:23 EDT
Was not able to test 19 Beta RC1 (anaconda 19.27-1) due to boot issue. In 19 Beta RC2 (anaconda 19.28-1) I can confirm that the LVM box is checked by default, however I also saw bug 964069 (Anaconda creates native partition in text mode if LVM or btrfs is selected) when I chose the default LVM.
Comment 7 Fedora Update System 2013-05-17 18:18:57 EDT
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-05-18 00:54:52 EDT
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.