Bug 962610 - [RFE]Enable functionality "install" and "install-plugin" for edit-node
[RFE]Enable functionality "install" and "install-plugin" for edit-node
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
: 1035226 (view as bug list)
Depends On: 976342
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 23:02 EDT by haiyang,dong
Modified: 2014-01-21 14:33 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Install and install-plugin options are now enabled in edit-node.They are now enabled to provide the ability to install plugins or other necessary packages by end users
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:33:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-05-13 23:02:43 EDT
Description of problem:
Right now, rhev-h 6.4 disables functionality :
--install
--install-plugin
for edit-node.

According to https://bugzilla.redhat.com/show_bug.cgi?id=928595#c1, so it's better that support 
functionality "install" and "install-plugin" for edit-node in rhev-h 6.5

Version-Release number of selected component (if applicable):
ovirt-node-tools-2.5.0-17.el6_4.4.noarch.rpm

How reproducible:
100% 
 
Steps to Reproduce:


Actual result:          
                                                  
Expect result:


Additional info:
Comment 8 haiyang,dong 2013-08-08 05:00:27 EDT
Test version:
ovirt-node-tools-3.0.0-6.1.el6.noarch
rhev-hypervisor6-6.5-20130725.0.el6 
ovirt-node-3.0.0-6.1.el6
ovirt-node-plugin-puppet-3.0.0-6.1.el6.noarch.rpm


Tested as follows:
1.edit-node --repo=edit-node.repo --install=ovirt-node-plugin-puppet-3.0.0-6.1.el6.noarch.rpm rhevh-6.5-20130725.0.el6.iso

2.edit-node --repo=edit-node.repo --install-plugin=ovirt-node-plugin-puppet-3.0.0-6.1.el6.noarch.rpm rhevh-6.5-20130725.0.el6.iso

Install plugin "puppet" into rhevh-6.5-20130725.0.el6.iso successfully.

so this bug has been fixed, change the status into "VERIFIED".
Comment 11 Cheryn Tan 2013-11-07 19:30:06 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 haiyang,dong 2013-11-28 22:01:50 EST
*** Bug 1035226 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2014-01-21 14:33:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.