Bug 962699 - gnome initial setup does not list Indic input methods by default
gnome initial setup does not list Indic input methods by default
Status: CLOSED DUPLICATE of bug 928645
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jasper St. Pierre
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 05:35 EDT by anish
Modified: 2015-04-12 19:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 00:44:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Input sources window shows indian as input sources (15.29 KB, image/png)
2013-05-15 05:33 EDT, anish
no flags Details

  None (edit)
Description anish 2013-05-14 05:35:12 EDT
Description of problem:
After selection of Indian languages, input sources screen shows only "Indian" and it does not show list of available input methods associated with that language.

e.g After selection of "Bengali" language in g-i-s, in Input sources window shows input sources as "Indian" which is wrong because Bengali is been used in Bangladesh as well as in India.
It does not show list of available input methods available for that language,to choose input method you need to select it from bar at the bottom.


Version-Release number of selected component (if applicable):



Steps to Reproduce:
1.Start gnome initial setup
2. Choose "Bengali"  language
3: Go to Select Input sources 
  
Actual results:
List of input methods associated with Bengali language should appear

Expected results:
Input method named "Indian" appears
Comment 1 anish 2013-05-14 05:41:24 EDT
> 3: Go to Select Input sources 
>   
> Actual results:
> List of input methods associated with Bengali language should appear
> 
> Expected results:
> Input method named "Indian" appears


Actual results:
Input method named "Indian" appears

Expected results:
List of input methods associated with Bengali language should appear
Comment 2 Jens Petersen 2013-05-15 04:48:08 EDT
Can you add a screenshot?
Comment 3 anish 2013-05-15 05:33:16 EDT
Created attachment 748163 [details]
Input sources window shows indian as input sources

Screenshot also list itrans input method because i had installed this input method using g-i-s.Otherwise on a fresh installation g-i-s shows Indian as input source name.
Comment 4 Parag Nemade 2013-05-15 09:50:33 EDT
This is a anaconda issue.
Comment 5 Jens Petersen 2013-05-15 21:18:28 EDT
I assume "Indian" is the xkb India (in) layout.

I think missing IMEs is just bug 928645.

I am surprised itrans is listed while not inscript.

Parag??
Comment 6 Parag Nemade 2013-05-16 01:14:01 EDT
Actually here the original problem is from Anaconda and not at all related to g-i-s. Yesterday I tried to look into this problem and found that anaconda's keyboard spoke class uses pyanaconda's keyboard.py which have all the functions for xkb layout list that uses wrapper for libxklavier.

In summary, Some logic is causing "Marathi" language to be mapped to "Indian" layout. Rest Indic languages uses correct keymaps.
Comment 7 Mike FABIAN 2013-05-16 02:05:31 EDT
(In reply to comment #5)
> I assume "Indian" is the xkb India (in) layout.

Yes.

> I am surprised itrans is listed while not inscript.

Anish added “itrans” manually (see comment#3).
Comment 8 Jens Petersen 2013-05-16 03:21:27 EDT
(In reply to comment #6)
> In summary, Some logic is causing "Marathi" language to be mapped to
> "Indian" layout. Rest Indic languages uses correct keymaps.

Only Marathi?  And Bengali?(In reply to comment #7)

> (In reply to comment #5)
> Anish added “itrans” manually (see comment#3).

Ah right nod thanks - I was struggling to parse "installed".
Comment 9 Jens Petersen 2013-05-16 04:03:28 EDT
I am pretty sure that the main IME part of this bug is just a duplicate of bug 928645 - so please test - except RC1 net install seems to backtrace for me currently.

Please file a separate bug against anaconda (or langtable)
if you see issues with the xkb layouts setup.
Comment 10 Parag Nemade 2013-05-16 05:42:42 EDT
Jens,
  Finally got fresh f19 Beta TC4 installed. Here is what I did.

1) Used Marathi language in anaconda which picks "Indian" named keymap.
2) Installed Gnome Desktop Environment.
3) g-i-s started in Marathi
4) selected again Marathi language in g-i-s and finished its setup.

Observations on 4th step:- g-i-s when selected Marathi language, input sources step did not show default m17n keymap for Marathi but showed "English" and "Indian" keymaps.

So yes this can be duplicate of bug 928645. 

Now about this bug, using this setup tried to reproduce the bug using steps in comment#0
Choosing "Bengali" language did not show default Bengali m17n keymap (Which is again bug 928645), but it showed "English" and "Indian" which looks ok.
Comment 11 Jens Petersen 2013-05-16 05:49:52 EDT
Rui says g-i-s should now setup IMEs (Input Sources) following
https://git.gnome.org/browse/gnome-desktop/tree/libgnome-desktop/default-input-sources.h .
Comment 12 anish 2013-05-16 06:15:47 EDT
> Choosing "Bengali" language did not show default Bengali m17n keymap (Which
> is again bug 928645), but it showed "English" and "Indian" which looks ok.

Bengali is used in India and Bangladesh, i think showing Indian option is wrong here
Comment 13 Jens Petersen 2013-05-17 00:38:34 EDT
> Bengali is used in India and Bangladesh, i think showing Indian option is
> wrong here

The basic name (India) comes from xorg (xkeyboard-config)
and is then tranformed by gnome to Indian I think.
Defaulting to "India" keyboard is correct, but I don't
like the "friendly" change from India -> Indian
(US -> English, etc) - actually I would say again
it is wrong - but that is a separate issue/discussion
that is needed upstream.
Comment 14 Jens Petersen 2013-05-17 00:44:58 EDT
I tested new Hindi user and got inscript IME defined by default by g-i-s.

*** This bug has been marked as a duplicate of bug 928645 ***
Comment 15 Parag Nemade 2013-05-17 01:07:50 EDT
(In reply to comment #13)
> > Bengali is used in India and Bangladesh, i think showing Indian option is
> > wrong here
> 
> The basic name (India) comes from xorg (xkeyboard-config)
> and is then tranformed by gnome to Indian I think.

You can easily check Indian appears the moment you choose a Indic language where no xkb keymap is available for that language (Note I said language not script) in anaconda.

> Defaulting to "India" keyboard is correct, but I don't
> like the "friendly" change from India -> Indian
> (US -> English, etc) - actually I would say again
> it is wrong - but that is a separate issue/discussion
> that is needed upstream.

Right. This is not a g-i-s issue.
Comment 16 Mike FABIAN 2013-05-17 03:35:42 EDT
(In reply to comment #13)

> The basic name (India) comes from xorg (xkeyboard-config)
> and is then tranformed by gnome to Indian I think.
> Defaulting to "India" keyboard is correct, but I don't
> like the "friendly" change from India -> Indian
> (US -> English, etc) - actually I would say again
> it is wrong - but that is a separate issue/discussion
> that is needed upstream.

No, “Indian” is already in xkeyboard-config:

$ grep -C 5 Indian /usr/share/X11/xkb/rules/evdev.xml 
    <layout>
      <configItem>
        <name>in</name>
        
        <shortDescription>in</shortDescription>
        <description>Indian</description>
      </configItem>
      <variantList>
        <variant>
          <configItem>
            <name>ben</name>

Note You need to log in before you can comment on or make changes to this bug.