Bug 928645 - IMEs no longer automatically configured for needed languages in F19 GNOME
Summary: IMEs no longer automatically configured for needed languages in F19 GNOME
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rui Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 956458 958716 962699 (view as bug list)
Depends On:
Blocks: F19Beta-accepted, F19BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-03-28 06:47 UTC by Mike FABIAN
Modified: 2014-02-21 06:18 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-21 06:18:03 UTC
Type: Bug


Attachments (Terms of Use)
gnome-initial-setup-input-sources-list-empty-at-the-beginning.png (687.42 KB, image/png)
2013-03-28 06:47 UTC, Mike FABIAN
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 696754 0 None None None Never

Description Mike FABIAN 2013-03-28 06:47:14 UTC
Created attachment 717457 [details]
gnome-initial-setup-input-sources-list-empty-at-the-beginning.png

- Install Fedora-19-Alpha-TC2-x86_64-DVD.iso in qemu.

  Commandline used for qemu was:

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 1 -drive file=./Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2-output.log -name Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-19-Alpha-TC2/Fedora-19-Alpha-TC2-x86_64-DVD.iso -boot c -vga std -display vnc=:4 -net nic -net user,hostname=Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,hostfwd=tcp::5560-:22 -monitor stdio -usb

- Select Japanese
- Select to install on whole disk
- Select Timezone
- Select default Gnome install
- continue with installation

after the first reboot, gnome-initial-setup shows up.

The list of input sources is initially empty, I think
there should be a keyboard and a Japanese input method already
by default.

See attached screen shot.

Comment 1 Jens Petersen 2013-05-02 07:09:52 UTC
Current GNOME 3.8 UI does not setup a default Input Source
(kbd layout) for new users, which leads to somewhat strange UI experience.  Worse for some locales (languages) it means
that one is not able to input ASCII characters without having
to tweak the Input Sources.
This is also a regression compared to Fedora 18/GNOME 3.6,
which defaulted to the system keyboard layout.

Proposing as a F19 Beta Blocker.

Comment 2 Jens Petersen 2013-05-02 07:12:57 UTC
*** Bug 956458 has been marked as a duplicate of this bug. ***

Comment 3 Rui Matos 2013-05-02 11:50:14 UTC
The list coming up empty will be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=958714 .

Comment 4 Adam Williamson 2013-05-03 01:05:39 UTC
Have the anaconda folks accepted that bug, though, or have you just filed it? Seems important to make sure everyone's on the same page here.

Comment 5 Rui Matos 2013-05-03 08:32:35 UTC
(In reply to comment #4)
> Have the anaconda folks accepted that bug, though, or have you just filed
> it? Seems important to make sure everyone's on the same page here.

Yes, I spoke with Vratislav on IRC.

Comment 6 Adam Williamson 2013-05-06 16:48:20 UTC
Discussed at 2013-05-06 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-06/f19beta-blocker-review-3.2013-05-06-16.02.log.txt . We're definitely worried about this one, but it doesn't seem like this report makes it clearly precisely what the *practical* impact of this bug is. It would help a lot if we could make that clear.

So, say you're a Japanese (or whatever) user, and you make a normal choice at the keyboard layout spoke in anaconda. What do you choose? What keyboard layout actually winds up being used during gnome-initial-setup and first login? What are the practical consequences of this? Are we talking minor inconvenience, complete inability to create a user account, or what? Thanks!

We're also interested to see what the impact of the fix for 958714 will be on this bug.

Comment 7 Rui Matos 2013-05-07 10:07:09 UTC
(In reply to comment #6)
> So, say you're a Japanese (or whatever) user, and you make a normal choice
> at the keyboard layout spoke in anaconda. What do you choose?

Since anaconda only provides XKB keymaps as options (i.e. no IBus engines) such a user will most likely choose either the US layout or the Japanase layout which is an ASCII layout with some minor differences to the US layout in punctuation key locations.

> What keyboard
> layout actually winds up being used during gnome-initial-setup and first
> login?

The layouts chosen in anaconda. In our case above either US or Japanese or even both.

> What are the practical consequences of this? Are we talking minor
> inconvenience, complete inability to create a user account, or what? Thanks!

So in F19 there are actually 2 ways to create user accounts. During installation in anaconda or, if you don't do it there, during a special run of gnome-initial-setup that GDM runs when there are no users created yet.

In the first case GDM comes up normally and the layouts available there are the ones configured in anaconda. When the user logs into this account the "regular" gnome-initial-setup runs and again those same layouts are there but now the user can add more layouts or input methods (in case any IBus IMEs are installed). I.e. our Japanese user can now add Japanese (Anthy) and start using it right away.

In the case where the user account isn't created in anaconda GDM initially presents the "expanded" gnome-initial-setup that allows you to create an account. But as far as input methods are concerned it works as described above.

> We're also interested to see what the impact of the fix for 958714 will be
> on this bug.

Just that the list won't come up empty as it does now.

Comment 8 Adam Williamson 2013-05-07 19:23:25 UTC
That's pretty much as I saw it, yes. Okay. So what's the bug here?

If anything, Mike's report is two bugs:

#1 - the g-i-s input list comes up empty, it should show whatever was selected in anaconda.

Okay, we have a bug for that already, that's 958714.

#2 - we don't magically set up proper Japanese input configuration in anaconda when you pick Japanese as your language.

Yes? If so, this bug is effectively just for #2, and we should change the summary, and it kinda becomes an RFE, because that's quite a complex thing for us to do. For a start, we'd need to add the iBus input methods to anaconda and make sure they work, then we could start thinking about getting them selected automatically.

If I'm wrong, can someone please define precisely what it is this bug is for, and how it differs from 958714?

Comment 9 Mike FABIAN 2013-05-08 05:28:41 UTC
(In reply to comment #8)
> That's pretty much as I saw it, yes. Okay. So what's the bug here?
> 
> If anything, Mike's report is two bugs:
> 
> #1 - the g-i-s input list comes up empty, it should show whatever was
> selected in anaconda.
> 
> Okay, we have a bug for that already, that's 958714.
> 
> #2 - we don't magically set up proper Japanese input configuration in
> anaconda when you pick Japanese as your language.
> 
> Yes? If so, this bug is effectively just for #2,

Yes, to me it looks like only #2 remains if bug#958714 is fixed.

> summary, and it kinda becomes an RFE, because that's quite a complex thing
> for us to do.

I think a Japanese input method was setup automatically on f18 after
an installation in Japanese though, if I remember correctly.

> For a start, we'd need to add the iBus input methods to
> anaconda and make sure they work, then we could start thinking about getting
> them selected automatically.

Did  f18 do this using anaconda?

Comment 10 Adam Williamson 2013-05-08 06:10:43 UTC
"I think a Japanese input method was setup automatically on f18 after an installation in Japanese though, if I remember correctly."

Really? Hmm, that must have been GNOME being smart based on the language, I guess, because anaconda just sets up the layouts it shows on the keyboard spoke. I guess we need to look at it more closely.

Comment 11 Adam Williamson 2013-05-08 17:10:35 UTC
Discussed at 2013-05-08 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-08/f19beta-blocker-review-4.2013-05-08-16.00.log.txt . This doesn't look like a blocker - 958714 is probably a stronger candidate - but we're still not quite sure what all the issues are here, so we're punting it for clarification and testing, esp. with the 958714 fix when it comes.

Comment 12 Adam Williamson 2013-05-08 17:42:27 UTC
OK, so both Rui and myself now understand this bug to cover the issue with GNOME's automatic setup of IMEs for certain languages no longer working. The issue with the g-i-s input method dialog coming up empty is a bug in anaconda and is filed as #958714. Updating summary.

Comment 13 Jens Petersen 2013-05-09 01:22:08 UTC
*** Bug 958716 has been marked as a duplicate of this bug. ***

Comment 14 Adam Williamson 2013-05-09 01:27:52 UTC
Do we know yet for sure whether the IME configuration magic is entirely broken, or have people only tested Japanese so far?

Comment 15 Jens Petersen 2013-05-09 04:05:09 UTC
I believe it is not supported yet and in fact currently IMEs cannot be
added from g-i-s, which probably also blocks this.

We really need an upstream bug for this I guess.
Anyone know if there is one?

Comment 16 Adam Williamson 2013-05-09 04:26:07 UTC
Jens: well this bug says 'g-i-s', but the functionality was present in GNOME in 3.6, Rui tells me; it is/was done by gnome-settings-daemon. So I wouldn't expect an appropriate IME to show up in g-i-s in F19 at present, necessarily, but we would kinda expect an appropriate IME to show up once you finish g-i-s and go into the desktop.

It's presumably a question for upstream whether, now we have g-i-s, it makes sense to move this from g-s-d out into g-i-s. But we should probably check what precisely the current situation is.

The bug for adding IMEs to g-i-s is #950688; it's marked as ON_QA.

Comment 17 Adam Williamson 2013-05-13 17:00:41 UTC
Discussed at 2013-05-13 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-13/f19beta-blocker-review-5.2013-05-13-16.00.log.txt . Now we're clear on what is broken and what is working, we're happy rejecting this bug as a blocker: it'd be nice to have IMEs configured 'magically' for users of appropriate languages, but if we don't, that clearly doesn't violate the criteria.

Comment 18 Jens Petersen 2013-05-14 03:44:13 UTC
i believe Rui is working on moving that functionality to g-i-s for F19.

Not sure if it is in gnome-initial-setup-0.10-1.fc19.

Comment 19 Mike FABIAN 2013-05-14 05:13:15 UTC
I did get the Japanese input method "Kana Kanji" (ibus-kkc) automatically
after a netinstall  of Fedora-19-Beta-TC4-x86_64-netinst.iso.

gnome-initial-setup-0.9-2.fc19.x86_64

Comment 20 Adam Williamson 2013-05-15 17:08:22 UTC
mike: so you just did an install in Japanese, didn't add any input methods during the relevant step of g-i-s, but you had KKC configured when you logged into your desktop?

Comment 21 Adam Williamson 2013-05-15 23:36:20 UTC
Discussed at 2013-05-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Accepted as a freeze exception bug as it would be good to have this function in Beta for testing. Whether we pull a fix if one shows up, though, depends on how invasive it is, how late it is, and how well it's tested.

Note: I built a live image with the latest everything today, and found that if I picked Japanese language in gnome-initial-setup, the KKC IME was shown on the input method screen. However, if I left that screen without touching anything and completed g-i-s, KKC didn't actually appear to be enabled either for the rest of g-i-s, or for the user session I was eventually logged into.

Comment 22 Mike FABIAN 2013-05-16 06:10:05 UTC
(In reply to comment #20)
> mike: so you just did an install in Japanese, didn't add any input methods
> during the relevant step of g-i-s, but you had KKC configured when you
> logged into your desktop?

Yes.

Comment 23 Jens Petersen 2013-05-16 06:48:44 UTC
I didn't see any IMEs setup by default recently,
I think this is fixed by gnome-initial-setup-0.10-1.fc19
for Japanese at least.

Comment 24 Adam Williamson 2013-05-16 06:49:34 UTC
Jens: well, see my result from comment #21. It didn't quite work for me.

Comment 25 Jens Petersen 2013-05-16 10:09:36 UTC
As yes thanks, Rui mentioned this bug to me earlier on irc.

Comment 26 Parag Nemade 2013-05-16 10:39:41 UTC
I installed Fedora 19 Beta TC4, then manually updated to gnome-initial-setup-0.10-1.fc19 build. I can see this bug is now fixed with this update.

Comment 27 Adam Williamson 2013-05-16 16:23:50 UTC
parag: see if the IME that's shown in g-i-s is actually configured for your user when you complete it - c#21.

Comment 28 Rui Matos 2013-05-16 16:29:49 UTC
(In reply to comment #21)
> Note: I built a live image with the latest everything today, and found that
> if I picked Japanese language in gnome-initial-setup, the KKC IME was shown
> on the input method screen. However, if I left that screen without touching
> anything and completed g-i-s, KKC didn't actually appear to be enabled
> either for the rest of g-i-s, or for the user session I was eventually
> logged into.

Yeah, there's a bug there. Do we need to have it fixed for the beta or can it go in afterwards?

Comment 29 Adam Williamson 2013-05-16 16:46:32 UTC
AcceptedFreezeException means that we can choose to pull a fix into Beta if it looks safe, but we aren't blocking on it.

Comment 30 Jens Petersen 2013-05-17 04:44:58 UTC
*** Bug 962699 has been marked as a duplicate of this bug. ***

Comment 31 Rui Matos 2013-05-20 13:17:25 UTC
The current g-i-s update in bodhi should fix this.

Comment 32 Adam Williamson 2013-05-21 00:54:44 UTC
That's https://admin.fedoraproject.org/updates/FEDORA-2013-8488/gnome-initial-setup-0.10-3.fc19 . It will be in Beta RC3. Setting ON_QA.

Comment 33 Adam Williamson 2013-05-21 16:41:38 UTC
Confirmed that latest g-i-s fixes this. It's still doing its little dance when you run it in Japanese, but it works :)

Comment 34 Jens Petersen 2013-05-22 09:26:26 UTC
Thanks - looks good to me too for Japanese input.

Comment 35 Mike FABIAN 2013-05-26 11:45:07 UTC
Chinese and Marathi looks OK as well.

Comment 36 Parag Nemade 2014-02-21 06:18:03 UTC
This should be closed then....


Note You need to log in before you can comment on or make changes to this bug.