Bug 962767 - Initial Setup look's like good old 90s with KDE environment
Initial Setup look's like good old 90s with KDE environment
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: oxygen-gtk3 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 963934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 08:10 EDT by Vratislav Podzimek
Modified: 2015-03-13 09:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-13 07:54:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vratislav Podzimek 2013-05-14 08:10:08 EDT
Description of problem:
The Initial Setup tool looks like a very old GUI tool when installed with the KDE environment.

Version-Release number of selected component (if applicable):
initial-setup-0.3.4-3.fc19

How reproducible:
100%

Steps to Reproduce:
1. install KDE environment from a Fedora 19 DVD or netinst
2. reboot to the Initial Setup after installation process
  
Actual results:
old look

Expected results:
fresh look

Additional info:
Installing adwaita-gtk3-theme package solves the issue.
Comment 1 Rex Dieter 2013-05-14 08:24:20 EDT
The problem likely is that gtk3 currently defines a default theme (adwaita-gtk3-theme), but has no dependency on it to ensure that it is present.

For what it's worth, we hack around the issue in the kde spin.  See:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/tree/fedora-live-kde-base.ks

starting at line 35

But, beyond that, I'm not aware of anything we (kde-sig) can't do much about the missing theming if installing via other methods.


Some options include:
1.  let gtk3 handle it better somehow:
    a. gtk3 packaging add Requires: adwaita-gtk3-theme
    b. gtk3 use some better fallback theme when adwaita-gtk3-theme is not present
2.  initial setup handle it somehow:
    a. Requires: adwaita-gtk3-theme
    b. handle fallback theme itself somehow
Comment 2 Kevin Kofler 2013-05-14 09:12:29 EDT
initial-setup could check whether oxygen-gtk3 is available and adwaita-gtk3-theme is not and programmatically switch to oxygen-gtk3 in that case.
Comment 3 Kevin Kofler 2013-05-14 09:44:06 EDT
If not, put adwaita-gtk3 as default in comps somewhere where it's pulled in no matter what desktop you pick (or in the kde-desktop group, but ugh…) and do -adwaita-gtk3-theme in the KDE kickstart where we have the hack to use oxygen-gtk3 instead. That doesn't need any coding or packaging changes, just comps and kickstart hackery.
Comment 4 Vratislav Podzimek 2013-05-17 04:21:48 EDT
*** Bug 963934 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Reznik 2013-06-06 05:02:53 EDT
Well, we really should do what Kevin says at least in comment #3.
Comment 6 Vratislav Podzimek 2013-06-06 08:35:14 EDT
(In reply to Jaroslav Reznik from comment #5)
> Well, we really should do what Kevin says at least in comment #3.
So may I reassign this bug to the 'comps' component?
Comment 7 Martin Kolman 2014-04-17 05:16:57 EDT
Well, reassigning to comps as per comment 3 anyway.
Comment 8 Massimiliano 2014-04-21 19:50:07 EDT
I don't like very much the solution proposed in comment #3. In my KDE kickstart I've decided that oxygen-gtk3 is the default theme for gtk3, and it works perfectly. I don't like unnecessary things pulled in my system.
Comment 9 Jaroslav Reznik 2015-03-03 09:56:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 10 Jaroslav Reznik 2015-03-13 05:04:30 EDT
There's one possible solution - as Adwaita theme is pretty similar to Breeze theme (hey, flat design trendy again), GTK apps can stay with Adwaita instead of Oxygen.
Comment 11 Rex Dieter 2015-03-13 07:54:56 EDT
for f22+, kde spin is using adwaita by default (and essentially retiring oxygen-gtk3, since gtk3 removed the theming api it uses)
Comment 12 Massimiliano 2015-03-13 09:25:14 EDT
(In reply to Rex Dieter from comment #11)
> for f22+, kde spin is using adwaita by default (and essentially retiring
> oxygen-gtk3, since gtk3 removed the theming api it uses)

Could you provide more info about this?

Thanks
Comment 13 Rex Dieter 2015-03-13 09:29:03 EDT
Essentially,
https://bugzilla.gnome.org/show_bug.cgi?id=735211

Note You need to log in before you can comment on or make changes to this bug.