Bug 962845 - [as7] resource type admin pages missing some child services from as7 plugin
[as7] resource type admin pages missing some child services from as7 plugin
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.2
Unspecified Unspecified
high Severity high
: ER01
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
: 1004366 (view as bug list)
Depends On: 962841
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 10:52 EDT by Thomas Segismont
Modified: 2015-06-29 19:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962841
Environment:
Last Closed: 2014-01-02 15:37:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 486743 None None None Never

  None (edit)
Description Thomas Segismont 2013-05-14 10:52:49 EDT
+++ This bug was initially created as a clone of Bug #962841 +++

Description of problem:
Metric Collection Template screen does not show all metrics from as7 plugin

Version-Release number of selected component (if applicable):
4.7

How reproducible:
Always

Steps to Reproduce:
1.Open the Administration > Metric Collection templates page
  
Actual results:
Some as7 plugin metrics are missing (for example all metrics from child services of the JVM service)

Expected results:
All metrics should appear and the user should be able to define its own values
Comment 1 John Mazzitelli 2013-05-20 09:32:16 EDT
see bug #962841 for more info on how I replicated this and other notes.
Comment 2 John Mazzitelli 2013-05-23 15:05:10 EDT
git commit to master: b335646
Comment 3 Larry O'Leary 2013-09-06 10:33:45 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 4 Larry O'Leary 2013-09-06 10:34:26 EDT
As this is MODIFIED or ON_QA, setting milestone to ER01.
Comment 5 Sunil Kondkar 2013-10-03 07:17:01 EDT
Verified on JBoss ON Version: 3.2.0.ER2 Build Number: 9bf6f76:371eac0

Verified that the resource types in 'servers' section of resource type admin pages show child service types (Ex: "JVM" and "webservices" types under the "JBossAS7 Standalone Server" )
Verified in 'Alert Definition Templates', 'Drift Definition Templates' and 'Metric Collection Templates'.
Comment 7 Larry O'Leary 2014-01-09 09:41:21 EST
*** Bug 1004366 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.