Bug 962905 - subscription-manager-gui: Cannot enter valid numbers in quantity spinner.
subscription-manager-gui: Cannot enter valid numbers in quantity spinner.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-14 14:26 EDT by J.C. Molet
Modified: 2013-09-30 19:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:08:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2013-05-14 14:26:18 EDT
Description of problem:
When adjusting the quantity in the gui for subscriptions that have an instance_multiplier set, you cannot set numbers greater than nine properly.

Version-Release number of selected component (if applicable):
subscription-manager: 1.8.7-1.git.39.c802238.el5


How reproducible:
always

Steps to Reproduce:
1. Open up subscription-manager-gui
2. Register
3. click the 'All Available Subscriptions' tab
4. click 'update'
5. Find a subscription with an instance_multiplier attribute (in the TESTDATA, "Awesome OS Instance Based (Standard Support)" is a good example).
6. Click on the quantity field to adjust the quantity
7. Enter in any number that meets the instance_multiplier constraints but also contains digits which are non-even (examples: 10, 012, 234)
  
Actual results:
Since the instance_multiplier is checked on EACH DIGIT instead of the ENTIRE NUMBER, you cannot enter in many valid quantities.

Expected results:
You should be able to type in any valid quantity.

Additional info:
Secondary bug:  the keyboard up and down arrows also don't work properly, it scrolls: 2, blank, 4, blank, 6, blank, ...  This means you have to press twice as many buttons to get to the number you want using this method.
Comment 1 RHEL Product and Program Management 2013-05-14 14:27:57 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Ondrej Vasik 2013-05-15 07:41:22 EDT
Could you please set devel_ack/condnack for 5.10 or postpone/close this bugzilla? Erratas should be filed by May 21st, so development phase is nearing its exit.
Comment 3 Alex Wood 2013-05-21 13:55:21 EDT
commit d6a01908e1fb44eab0096360dfe96908a92f8aec
Author: Alex Wood <awood@redhat.com>
Date:   Mon May 20 11:05:13 2013 -0400

    962905: Fixing errors with quantity spinner.
Comment 4 Jesus M. Rodriguez 2013-05-21 14:29:49 EDT
Moving back to modified to include in the errata.
Comment 6 Sharath Dwaral 2013-05-22 14:04:36 EDT
Version: Brew Build

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.7-1
subscription-manager: 1.8.8-1.el5
python-rhsm: 1.8.11-1.el5_9

Steps to Reproduce:

1. Open up subscription-manager-gui
2. Register
3. click the 'All Available Subscriptions' tab
4. click 'update'
5. Find a subscription with an instance_multiplier attribute (in the TESTDATA, "Awesome OS Instance Based (Standard Support)" is a good example).
6. Click on the quantity field to adjust the quantity

The quantity field can take in digits that have non-even number
The quantity filed cannot begin with '0'
The quantity field should be a positive number
The increment and decrement buttons work appropriately (+1 and -1)


VERIFIED
Comment 9 errata-xmlrpc 2013-09-30 19:08:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.