Bug 962996 - packstack expects eth0 as the interface
packstack expects eth0 as the interface
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: Triaged
: 978678 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 19:09 EDT by Steven Dake
Modified: 2016-04-26 13:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 13:51:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2013-05-14 19:09:21 EDT
Description of problem:
packstack expects eth0 interface names.  In some situations users may not want to setup on eth0.

Version-Release number of selected component (if applicable):
rdo-3 repo

How reproducible:
100%

Steps to Reproduce:
1. setup a vm with an eth1 but no eth0
2. run packstack --install-hosts=x,y,z where z contains a vm with eth1
3.
  
Actual results:
packstack expecting eth0 when there is none

Expected results:
packstack should install regardless of ethernet interface name

Additional info:
[sdake@brew64 ~]$ packstack --install-hosts=192.168.122.10,192.168.122.11,192.168.122.12
Welcome to Installer setup utility
Packstack changed given value  to required value /home/sdake/.ssh/id_rsa.pub

Installing:
Clean Up...                                              [ DONE ]
Setting up ssh keys...root@192.168.122.10's password: 
root@192.168.122.11's password: 
root@192.168.122.12's password: 
                                   [ DONE ]
Adding pre install manifest entries...                   [ DONE ]
Adding MySQL manifest entries...                         [ DONE ]
Adding QPID manifest entries...                          [ DONE ]
Adding Keystone manifest entries...                      [ DONE ]
Adding Glance Keystone manifest entries...               [ DONE ]
Adding Glance manifest entries...                        [ DONE ]
Adding Cinder Keystone manifest entries...               [ DONE ]
Installing dependencies for Cinder...                    [ DONE ]
Checking if the Cinder server has a cinder-volumes vg... [ DONE ]
Adding Cinder manifest entries...                        [ DONE ]
Adding Nova API manifest entries...                      [ DONE ]
Adding Nova Keystone manifest entries...                 [ DONE ]
Adding Nova Cert manifest entries...                     [ DONE ]
Adding Nova Conductor manifest entries...                [ DONE ]
Adding Nova Compute manifest entries...                  [ DONE ]
Adding Nova Network manifest entries...
ERROR : Error running remote script: Device eth0 does not exist

Please check log file /var/tmp/packstack/20130514-155740-O_bVKz/openstack-setup.log for more information

Additional information:
 * A new answerfile was created in: /home/sdake/packstack-answers-20130514-155740.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
Comment 2 Steven Dake 2013-05-14 20:28:56 EDT
A bit more information:

Some of my VMs had eth0 and some had eth1 which is what seems to cause the issue.
Comment 3 Alvaro Lopez Ortega 2013-11-13 13:51:01 EST
We do not plan to support heterogeneous environments. Foreman may be able to handle this scenario gracefully though.
Comment 4 Alvaro Lopez Ortega 2013-11-13 14:05:59 EST
*** Bug 978678 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.