Bug 978678 - packstack only try found eth1 during single node deployment
Summary: packstack only try found eth1 during single node deployment
Keywords:
Status: CLOSED DUPLICATE of bug 962996
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.0
Assignee: Martin Magr
QA Contact: Nir Magnezi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-27 04:29 UTC by Hangbin Liu
Modified: 2013-11-13 19:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-13 19:05:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hangbin Liu 2013-06-27 04:29:12 UTC
Description of problem:
packstack only try found eth1 during single node deployment

Version-Release number of selected component (if applicable):
# uname -r
3.9.5-301.fc19.x86_64
# rpm -qa | grep openstack
openstack-packstack-2013.1.1-0.3.dev527.fc19.noarch


How reproducible:
everytime

Steps to Reproduce:
1. # packstack --install-hosts=10.16.42.233 <- this is my host address
2.
3.

Actual results:

# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:13:20:f8:82:2e brd ff:ff:ff:ff:ff:ff
    inet 10.16.42.233/21 brd 10.16.47.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 2620:52:0:102f:213:20ff:fef8:822e/64 scope global dynamic
       valid_lft 2591973sec preferred_lft 604773sec
    inet6 fe80::213:20ff:fef8:822e/64 scope link
       valid_lft forever preferred_lft forever
3: enp1s0f0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:1b:21:38:2e:10 brd ff:ff:ff:ff:ff:ff
4: enp1s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:1b:21:38:2e:11 brd ff:ff:ff:ff:ff:ff

# packstack --install-hosts=10.16.42.233
Welcome to Installer setup utility

Installing:
Clean Up...                                              [ DONE ]
Adding pre install manifest entries...                   [ DONE ]
Setting up ssh keys...root@10.16.42.233's password:
                                   [ DONE ]
Adding MySQL manifest entries...                         [ DONE ]
Adding QPID manifest entries...                          [ DONE ]
Adding Keystone manifest entries...                      [ DONE ]
Adding Glance Keystone manifest entries...               [ DONE ]
Adding Glance manifest entries...                        [ DONE ]
Adding Cinder Keystone manifest entries...               [ DONE ]
Installing dependencies for Cinder...                    [ DONE ]
Checking if the Cinder server has a cinder-volumes vg... [ DONE ]
Adding Cinder manifest entries...                        [ DONE ]
Adding Nova API manifest entries...                      [ DONE ]
Adding Nova Keystone manifest entries...                 [ DONE ]
Adding Nova Cert manifest entries...                     [ DONE ]
Adding Nova Conductor manifest entries...                [ DONE ]
Adding Nova Compute manifest entries...
ERROR : Error running remote script: Device eth1 does not exist

Please check log file /var/tmp/packstack/20130626-193758-X_hUoG/openstack-setup.log for more information

Additional information:
 * A new answerfile was created in: /root/packstack-answers-20130626-193758.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.


Expected results:
It should try to find other interface automatically.


Additional info:
We don't use ethX for a long time on Fedora. I think we should find the second interface automatically instead of hard code "eth1"

Comment 2 Alvaro Lopez Ortega 2013-11-13 19:05:59 UTC

*** This bug has been marked as a duplicate of bug 962996 ***


Note You need to log in before you can comment on or make changes to this bug.