Bug 9630 - slovene keymap doesn't work
Summary: slovene keymap doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: console-tools
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 10555 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-21 10:35 UTC by David Balažic
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-08-09 09:09:02 UTC


Attachments (Terms of Use)

Description David Balažic 2000-02-21 10:35:22 UTC
setting the keyboard to slovene doesn't work :
> loadkeys slovene
Loading /usr/lib/kbd/keymaps/i386/qwertz/slovene.kmap.gz
unknown keysym 'cent'
/usr/lib/kbd/keymaps/i386/qwertz/slovene.kmap.gz:6: parse error
syntax error in map file
key bindings not changed

I located the problem to file
/usr/lib/kbd/keymaps/i386/include/euro.inc.gz which is included
by slovene.kmap , the problematic line is :
altgr keycode 46 = cent

Commenting it out "fixes" the problem.

Comment 1 David Balažic 2000-04-10 08:19:59 UTC
After some looking around I discovered that the 'cent' symbol
is legal , as it is used by all other keymaps too.
The thing is that slovene.kmap has line :
codepage "iso-8859-2"
If I delete this line , then it works OK.
Note that I don't remember if the keyword is actually 'codepage'
or something else. It is one of the first lines in the file,
just look for *8859* :-)

Comment 2 David Balažic 2000-04-10 08:27:59 UTC
*** Bug 10555 has been marked as a duplicate of this bug. ***

Comment 3 David Balažic 2000-04-10 09:02:59 UTC
OK , the line is not 'codepage "iso-8859-2"' ,
but 'charset "iso-8859-2"'

Comment 4 David Balažic 2000-08-07 17:02:09 UTC
Still here in Pinstripe.
Just do 'loadkeys slovene' and observe the error messages.

Comment 5 Bernhard Rosenkraenzer 2000-08-09 09:09:00 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.