Bug 963004 - [abrt] iotop-0.5-1.fc19: ui.py:472:refresh_display:UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 73: ordinal not in range(128)
[abrt] iotop-0.5-1.fc19: ui.py:472:refresh_display:UnicodeEncodeError: 'ascii...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iotop (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
abrt_hash:e284eff112ca7596f11d5439b1b...
:
: 970539 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 19:50 EDT by Jiří Martínek
Modified: 2013-06-17 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: iotop-0.6-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.45 KB, text/plain)
2013-05-14 19:51 EDT, Jiří Martínek
no flags Details
File: core_backtrace (791 bytes, text/plain)
2013-05-14 19:51 EDT, Jiří Martínek
no flags Details
File: environ (3.41 KB, text/plain)
2013-05-14 19:51 EDT, Jiří Martínek
no flags Details

  None (edit)
Description Jiří Martínek 2013-05-14 19:50:57 EDT
Description of problem:
Just launched iotop

Version-Release number of selected component:
iotop-0.5-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/iotop
dso_list:       python-libs-2.7.4-4.fc19.x86_64
executable:     /usr/bin/iotop
kernel:         3.9.1-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
ui.py:472:refresh_display:UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 73: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/iotop", line 16, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 605, in main
    main_loop()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 595, in <lambda>
    main_loop = lambda: run_iotop(options)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 493, in run_iotop
    return curses.wrapper(run_iotop_window, options)
  File "/usr/lib64/python2.7/curses/wrapper.py", line 43, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 486, in run_iotop_window
    ui.run()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 155, in run
    self.process_list.duration)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 472, in refresh_display
    self.win.addstr(i + len(summary) + 1, 0, lines[i])
UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 73: ordinal not in range(128)

Local variables in innermost frame:
remaining_cols: 10
actual: (151552, 0)
attr: 262144
title: '    COMMAND'
i: 0
pid: '  TID'
status_msg: None
lines: [u' 1929 be/4 gio       126.59 K/s    0.00 B/s  0.00 %  5.13 % chrome --~ger\u2019s Cat)', u'  479 be/3 root        0.00 B/s    0.00 B/s  0.00 %  4.50 % [jbd2/sda3-8]', u' 1713 be/4 gio        15.34 K/s    0.00 B/s  0.00 %  1.47 % chrome [B~rBlocking]', u'    1 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % systemd -~rialize 22', u'    2 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kthreadd]', u'    3 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [ksoftirqd/0]', u'    5 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kworker/0:0H]', u'    7 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kworker/u:0H]', u'    8 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [migration/0]', u'    9 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [rcu_bh]', u'   10 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [rcu_sched]', u'   11 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [watchdog/0]', u'   12 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [watchdog/1]', u'   13 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [migration/1]', u'   14 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [ksoftirqd/1]', u'   16 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kworker/1:0H]', u'   17 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [khelper]', u'   18 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kdevtmpfs]', u'   19 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [netns]', u'   20 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [bdi-default]', u'   21 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kintegrityd]', u'   22 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kblockd]', u'   23 be/0 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [ata_sff]']
summary: ['Total DISK READ :     141.93 K/s | Total DISK WRITE :       0.00 B/s', 'Actual DISK READ:     141.93 K/s | Actual DISK WRITE:       0.00 B/s']
s: 'Actual DISK READ:     141.93 K/s | Actual DISK WRITE:       0.00 B/s'
titles: ['  TID', '  PRIO', '  USER', '     DISK READ', '  DISK WRITE', '  SWAPIN', '      IO', '    COMMAND']
duration: 1.0427589416503906
first_time: False
total: (151552, 0)
self: <iotop.ui.IOTopUI object at 0x121cad0>
num_lines: 23
Comment 1 Jiří Martínek 2013-05-14 19:51:01 EDT
Created attachment 747969 [details]
File: backtrace
Comment 2 Jiří Martínek 2013-05-14 19:51:03 EDT
Created attachment 747970 [details]
File: core_backtrace
Comment 3 Jiří Martínek 2013-05-14 19:51:05 EDT
Created attachment 747971 [details]
File: environ
Comment 5 Michal Hlavinka 2013-06-04 06:00:38 EDT
*** Bug 970539 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-06-04 06:06:26 EDT
iotop-0.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iotop-0.6-1.fc18
Comment 7 Fedora Update System 2013-06-04 06:06:38 EDT
iotop-0.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iotop-0.6-1.fc19
Comment 8 Fedora Update System 2013-06-04 22:32:59 EDT
Package iotop-0.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iotop-0.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10035/iotop-0.6-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-13 02:41:57 EDT
iotop-0.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-06-17 21:34:07 EDT
iotop-0.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.