Bug 970539 - [abrt] iotop-0.5-1.fc19: ui.py:472:refresh_display:UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 144: ordinal not in range(128)
[abrt] iotop-0.5-1.fc19: ui.py:472:refresh_display:UnicodeEncodeError: 'ascii...
Status: CLOSED DUPLICATE of bug 963004
Product: Fedora
Classification: Fedora
Component: iotop (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
abrt_hash:b36fb909c924d01c1ced1fe71ae...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 05:43 EDT by smanocch
Modified: 2013-06-04 06:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 06:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.83 KB, text/plain)
2013-06-04 05:43 EDT, smanocch
no flags Details
File: core_backtrace (787 bytes, text/plain)
2013-06-04 05:43 EDT, smanocch
no flags Details
File: environ (2.56 KB, text/plain)
2013-06-04 05:43 EDT, smanocch
no flags Details

  None (edit)
Description smanocch 2013-06-04 05:43:37 EDT
Description of problem:
Viewing HD perfomance

Version-Release number of selected component:
iotop-0.5-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /bin/iotop -o
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /bin/iotop
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
ui.py:472:refresh_display:UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 144: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/iotop", line 16, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 605, in main
    main_loop()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 595, in <lambda>
    main_loop = lambda: run_iotop(options)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 493, in run_iotop
    return curses.wrapper(run_iotop_window, options)
  File "/usr/lib64/python2.7/curses/wrapper.py", line 43, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 486, in run_iotop_window
    ui.run()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 155, in run
    self.process_list.duration)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 472, in refresh_display
    self.win.addstr(i + len(summary) + 1, 0, lines[i])
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 144: ordinal not in range(128)

Local variables in innermost frame:
remaining_cols: 88
actual: (942080, 0)
attr: 262144
title: '    COMMAND'
i: 1
pid: '  TID'
status_msg: None
lines: [u'20371 be/4 root      283.79 K/s    0.00 B/s  0.00 % 99.99 % java -Declipse.security -Dwas.status.socket=5097~nfig JazzSMNode01Cell JazzSMNode01 server1 [main]', u'20688 be/4 smanocch    0.00 B/s    0.00 B/s  0.00 % 97.78 % libgnome-shell-browser-plugin.so --lang=en-US --~468D3C5C32D,Fedora release 19 (Schr\xf6dinger\u2019s Cat)', u'20648 be/4 smanocch  332.98 K/s    0.00 B/s  0.00 % 94.01 % javaw -Xquickstart -Xms100m -Xmx1024m -Xmnx64m -~r_1.1.1.R36x_v20101122_1400.jar [org.eclipse.jdt]', u'20080 be/4 smanocch   94.60 K/s    0.00 B/s  0.00 % 90.09 % javaw -Xquickstart -Xms100m -Xmx1024m -Xmnx64m -~nox.launcher_1.1.1.R36x_v20101122_1400.jar [main]', u'20328 be/4 smanocch   83.25 K/s    0.00 B/s  0.00 % 74.96 % javaw -Xquickstart -Xms100m -Xmx1024m -Xmnx64m -~r_1.1.1.R36x_v20101122_1400.jar [Link Indexer wo]', u'19977 be/4 smanocch    0.00 B/s    0.00 B/s  0.00 % 52.09 % gnome-shell [pool]', u'11894 be/4 smanocch   11.35 K/s   37.84 K/s  0.00 % 12.27 % chrome [Chrome_CacheThr]', u' 1586 be/4 root       60.54 K/s    0.00 B/s  0.00 %  3.71 % Xorg :0 -background none -verbose -auth /run/gdm~gdm-3cikIi/database -seat seat0 -nolisten tcp vt1']
summary: ['Total DISK READ :     866.51 K/s | Total DISK WRITE :      37.84 K/s', 'Actual DISK READ:     870.29 K/s | Actual DISK WRITE:       0.00 B/s']
s: 'Actual DISK READ:     870.29 K/s | Actual DISK WRITE:       0.00 B/s'
titles: ['  TID', '  PRIO', '  USER', '     DISK READ', '  DISK WRITE', '  SWAPIN', '      IO', '    COMMAND']
duration: 1.0571160316467285
first_time: False
total: (937984, 40960)
self: <iotop.ui.IOTopUI object at 0x7f2cef3fe610>
num_lines: 8
Comment 1 smanocch 2013-06-04 05:43:42 EDT
Created attachment 756666 [details]
File: backtrace
Comment 2 smanocch 2013-06-04 05:43:45 EDT
Created attachment 756667 [details]
File: core_backtrace
Comment 3 smanocch 2013-06-04 05:43:48 EDT
Created attachment 756668 [details]
File: environ
Comment 4 Michal Hlavinka 2013-06-04 06:00:38 EDT

*** This bug has been marked as a duplicate of bug 963004 ***

Note You need to log in before you can comment on or make changes to this bug.