Bug 963018 - SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the directory /etc/sssd.
SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the di...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
abrt_hash:78c7ddfa71c09019bf6b08d67fa...
:
: 963019 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 21:42 EDT by Neil
Modified: 2013-05-27 05:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 05:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil 2013-05-14 21:42:03 EDT
Description of problem:
SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the directory /etc/sssd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that realmd should be allowed read access on the sssd directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep realmd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sssd_conf_t:s0
Target Objects                /etc/sssd [ dir ]
Source                        realmd
Source Path                   /usr/lib64/realmd/realmd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           realmd-0.14.1-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-43.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc1.git2.2.fc20.x86_64 #1
                              SMP Tue May 14 05:16:42 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-14 18:31:41 PDT
Last Seen                     2013-05-14 18:31:41 PDT
Local ID                      3b03b113-45c4-463b-aee6-c5f0ac16ffad

Raw Audit Messages
type=AVC msg=audit(1368581501.832:359): avc:  denied  { read } for  pid=1116 comm="realmd" name="sssd" dev="dm-1" ino=531130 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sssd_conf_t:s0 tclass=dir


type=SYSCALL msg=audit(1368581501.832:359): arch=x86_64 syscall=inotify_add_watch success=yes exit=EPERM a0=9 a1=7f84feff0480 a2=1002fce a3=7fff9b8dcaa0 items=0 ppid=1115 pid=1116 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=realmd exe=/usr/lib64/realmd/realmd subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: realmd,system_dbusd_t,sssd_conf_t,dir,read

audit2allow

#============= system_dbusd_t ==============
allow system_dbusd_t sssd_conf_t:dir read;

audit2allow -R
require {
	type system_dbusd_t;
}

#============= system_dbusd_t ==============
sssd_manage_config(system_dbusd_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc1.git2.2.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-15 04:54:24 EDT
*** Bug 963019 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-05-15 04:56:38 EDT
The problem is the realmd is not running with the correct labeling.

Stef, 
is there a patch change in F20?
Comment 3 Daniel Walsh 2013-05-15 11:22:08 EDT
This looks like realmd is not labeled correctly so when it stated it did not transition to realmd_t.  restorecon -v PATHTO/realmd
Comment 4 Fedora Admin XMLRPC Client 2013-05-20 12:32:58 EDT
The Fedora 20 component was created in error. We only create new Fedora versions when we branch a new release. These bugs are all being moved to rawhide. 

Please retarget them to 19 if they also apply to the Fedora 19 branched release. 

Thanks.
Comment 5 Stef Walter 2013-05-27 05:44:53 EDT
(In reply to Miroslav Grepl from comment #2)
> The problem is the realmd is not running with the correct labeling.
> 
> Stef, 
> is there a patch change in F20?

There is currently no difference between realmd in F19 and F20. Closing this. 

Niel, please reopen if we've incorrectly diagnosed the issue. It seems like we've tracked down all the other SELinux realmd related issues. But we welcome any further reports of such failures in corner cases.

Note You need to log in before you can comment on or make changes to this bug.