Bug 963019 - SELinux is preventing /usr/lib64/realmd/realmd from 'execute_no_trans' accesses on the file /usr/lib64/realmd/realmd.
SELinux is preventing /usr/lib64/realmd/realmd from 'execute_no_trans' access...
Status: CLOSED DUPLICATE of bug 963018
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:61af1185c6e33b9d15ea68e671e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 21:43 EDT by Neil
Modified: 2013-05-20 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 04:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil 2013-05-14 21:43:49 EDT
Description of problem:
SELinux is preventing /usr/lib64/realmd/realmd from 'execute_no_trans' accesses on the file /usr/lib64/realmd/realmd.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/usr/lib64/realmd/realmd default label should be realmd_exec_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /usr/lib64/realmd/realmd

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that realmd should be allowed execute_no_trans access on the realmd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep realmd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:lib_t:s0
Target Objects                /usr/lib64/realmd/realmd [ file ]
Source                        realmd
Source Path                   /usr/lib64/realmd/realmd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           realmd-0.14.1-1.fc20.x86_64
Target RPM Packages           realmd-0.14.1-1.fc20.x86_64
Policy RPM                    selinux-policy-3.12.1-43.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc1.git2.2.fc20.x86_64 #1
                              SMP Tue May 14 05:16:42 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-14 18:31:41 PDT
Last Seen                     2013-05-14 18:31:41 PDT
Local ID                      4c17cf47-d4f4-429f-a3a4-37b8f605dcad

Raw Audit Messages
type=AVC msg=audit(1368581501.816:358): avc:  denied  { execute_no_trans } for  pid=1116 comm="dbus-daemon-lau" path="/usr/lib64/realmd/realmd" dev="dm-1" ino=410399 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:lib_t:s0 tclass=file


type=SYSCALL msg=audit(1368581501.816:358): arch=x86_64 syscall=execve success=yes exit=0 a0=7fd9ef9a5910 a1=7fd9ef9a5810 a2=7fd9ef9a4010 a3=0 items=0 ppid=1115 pid=1116 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=realmd exe=/usr/lib64/realmd/realmd subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: realmd,system_dbusd_t,lib_t,file,execute_no_trans

audit2allow

#============= system_dbusd_t ==============
allow system_dbusd_t lib_t:file execute_no_trans;

audit2allow -R
require {
	type lib_t;
	type system_dbusd_t;
	class file execute_no_trans;
}

#============= system_dbusd_t ==============
allow system_dbusd_t lib_t:file execute_no_trans;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc1.git2.2.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-15 04:54:24 EDT

*** This bug has been marked as a duplicate of bug 963018 ***
Comment 2 Fedora Admin XMLRPC Client 2013-05-20 12:32:50 EDT
The Fedora 20 component was created in error. We only create new Fedora versions when we branch a new release. These bugs are all being moved to rawhide. 

Please retarget them to 19 if they also apply to the Fedora 19 branched release. 

Thanks.

Note You need to log in before you can comment on or make changes to this bug.