Bug 963059 - Anaconda on Fedora 19 doesn't have option for setup HOSTNAME and NETWORK layout
Anaconda on Fedora 19 doesn't have option for setup HOSTNAME and NETWORK layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-05-15 00:55 EDT by Nix\
Modified: 2013-06-11 23:38 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-19.30.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 23:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nix\ 2013-05-15 00:55:36 EDT
Description of problem:

On the new Anaconda, it's not available from liveinst to setup a hostname for the installation.

While the DVD has the option for the hostname and network setup, the LiveCD doesn't.
It's reasonable that is configurable from the DE (gnome, KDE, XFCE, MATE, LXDE), but it's not the traditional way for any distribution.

If the Anaconda installer doesn't have the option because of programation or design causes, then it should have a big text/advice or similar announcing that hostname and/or network should be configured before installing Fedora, otherwise a lot of users, would install Fedora and then discover that their system is called "localhost.localdomain" and that they weren't asked to enter one.

The general user doesn't know how to setup the hostname by using hostnamectl command, and a LOT of users are asking on #fedora channel in freenode network (and I quote) "I installed Fedora and it never asked me for a hostname, my PC is called localhost.localdomain, why is that?".

If the design team, designed Anaconda this way, against the logic, then it's necessary a text/advisory, alerting that the user must configure the hostname, network and other stuff using the DE before installing Fedora using liveinst.

The LiveCD it's not only for testing purposes, the Fedora Spins, are in LiveCD format, and a lot of users, download the LiveCD for bandwith reason too, like LiveCD of gnome.

So, I would suggest to add any kind of text or warning on Anaconda for LiveCD format about the absence of hostname and network setup during the installation, making it more understandable for the novice user.

Version-Release number of selected component (if applicable):

Fedora 19

How reproducible:
Always

Steps to Reproduce:
1.Download a LiveCD of any Spin
2.Install it
3.See the localhost.localdomain when the login is showed
  
Actual results:

It's required additional steps after installation for setup hostname and personal network configuration/layout. So, what's the sense of Anaconda, if it doesn't fulfill all functions of a installator system.

Expected results:

Add some alert/warning/text advising about the absence of configurability of hostname and network during installation.

Additional info:

The ideal solution would be to either add a button or field text to write the hostname or access the network setup during the installation. If this is not possible, then I strongly recommend at least to add a warning regarding the lack of that setup option as I previously mentioned on the "Description of problem".
Comment 2 Nix\ 2013-05-15 01:33:25 EDT
Other good idea is add some post-installation screen, like the old Anaconda, asking for the hostname, network, and adding releases notes for promotion and information. If the problem is that the liveCD make some conflict with the network configuration of networkmanager and the network/hostname of the Anaconda, the post-installation is a good place for configure it and finish correctly the installation without any additional setup not knowed for novice users.
Comment 3 xset1980 2013-05-15 18:13:31 EDT
Indeed, I think it's a major flaw in the absence of hostname and network configurability in LiveCD format, support the suggestion of Nix\.
Comment 4 xset1980 2013-05-16 03:05:08 EDT
Another idea, i think, is that if the problem is the conflicts between networkmanager and the Anaconda network setup, create a first screen for select "Try Live or Install", and solve the problem between both network configurators.

Kubuntu installer has the feature (Install or Try).
I understand that may be networmanager this is troublesome with Anaconda network configurator (in LiveCD, not DVD because this no occurs -no NM present-, is understandable), so, if is not possible modify Anaconda for add hostname, network and (would be too much to request?) grub password, or add a text or advisory, maybe add a traditional Anaconda with host and net not hidden for install and other anaconda with net and host hidden for try in live mode and not install Fedora.
Comment 5 Germán Racca 2013-05-16 15:27:50 EDT
I agree with Nix. There are people whose primary source of installation is the Fedora LiveCD because of bandwidth limitations. To add a field in which the user can put the hostname in the LiveCD is really a good idea.
Comment 6 Nix\ 2013-05-17 03:46:27 EDT
In addition, I can see that running anaconda from a installed Fedora 19 from liveCD, show me full options, network configuration, and more, so, is a full anaconda. Why the Anaconda of the LiveCD medium looks like a anorexic installer?. What is the fundamented and strong reason for cut 90% of the options of Anaconda in LiveCD medium?.
Comment 7 Radek Vykydal 2013-05-21 10:19:14 EDT
(In reply to Nix\ from comment #6)
> In addition, I can see that running anaconda from a installed Fedora 19 from
> liveCD, show me full options, network configuration, and more, so, is a full
> anaconda. Why the Anaconda of the LiveCD medium looks like a anorexic
> installer?. What is the fundamented and strong reason for cut 90% of the
> options of Anaconda in LiveCD medium?.

Because (apart from Network configuration) they are all effectively set by using LiveCD installation method
INSTALLATION SOURCE: liveCD image
SOFTWARE SELECTION: liveCD image content
LANGUAGE SUPPORT: liveCD image content (= no additional support)
Comment 8 Radek Vykydal 2013-05-21 10:23:56 EDT
I see using Live desktop environment for network configuration as better option both for technical reasons (problems that can arise from mixed using of installer's and DE configuration tools) and for user experience reasons - using the same (DE) tool during installation and in installed system. Nevertheless, adding a hint to use DE tools seems like a good idea.

As for hostname setting, we could add it to the hint but in this case I think we could offer the setting in Anaconda too. (Re)design of the entry placement would require some time, people, and expertise. For F19 I think this option might work:

In LiveCD, present always standalone Network Configuration pre-hub screen (in other types of install it is showed only if there is no network connection, which is needed for install) modified to show hint about network configuration and hostname setting entry: http://rvykydal.fedorapeople.org/live_network_hostname.webm

Further discussion of this issue should happen on anaconda-devel-list to get broader audience/input.
Comment 9 Nix\ 2013-05-29 04:48:37 EDT
(In reply to Radek Vykydal from comment #8)
> I see using Live desktop environment for network configuration as better
> option both for technical reasons (problems that can arise from mixed using
> of installer's and DE configuration tools) and for user experience reasons -
> using the same (DE) tool during installation and in installed system.
> Nevertheless, adding a hint to use DE tools seems like a good idea.
> 
> As for hostname setting, we could add it to the hint but in this case I
> think we could offer the setting in Anaconda too. (Re)design of the entry
> placement would require some time, people, and expertise. For F19 I think
> this option might work:
> 
> In LiveCD, present always standalone Network Configuration pre-hub screen
> (in other types of install it is showed only if there is no network
> connection, which is needed for install) modified to show hint about network
> configuration and hostname setting entry:
> http://rvykydal.fedorapeople.org/live_network_hostname.webm
> 
> Further discussion of this issue should happen on anaconda-devel-list to get
> broader audience/input.

@ Radek Vykydal

I see the video pasted by you, and is a perfect idea, i see that you understand me perfectly!. Actually hostname is never asked in the installation of LiveCD media and is not clear that the user must configure the network with live tools, in the webm video recorded by you is clear the message about "configure network using...", perfect!.

So, in gnome media is easy, in KDE the live tools (network manager kde plasmoid) is a bit difficult for configure it, but the KDE users know how configure the network i guess.

You recomend me that move the bug report to anaconda-devel-list, let me how, because i have a fas account, but i no know how move the actual bug with comments and you comment (the video is the best evidence that anaconda is modifiable).

Maybe the change is not done for F19 release, but yes for F20. Maybe yes, and would be really a great improvement i guess for fedora users.

Thanks a lot for the time and for the test and video Radek. Is really nice report bug and work with people like you.
Comment 10 Nix\ 2013-05-29 12:16:18 EDT
@Radek Vykydal

Please alert me (via mail, irc or bugzilla) when you send the patch, screencast and proposal/suggestion/bug/feature to the lists to continue the evolution of it for watch and answer any question of any people if is required about why the bug report and the logic used for it.

Thank you.

freenode: nix\
Comment 11 Radek Vykydal 2013-05-30 03:13:30 EDT
(In reply to Nix\ from comment #10)
> @Radek Vykydal
> 
> Please alert me (via mail, irc or bugzilla) when you send the patch,
> screencast and proposal/suggestion/bug/feature to the lists to continue the
> evolution of it for watch and answer any question of any people if is
> required about why the bug report and the logic used for it.
> 
> Thank you.
> 
> freenode: nix\

http://www.redhat.com/archives/anaconda-devel-list/2013-May/msg00062.html
Comment 12 Nix\ 2013-05-30 17:14:51 EDT
(In reply to Radek Vykydal from comment #11)
> (In reply to Nix\ from comment #10)
> > @Radek Vykydal
> > 
> > Please alert me (via mail, irc or bugzilla) when you send the patch,
> > screencast and proposal/suggestion/bug/feature to the lists to continue the
> > evolution of it for watch and answer any question of any people if is
> > required about why the bug report and the logic used for it.
> > 
> > Thank you.
> > 
> > freenode: nix\
> 
> http://www.redhat.com/archives/anaconda-devel-list/2013-May/msg00062.html

Thanks for the feedback Radek, is good to see that was accepted. I suggest to add something to the original text proposed by Chris Lummes:

Original text from C. Lummes: "Please use the live desktop environment's tools for customizing your network configuration.  You can set the hostname here"

My suggestion: "Please use the live desktop environment's tools for customizing your network configuration before installing.  You can set the hostname here"

Added: "before installing"

To translate to Spanish (my native language, for the l10n fedora team) will be:

"Please use the live desktop environment's tools for customizing your
network configuration.  You can set the hostname here" 

               >> translated to spanish >>

"Por favor utilice las herramientas del entorno Live Desktop para personalizar su configuración de red. Puede establecer el nombre de host aquí."

Live Desktop environment is not 100% translatable to Spanish, because Live Desktop environment translated is: "Entorno de escritorio vivo", and "escritorio vivo" in spanish loses its meaning because "vivo" in spanish is used for "alive" in english, so, "vivo" is used for alive things like pets, humans, etc, no for things like a CD or OS.

Maybe "escritorio activo" (my favorite) or "medio vivo" are the best choices. I would like to know the opinion of those responsible of translations.

Option 1: "Por favor utilice las herramientas del entorno Live Desktop para personalizar su configuración de red. Puede establecer el nombre de host aquí."

Option 2: "Por favor utilice las herramientas del entorno vivo para personalizar su configuración de red. Puede establecer el nombre de host aquí."

Option 3: "Por favor utilice las herramientas del escritorio activo para personalizar su configuración de red. Puede establecer el nombre de host aquí."

Option 4: "Por favor utilice las herramientas del entorno Live CD para personalizar su configuración de red. Puede establecer el nombre de host aquí."

The most common users understand Live CD or Live Desktop very well, but is the traslation will be 100% of the en_US text i suggest some of the four options.

Regards
Comment 13 Nix\ 2013-05-31 21:44:03 EDT
@Radek Vykydal

I was reading the Emails that I got from anaconda-devel-list@redhat.com and I could observe that there is a patch called "0001-Add-modified-network-spoke-to-LiveDVD-963059.patch". As far as I understood from looking at the patch and reading the Emails, I see that it has been added a new functionality to the ones suggested in this bug report (hostname setup and text reminder about configure network on DE tools), that it seems to be an interactive "dialog box" that reflects the Live DVD network status on real time, did I get it right?.
Comment 14 Adam Williamson 2013-06-05 13:46:17 EDT
nix: that's basically it, yes. See the thread https://www.redhat.com/archives/anaconda-devel-list/2013-May/msg00062.html also .
Comment 15 Adam Williamson 2013-06-05 13:48:09 EDT
Discussed at 2013-06-05 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-05/f19final-blocker-review-3.2013-06-05-16.05.log.txt . Accepted as a freeze exception issue: the difficulty of setting hostname on live installs is something it would make sense to solve for final, and it's also nice to make it more clear to users that they can use the host desktop's configuration tools for the network. These are both beneficial changes to have in 19 final for sure.
Comment 16 Fedora Update System 2013-06-06 14:37:27 EDT
anaconda-19.30.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.3-1.fc19
Comment 17 Fedora Update System 2013-06-07 11:42:04 EDT
Package anaconda-19.30.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10283/anaconda-19.30.3-1.fc19
then log in and leave karma (feedback).
Comment 18 Nix\ 2013-06-11 00:55:12 EDT
Works well and fix the initial bug, but, network configuration item is under SOFTWARE section.
Reported bug as #973013 waiting for a fix.
Comment 20 Fedora Update System 2013-06-11 23:38:25 EDT
anaconda-19.30.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.