Bug 973013 - Network Configuration is under Software section in Fedora 19
Network Configuration is under Software section in Fedora 19
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 00:54 EDT by Nix\
Modified: 2014-01-08 11:38 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 11:38:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot pointed the bug. (111.75 KB, image/png)
2013-06-11 00:54 EDT, Nix\
no flags Details
a patch creating new network category (2.94 KB, text/plain)
2013-06-17 05:56 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Nix\ 2013-06-11 00:54:07 EDT
Created attachment 759421 [details]
Screenshot pointed the bug.

Description of problem:
The patch for setup the hostname and network in live mode work well. Hostname is configurable and a text say that live desktop enviroments tools should be used for configure the network.

The bug is that NETWORK CONFIGURATION item is under SOFTWARE section.

Version-Release number of selected component (if applicable):

Fedora 19 TC2
Anaconda 19.30.3-1

How reproducible:
Always


Steps to Reproduce:
1.Boot from a live DVD or CD of Fedora 19
2.Open a terminal, log as root, and execute: # yum update --enablerepo=updates-testing anaconda. The new version installed will be 19.30.3-1
3.Execute liveinst from another terminal or the same, but not as root.

Actual results:

Network Configuration item is under software section in Anaconda 19.30.3-1

Expected results:

Network Configuration under network or related section, no software.

Additional info:
Attach screenshot.
Comment 1 Adam Williamson 2013-06-14 18:24:54 EDT
Confirmed (in 19.30.7 still), this looks kinda weird and we really ought to fix it.
Comment 2 Nix\ 2013-06-15 02:13:44 EDT
(In reply to Adam Williamson from comment #1)
> Confirmed (in 19.30.7 still), this looks kinda weird and we really ought to
> fix it.

Yes Adam. Please check and push if you can the bug https://bugzilla.redhat.com/show_bug.cgi?id=974736

Anaconda totally crash for a unicode bug.

Regards

Nix\
Freenode: #fedora #fedora-social
nix-sasl@gmail.com
Comment 3 Radek Vykydal 2013-06-17 05:56:06 EDT
Created attachment 761976 [details]
a patch creating new network category

Chris, what do you think? I whipped up this patch, adding new Network category for Network Spoke in Live CD.

http://rvykydal.fedorapeople.org/network_category.png

Is it too hacky?
Is the NETWORK description of the category too silly?
Does the category deserve its existence on LiveCD (we only point to DE tools in the spoke)?
Comment 4 Chris Lumens 2013-06-17 14:59:21 EDT
If we're going to move network out from under software (which is fine), I think we should take a more broad look at the categories.  I don't like storage being in its own category, and I think having networking in its own category as well might be too much.  Perhaps there's a way to combine storage and networking somehow into one more broad category?
Comment 5 Adam Williamson 2013-06-17 15:16:21 EDT
If this is going to be anything more than just a small tweak, we should probably make it F20 stuff. It looks a bit untidy for F19 but it does the job as is, and we're getting closer to go/no-go.
Comment 6 Nix\ 2013-06-20 02:54:19 EDT
Maybe a new category for storage and networking in liveCD mode, HARDWARE STUFF?.
Comment 7 Chris Lumens 2013-06-20 11:44:41 EDT
I'd prefer to think on the wording a bit and not worry with this for F19.
Comment 8 Adam Williamson 2013-06-20 19:54:57 EDT
OK, then as the person who nominated it for FE, I withdraw the nomination.
Comment 9 Nix\ 2013-06-21 05:10:11 EDT
A word that involve networking and storage... no idea, except hardware stuff.
Devices, Transfer Data Devices, Data Transfer Devices
Comment 10 Adam Williamson 2013-06-21 12:29:56 EDT
Nix: you don't need to keep updating it for each build now, it's not going to be fixed for F19, we've moved it out to F20. thanks.
Comment 11 Nix\ 2013-06-25 01:47:29 EDT
(In reply to Adam Williamson from comment #10)
> Nix: you don't need to keep updating it for each build now, it's not going
> to be fixed for F19, we've moved it out to F20. thanks.

Adam Williamson,

All right!, if you want suggestions about new category/wording, please tell me, because I have a lot of ideas. Thank you.
Comment 12 Chris Lumens 2013-07-29 16:29:17 EDT
Well, I sent off a patch that changes the name to get the conversation restarted.  I don't necessarily really like what I picked though.

Note You need to log in before you can comment on or make changes to this bug.