Bug 963206 - Headpin Nightly : headpin cli refresh manifest failed
Headpin Nightly : headpin cli refresh manifest failed
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
:
Depends On: 975026 1009012
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-05-15 07:40 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:10:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (133.23 KB, application/x-gzip)
2013-05-15 08:11 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2013-05-15 07:40:37 EDT
Description of problem:
headpin cli refresh manifest failed 

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-configure-1.4.3-1.git.17.b0067d4.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.333.d2a35bc.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-common-1.4.2-1.git.333.d2a35bc.el6.noarch
katello-headpin-1.4.2-1.git.333.d2a35bc.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-headpin-all-1.4.2-1.git.333.d2a35bc.el6.noarch
katello-cli-1.4.2-1.git.48.441089b.el6.noarch
katello-glue-candlepin-1.4.2-1.git.333.d2a35bc.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin

Steps to Reproduce:
1.Create a org
  # headpin -u admin -p *** org create --name testorg
    Successfully created org [ testorg ]

2.Import manifest
  # headpin -u admin -p *** provider import_manifest --org testorg --name     
'Red Hat' --file '/tmp/manifest_refresh.zip'
Provider [ Red Hat ] manifest import complete

3.Add/modify the no of subscription on redhat customer portal


4.# headpin -u admin -p *** provider refresh_manifest --org testorg --name 'Red Hat'
Provider [ Red Hat ] failed to refresh manifest: U

  
Actual results:
Refresh manifest failed

Expected results:
Refresh manifest worked successfully

Additional info:
Comment 1 Tazim Kolhar 2013-05-15 08:11:24 EDT
Created attachment 748243 [details]
katello-debug
Comment 2 Tom McKay 2013-07-15 13:23:36 EDT
This should be working now, please re-test.
Comment 3 sthirugn@redhat.com 2013-07-22 09:59:49 EDT
This will not work until https://bugzilla.redhat.com/show_bug.cgi?id=975026 is fixed
Comment 4 Bryan Kearney 2013-08-02 14:52:20 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 5 Tazim Kolhar 2013-08-07 04:45:45 EDT
This will not work until https://bugzilla.redhat.com/show_bug.cgi?id=990699 is fixed
Comment 6 Tazim Kolhar 2013-08-08 08:04:29 EDT
VERIFIED :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch

# headpin -u admin -p admin provider import_manifest --org test --name 'Red Hat' --file '/root/manifest_refresh.zip'
Provider [ Red Hat ] manifest import complete

# headpin -u admin -p admin provider refresh_manifest --org test --name 'Red Hat'
Provider [ Red Hat ] manifest refresh complete
Comment 8 errata-xmlrpc 2013-10-01 07:10:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.