Bug 963329 - Error after successful login in free IPA configuration
Error after successful login in free IPA configuration
Status: CLOSED DUPLICATE of bug 966256
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 12:39 EDT by sthirugn@redhat.com
Modified: 2013-05-30 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 07:43:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error after successful log in (38.19 KB, image/png)
2013-05-15 12:39 EDT, sthirugn@redhat.com
no flags Details
production.log (9.95 KB, application/octet-stream)
2013-05-15 12:40 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-05-15 12:39:01 EDT
Created attachment 748407 [details]
Error after successful log in

Description of problem:
Error after successful login in free IPA configuration

Version-Release number of selected component (if applicable):
* candlepin-0.8.7-1.el6.noarch
* candlepin-selinux-0.8.7-1.el6.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-all-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.48.441089b.el6.noarch
* katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
* katello-common-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-configure-1.4.3-1.git.17.b0067d4.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-pulp-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install katello nightly
2. Use free IPA configuration in katello-configure
katello-configure --user-name=$user --user-email=$email --ldap-server=$server --auth-method=ldap --ldap-port=389 --ldap-server-type='free_ipa' --ldap-users-basedn=$usersbasedn --ldap-group-basedn=$groupsbasedn --ldap-roles=true --ldap-anon-queries=false --ldap-service-user=$serviceuser --ldap-service-pass='$servicepass --ldap-encryption=start_tls
3. Log in to Web UI with the correct free ipa user credentials
  
Actual results:
Log in is successful but an error is displayed in the homepage which prevents further navigation (see screenshot and log)

Expected results:
Log in is successful without any error in homepage

Additional info:
This was discovered while retesting https://bugzilla.redhat.com/show_bug.cgi?id=963272
Comment 1 sthirugn@redhat.com 2013-05-15 12:40:51 EDT
Created attachment 748409 [details]
production.log
Comment 2 Marek Hulan 2013-05-16 11:08:33 EDT
This seems to be a bug in ldap_fluff 0.1.3, could you please test with new version that was built few moments ago? You can find it here http://koji.katello.org/koji/taskinfo?taskID=35729 even before it gets into repository. Please restart katello after ldap_fluff update.
Comment 3 Marek Hulan 2013-05-30 03:51:51 EDT
Seems as a duplication for bug 966256
Comment 4 Bryan Kearney 2013-05-30 07:43:53 EDT

*** This bug has been marked as a duplicate of bug 966256 ***

Note You need to log in before you can comment on or make changes to this bug.