Bug 963408 - rpm repos can be synced with iso sync run
rpm repos can be synced with iso sync run
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
Master
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
: 997186 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 14:21 EDT by Preethi Thomas
Modified: 2015-02-28 16:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:55:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 350 None None None Never

  None (edit)
Description Preethi Thomas 2013-05-15 14:21:54 EDT
Description of problem:

If you run iso sync run on a rpm repo. The progress is not reported but if you see the log, you see the sync is running.

Version-Release number of selected component (if applicable):
[root@ibm-x3550m3-07 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.5.alpha.el6.noarch


How reproducible:


Steps to Reproduce:
1. Create a rpm and run rpm repo sync
2. Run iso repo sync run on the above repo
3. tail the pulp.log
  
Actual results:

[root@ibm-x3550m3-07 ~]# pulp-admin iso repo sync run --repo-id myepel-repo
+----------------------------------------------------------------------+
                 Synchronizing Repository [myepel-repo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Expected results:


Additional info:
Comment 3 Chris Duryee 2014-11-07 17:17:11 EST
*** Bug 997186 has been marked as a duplicate of this bug. ***
Comment 4 Chris Duryee 2014-11-07 17:17:58 EST
bz is still outstanding as of 2.5.0
Comment 5 Brian Bouterse 2015-02-28 16:55:04 EST
Moved to https://pulp.plan.io/issues/350

Note You need to log in before you can comment on or make changes to this bug.