Bug 963480 - fv_ tests INCOMPLETE after the first run on a data image
fv_ tests INCOMPLETE after the first run on a data image
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
: 962859 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 17:15 EDT by Greg Nichols
Modified: 2013-07-31 06:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: hwcert-client-1.5.9-33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 06:01:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fvtest.py patch to handle and ignore existing symlink (722 bytes, patch)
2013-05-15 17:21 EDT, Greg Nichols
no flags Details | Diff
additional patch - clean up hwcert package removal on guest (724 bytes, patch)
2013-05-15 20:53 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-05-15 17:15:49 EDT
Description of problem:

fv_tests on the guest don't run and are marked INCOMPLETE after an initial run.

The problem is a crash that occurs when the test (on the host) tries to initialize the data image for the run, and attempts to create a symlink that may already exist (v7-guest-script) and raise a "File Exists" exception.


Version-Release number of selected component (if applicable):

hwcert-client 1.5 R31
Comment 2 Greg Nichols 2013-05-15 17:21:33 EDT
Created attachment 748517 [details]
fvtest.py patch to handle and ignore existing symlink
Comment 3 Greg Nichols 2013-05-15 20:53:21 EDT
Created attachment 748541 [details]
additional patch - clean up hwcert package removal on guest

Patch is on R32
Comment 4 Greg Nichols 2013-05-16 09:35:19 EDT
Patches committed to R33
Comment 7 Greg Nichols 2013-05-24 10:32:06 EDT
*** Bug 962859 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2013-07-31 06:01:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1125.html

Note You need to log in before you can comment on or make changes to this bug.