Bug 962859 - FV tests incorrectly report "INCOMPLETE" test status
FV tests incorrectly report "INCOMPLETE" test status
Status: CLOSED DUPLICATE of bug 963480
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 11:25 EDT by James Pigott
Modified: 2013-05-24 10:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 10:32:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Pigott 2013-05-14 11:25:42 EDT
Description of problem: The FV tests appear to report an incorrect status when run together with the rest of the certification kit. If you go to /var/lib/xen/images and delete the VM data images, each test will pass if you run them separately.


Version-Release number of selected component (if applicable): hwcert-client-1.5.9-28


How reproducible: Every time


Steps to Reproduce:
1. Run entire test suite
2. Delete files in /var/lib/xen/images
3. Run fv tests marked as incomplete one at a time, deleting the images between runs.
  
Actual results: fv_network will show as incomplete


Expected results: All FV tests pass


Additional info:
Comment 1 Mark Coskey 2013-05-14 15:48:51 EDT
Above testing was done on a RHEL5.9 x86_64 SUT.
The pre-built VM used was hwcert-x86_64.img.tar.bz2
The data image was hwcertData-20130409.img.tar.bz2 
Both downloaded from ftp://partners.redhat.com/a166eabc5cf5df158922f9b06e5e7b21/hwcert/RHEL5/fv-images/

Once the above prebuilt VM is installed on the SUT from the remote test server the first fv_xxx test will pass, but the other three fv_xxx tests report incomplete. If the prebuilt VM is removed from the SUT between each of the fv_xxx remaining tests, only then will all fv_xxx tests pass.
Comment 2 Greg Nichols 2013-05-24 10:32:06 EDT

*** This bug has been marked as a duplicate of bug 963480 ***

Note You need to log in before you can comment on or make changes to this bug.