Bug 963548 - Met "Node execution failure" error when creating ruby on rails application.
Met "Node execution failure" error when creating ruby on rails application.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 963939 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 02:49 EDT by Yujie Zhang
Modified: 2015-05-14 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 23:58:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-05-16 02:49:22 EDT
Description of problem:

When creating ruby on rails application, met node execution failure error. 

Version-Release number of selected component (if applicable):

devenv-stage_353
STG(devenv-stage_351)

How reproducible:
always

Steps to Reproduce:
1. Login to openshift console
2. Try to create ruby on rails application
3.
  
Actual results:

Met "node execution failure" error when creating ruby on rails application.

[root@dhcp-8-252 home]# rhc app create rubyonrails345 ruby-1.9 mysql-5.1 --from-code git://github.com/openshift/rails-example.git 
Please sign in to start a new session to
ec2-174-129-134-12.compute-1.amazonaws.com.
Password: *


Checking your namespace ... none

Your namespace is unique to your account and is the suffix of the public URLs we
assign to your applications. You may configure your namespace here or leave it
blank and use 'rhc create-domain' to create a namespace later.  You will not be
able to create applications without first creating a namespace.

Please enter a namespace (letters and numbers only): aaa
Your domain name 'aaa' has been successfully created

Application Options
-------------------
  Namespace:   aaa
  Cartridges:  ruby-1.9, mysql-5.1
  Source Code: git://github.com/openshift/rails-example.git
  Gear Size:   default
  Scaling:     no

Creating application 'rubyonrails345' ... 
Unable to complete the requested operation due to: Node execution failure
(invalid exit code from node).  If the problem persists please contact Red Hat
support..
Reference ID: cf825093ae9f7d49962fb43a0237a1e3

Expected results:

Should be able to create ruby on rails application successfully.

Additional info:
Comment 1 Yujie Zhang 2013-05-16 04:08:54 EDT
The version is as following,sorry for the mistake:

Version-Release number of selected component (if applicable):
devenv-stage_353
STG(devenv-stage_353)
Comment 2 Dan McPherson 2013-05-16 23:59:31 EDT
There was an outage on rubygems.org I believe that was causing this issue.  Can you please retest.
Comment 3 Xiaoli Tian 2013-05-17 00:58:15 EDT
*** Bug 963939 has been marked as a duplicate of this bug. ***
Comment 4 Yujie Zhang 2013-05-17 05:25:29 EDT
Tested on STG again, ruby on rails can be created and accessed successfully, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.