Bug 963625 - ValueError: cannot initialize a disk that has partitions
ValueError: cannot initialize a disk that has partitions
Status: CLOSED DUPLICATE of bug 957188
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:a4f5bbf06d01dcbbdf1c93ba979...
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-16 05:34 EDT by Martin Banas
Modified: 2013-05-16 13:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 13:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (321.29 KB, text/plain)
2013-05-16 05:34 EDT, Martin Banas
no flags Details
File: anaconda.log (6.39 KB, text/plain)
2013-05-16 05:34 EDT, Martin Banas
no flags Details
File: backtrace (1.03 KB, text/plain)
2013-05-16 05:34 EDT, Martin Banas
no flags Details
File: environ (1019 bytes, text/plain)
2013-05-16 05:34 EDT, Martin Banas
no flags Details
File: ifcfg.log (1.13 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: ks.cfg (6.68 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: lsblk_output (1.42 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: nmcli_dev_list (4.78 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: packaging.log (22.00 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: program.log (21.59 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: storage.log (61.22 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details
File: syslog (105.70 KB, text/plain)
2013-05-16 05:35 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2013-05-16 05:34:50 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 803, in initializeDisk
    raise ValueError("cannot initialize a disk that has partitions")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 778, in clearPartitions
    self.initializeDisk(disk)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 412, in execute
    storage.clearPartitions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1561, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 392, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
ValueError: cannot initialize a disk that has partitions

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   repo=http://mirrors.nebo.edu/public/fedora/linux/development/19/i386/os/ stage2=http://dl.fedoraproject.org/pub/alt/stage/19-Beta-TC4/Fedora/i386/os/ lang=en_US.UTF-8 keymap=us ip=eth0:dhcp ifname=eth0:00:16:35:5c:e7:fe vnc recipeid=878945 ks=http://rtt1.s390.bos.redhat.com/nb/10.12.0.47-1368693748 console=ttyS0,115200 serial
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 392, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1561, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 412, in execute
    storage.clearPartitions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 778, in clearPartitions
    self.initializeDisk(disk)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 803, in initializeDisk
    raise ValueError("cannot initialize a disk that has partitions")
ValueError: cannot initialize a disk that has partitions

Potential duplicate: bug 914723
Comment 1 Martin Banas 2013-05-16 05:34:52 EDT
Created attachment 748700 [details]
File: anaconda-tb
Comment 2 Martin Banas 2013-05-16 05:34:55 EDT
Created attachment 748701 [details]
File: anaconda.log
Comment 3 Martin Banas 2013-05-16 05:34:56 EDT
Created attachment 748702 [details]
File: backtrace
Comment 4 Martin Banas 2013-05-16 05:34:58 EDT
Created attachment 748703 [details]
File: environ
Comment 5 Martin Banas 2013-05-16 05:35:01 EDT
Created attachment 748704 [details]
File: ifcfg.log
Comment 6 Martin Banas 2013-05-16 05:35:03 EDT
Created attachment 748705 [details]
File: ks.cfg
Comment 7 Martin Banas 2013-05-16 05:35:04 EDT
Created attachment 748706 [details]
File: lsblk_output
Comment 8 Martin Banas 2013-05-16 05:35:06 EDT
Created attachment 748707 [details]
File: nmcli_dev_list
Comment 9 Martin Banas 2013-05-16 05:35:08 EDT
Created attachment 748708 [details]
File: packaging.log
Comment 10 Martin Banas 2013-05-16 05:35:10 EDT
Created attachment 748709 [details]
File: program.log
Comment 11 Martin Banas 2013-05-16 05:35:12 EDT
Created attachment 748710 [details]
File: storage.log
Comment 12 Martin Banas 2013-05-16 05:35:14 EDT
Created attachment 748711 [details]
File: syslog
Comment 13 David Lehman 2013-05-16 13:50:33 EDT
The root cause of this is kpartx bug 957188 -- once that makes it into the first post-beta trees this will no longer be an issue.

*** This bug has been marked as a duplicate of bug 957188 ***

Note You need to log in before you can comment on or make changes to this bug.