Bug 957188 - kpartx should always base partition delimiter decision on map name
kpartx should always base partition delimiter decision on map name
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 962831 963625 (view as bug list)
Depends On:
Blocks: F19Beta/F19BetaBlocker fedora19rtt F19PPCBeta/F19PPCBetaBlocker/PPCBetaBlocker
  Show dependency treegraph
 
Reported: 2013-04-26 10:39 EDT by David Lehman
Modified: 2014-12-08 16:39 EST (History)
16 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-51.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 21:59:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-04-26 10:39:05 EDT
Description of problem:
kpartx has logic for when to use disk/partition delimiter of 'p'. It's based on whether the disk's name ends with a digit (use 'p') or not (no delimiter). This is behavior relied on by other tools such as parted. When invoked from udev rules, argv always includes a device node of the form "/dev/dm-X" where X is a digit. As a result, kpartx ends up always using a delimiter when invoked from udev rules. It should look up the map name that corresponds to the dm device and base the delimiter decision on that instead.

Version-Release number of selected component (if applicable):
Whatever's in f19 as of now.

How reproducible:
Always

Steps to Reproduce:
1. Start up a system with multipath and multipathd
2. Observe the names in /dev/mapper for the partitions on that mpath
3.
  
Actual results:
Even if the disk is named 'mpatha' the first partition will be named 'mpathap1'.

Expected results:
The first partition on 'mpatha' should be 'mpatha1'.

Additional info:
Comment 1 Mark Hamzy 2013-04-26 10:41:49 EDT
Proposing as a FinalBlocker:

The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)
Comment 2 Phil Knirsch 2013-04-30 10:40:42 EDT
Could someone from the LVM team please take a look at this? This will surely be a blocking issue for RHEL-7, so getting this fixed for Fedora 19 will make testing it and ensuring it works in RHEL-7 much easier.

Thanks & regards, Phil
Comment 3 Ben Marzinski 2013-04-30 20:18:30 EDT
This has been fixed.  kpartx will now use the basename of the device it is creating to determine the delimiter instead of the device name is was called with.
Comment 4 Fedora Update System 2013-04-30 20:23:40 EDT
device-mapper-multipath-0.4.9-50.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/device-mapper-multipath-0.4.9-50.fc19
Comment 5 David Lehman 2013-04-30 21:10:06 EDT
Thanks for the quick turnaround, Ben.
Comment 6 Fedora Update System 2013-05-01 16:44:14 EDT
Package device-mapper-multipath-0.4.9-50.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing device-mapper-multipath-0.4.9-50.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7197/device-mapper-multipath-0.4.9-50.fc19
then log in and leave karma (feedback).
Comment 7 David Lehman 2013-05-16 13:50:33 EDT
*** Bug 963625 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2013-05-16 14:09:45 EDT
Switching to a Beta blocker proposal: dlehman says this breaks dmraid, and Beta criteria say:

https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Hardware_and_firmware_RAID

The installer must be able to detect and install to hardware or firmware RAID storage devices.
Comment 9 Adam Williamson 2013-05-16 14:10:24 EDT
<dlehman> that will prevent any install to dmraid or mpath AIUI
Comment 10 Dennis Gilmore 2013-05-16 14:32:08 EDT
+1 for beta inclusion
Comment 11 Jaroslav Reznik 2013-05-16 14:41:48 EDT
+1 blocker as it breaks dmraid
Comment 12 Adam Williamson 2013-05-16 17:33:35 EDT
3 +1s, setting accepted.
Comment 13 Fedora Update System 2013-05-20 12:10:34 EDT
device-mapper-multipath-0.4.9-51.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/device-mapper-multipath-0.4.9-51.fc19
Comment 14 Fedora Update System 2013-05-21 21:59:33 EDT
device-mapper-multipath-0.4.9-50.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-05-25 23:38:42 EDT
device-mapper-multipath-0.4.9-51.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 David Shea 2014-12-08 16:39:21 EST
*** Bug 962831 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.