Bug 963680 - dnf dies with a traceback during update
dnf dies with a traceback during update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 965338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 07:33 EDT by Jan Synacek
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: hawkey-0.3.13-2.git15db39f.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 00:38:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2013-05-16 07:33:30 EDT
Description of problem:
I didn't do anything special, just ran 'dnf update' on my rawhide machine and after a while, got this error:

...

(303/515): man-pages-3.51-1.fc20.noarch.rpm                                               | 5.0 MB  00:00:00     

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 303, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 212, in main
    return_code = base.doTransaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 192, in doTransaction
    self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 1206, in download_packages
    local = po.repo.get_package(po, text=text)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 318, in get_package
    handle.download(pkg.location)
  File "/usr/lib64/python2.7/site-packages/librepo/__init__.py", line 801, in download
    self.download_package(url, dest, checksum_type, checksum, base_url, resume)
_librepo.Exception: (11, 'Temporary error (operation timeout, ...), next try could work', None)


Version-Release number of selected component (if applicable):
dnf-0.3.3-3.git91ba5e0.fc20.noarch
librepo-0.0.2-3.20130408git720d68d.fc20.x86_64


Steps to Reproduce:
1. dnf update
2. # get lucky here
3. observe a traceback

  
Actual results:
Traceback.


Expected results:
No traceback - maybe an error if there is something really important, or deal with it and continue.
Comment 1 Ales Kozumplik 2013-05-16 08:12:30 EDT
There's a missing exception handler at the package download code after migrating to librepo. Thanks for catching this.
Comment 2 Ales Kozumplik 2013-05-17 04:34:02 EDT
Commit 9ae7a93 addresses this. It will be included in dnf-0.3.6.
Comment 3 Ales Kozumplik 2013-05-21 01:34:37 EDT
*** Bug 965338 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-05-27 09:21:51 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19
Comment 5 Fedora Update System 2013-05-27 13:03:53 EDT
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.6-1.git24ce938.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-29 13:49:08 EDT
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.7-1.gitf8bdc98.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/hawkey-0.3.13-2.git15db39f.fc19,dnf-0.3.7-1.gitf8bdc98.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-07 00:38:23 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.