Bug 963796 - String Update: use 'attach --auto' description for 'register --auto-attach' description
String Update: use 'attach --auto' description for 'register --auto-attach' d...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-16 10:48 EDT by Matt Reid
Modified: 2013-09-30 19:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:08:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2013-05-16 10:48:35 EDT
Description of problem:
Noticed that we missed cleaning up a period on one of the help cli strings the other day.

Can we save ourselves having to maintain two strings and replace the one from 'register --auto-attach' with what we use for 'attach --auto'?

Replace:
subscription-manager register --help description of --auto-attach
#: ../src/subscription_manager/managercli.py:943
msgid "automatically attach this system to compatible subscriptions."

With:
subscription-manager attach --help description of --auto
#: ../src/subscription_manager/managercli.py:1347
msgid "automatically attach compatible subscriptions to this system"


Version-Release number of selected component (if applicable):
subscription-manager 1.8.7-1.git
Comment 1 RHEL Product and Program Management 2013-05-16 10:59:46 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Cory Scheviak 2013-06-03 09:47:56 EDT
commit a7b3b85b5d507e2114be933e93b2fc1af33553f7
Author: cjschevi <cschevia@redhat.com>
Date:   Tue May 28 10:35:23 2013 -0400

    963796: Unified descriptions
Comment 4 Shwetha Kallesh 2013-06-04 02:13:17 EDT
Verified!!

[root@localhost ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.10-1
subscription-manager: 1.8.9-1.el5
python-rhsm: 1.8.12-1.el5
[root@localhost ~]# 


[root@localhost ~]# subscription-manager register --help | grep auto-attach -A1
  --autosubscribe       Deprecated, see --auto-attach
  --auto-attach         automatically attach compatible subscriptions to this
                        system


[root@localhost ~]# subscription-manager attach --help | grep auto -A1
  --auto                automatically attach compatible subscriptions to this
                        system
Comment 6 errata-xmlrpc 2013-09-30 19:08:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.