Bug 963816 - hpijs dependency on net-snmp causes it to be uninstalled when mysql* packages are removed
hpijs dependency on net-snmp causes it to be uninstalled when mysql* packages...
Status: CLOSED DUPLICATE of bug 895643
Product: Fedora
Classification: Fedora
Component: hpijs (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 11:26 EDT by Basil Mohamed Gohar
Modified: 2013-05-20 09:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 03:57:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Basil Mohamed Gohar 2013-05-16 11:26:40 EDT
Description of problem:
Back on April 29th, 2013 I ran the following command, `yum erase mysql*` as I wanted to install the mariadb packages instead.  Today (May 16th, 2013), I attempted to print and got the error message in the print dialog, "file "/usr/lib/cups/filter/hpcups" not available".  Running `yum provides /usr/lib/cups/filter/hpcups` shows that the file is provided by package hpijs, which was not installed.  Curious, because I'd printed many times from this computer, I installed the package, and low-and-behold, I could print again.

Consequently, I discovered that hpijs was uninstalled on April 29th, 2013, when I removed all mysql-related packages from my system.  When I installed hpijs, I noticed it has a dependency on net-snmp.  net-snmp WAS uninstalled, along with hpijs, on April 29th, 2013.

I think this dependency relationship should probably be removed, because removing mysql-related packages on a desktop/workstation almost certainly should *NOT* remove my ability to print!

Version-Release number of selected component (if applicable):
3.12.11

How reproducible:
Every...single...time...

Steps to Reproduce:
1. Install MySQL packages as well as net-snmp (maybe by dependencies), and also hpijs if it's not already installed.
2. run `yum erase mysql*`, and observe as hpijs washes away in the runoff.
3. *facepalm*
  
Actual results:
Removal of the database server and client software disables printing on HP printers

Expected results:
Removal of database server and client software does NOT disable printing on HP printers

Additional info:
I don't know why hpijs needs to rely on net-snmp, and/or why removal of mysql-related packages REMOVES net-snmp.  Perhaps extremely relevant, I have the *remove-with-leaves* yum plugin.  Is this the expected behavior of this plugin?
Comment 1 Basil Mohamed Gohar 2013-05-16 11:30:05 EDT
I'd just like to say I would have included "remove-with-leaves" as the culprit in the title, but I'm not entirely sure it is the sole source of this problem.  At least mentioning it here and in the description should bring that issue up in searches in case other people have similar or related problems.
Comment 2 Basil Mohamed Gohar 2013-05-16 11:34:38 EDT
Here is a list of packages from yum.log that were uninstalled when I ran `yum erase mysql*`:

Apr 29 13:40:40 Erased: 1:eclipse-pydev-2.7.1-6.fc17.noarch
Apr 29 13:40:41 Erased: jython-2.2.1-9.fc17.noarch
Apr 29 13:40:41 Erased: phpMyAdmin-3.5.8-1.fc17.noarch
Apr 29 13:40:41 Erased: mysql-server-5.5.30-1.fc17.x86_64
Apr 29 13:40:41 Erased: php-mysql-5.4.14-1.fc17.x86_64
Apr 29 13:40:41 Erased: perl-DBD-MySQL-4.020-2.fc17.x86_64
Apr 29 13:40:41 Erased: mysql-5.5.30-1.fc17.x86_64
Apr 29 13:40:41 Erased: gmyth-0.7.1-18.fc17.x86_64
Apr 29 13:40:41 Erased: hplip-3.12.11-1.fc17.x86_64
Apr 29 13:40:41 Erased: 1:hpijs-3.12.11-1.fc17.x86_64
Apr 29 13:40:41 Erased: 1:net-snmp-5.7.1-5.fc17.1.x86_64
Apr 29 13:40:41 Erased: sysbench-0.4.12-6.fc17.x86_64
Apr 29 13:40:41 Erased: 1:mysql-connector-java-5.1.21-2.fc17.noarch
Apr 29 13:40:41 Erased: mysql-libs-5.5.30-1.fc17.x86_64
Comment 3 Tim Waugh 2013-05-17 08:06:54 EDT
$ rpm --test -e net-snmp mysql-libs
$ rpm -q hpijs
hpijs-3.13.3-2.fc18.x86_64

Works fine here on F-18.

Maybe try without the 'remove-with-leaves' plugin, to narrow down the cause of what you're seeing.
Comment 4 Jiri Popelka 2013-05-20 03:46:55 EDT
(In reply to Basil Mohamed Gohar from comment #2)
> Apr 29 13:40:41 Erased: hplip-3.12.11-1.fc17.x86_64
> Apr 29 13:40:41 Erased: 1:hpijs-3.12.11-1.fc17.x86_64

I already fixed that in hplip-3.12.11-2.fc17 (bug #895643) but have not created an F17 update since then. I'll do it now.
Comment 5 Jiri Popelka 2013-05-20 03:57:35 EDT

*** This bug has been marked as a duplicate of bug 895643 ***
Comment 6 Basil Mohamed Gohar 2013-05-20 09:36:43 EDT
Thanks, Jiri!

Note You need to log in before you can comment on or make changes to this bug.