Bug 963874 - String Update: 'Available Subscriptions' > 'Available' in All Available Subscriptions Table & CLI tweak
String Update: 'Available Subscriptions' > 'Available' in All Available Subsc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510 986971
  Show dependency treegraph
 
Reported: 2013-05-16 13:20 EDT by Matt Reid
Modified: 2013-09-30 19:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
: 986971 (view as bug list)
Environment:
Last Closed: 2013-09-30 19:09:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Subscription, All Available subscription column name change (248.33 KB, image/png)
2013-07-19 13:38 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2013-05-16 13:20:44 EDT
Description of problem:
We can save some table width and potential horizontal scrolling if we drop the redundant 'Subscriptions' from 'Available Subscriptions' in our Subscriptions table on the My Available Subscriptions tab. We already have a Subscription header for the Subscriptions themselves, we probably don't need to specify again that these are Subscriptions we're talking about.

Drop 'Subscriptions' from:
#: ../src/subscription_manager/gui/allsubs.py:84
#: ../src/subscription_manager/managercli.py:2058
msgid "Available Subscriptions"

I'm not sure where we use that in the CLI, my guess was 'list --available', but it says 'Quantity:' there. Anyone know where that shows in the CLI?

Speaking of which, within Subscription Manager, I'd like to see us reserve Quantity to talk about how many subscriptions will or have been attached, rather than how many are available. Could we change 'Quantity:' in the CLI output of 'list --available' to say 'Available:' and match the above change in the GUI?

#: ../src/subscription_manager/managercli.py:89
msgid "Quantity:"

Version-Release number of selected component (if applicable):
subscription-manager 1.8.7-1.git

More Info:

I'm not as concerned about us showing Quantity/Quantity Used in rct at this point, since I think they're referring to slightly different numbers. In Subscription Manager, we're cutting out what's been used and just showing the quantity that are available, whereas in cat-cert we show total quantity (at least on my employee sub cert I have a quantity of 10000), and how many were used (1).
Comment 1 RHEL Product and Program Management 2013-05-16 13:29:41 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2013-05-16 13:31:46 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Cory Scheviak 2013-06-13 08:44:20 EDT
bc35701aed77d9da06689d7c350342812924b016

subscription-manager.git
Comment 4 Sharath Dwaral 2013-07-19 13:38:06 EDT
Created attachment 775891 [details]
Subscription, All Available subscription column name change

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-debuginfo-1.8.13-1.el5
subscription-manager-gui-1.8.13-1.el5
subscription-manager-firstboot-1.8.13-1.el5
python-rhsm-1.8.13-1.el5
subscription-manager-migration-1.8.13-1.el5
subscription-manager-1.8.13-1.el5

Verification:

This bug is partially fixed

String Change from "Available Subscription" -> "Available"  (See Attachment)

>>  But the second change suggested from 
>>  "Quantity:" -> "Available:"  on CLI is incomplete

Marking VERIFIED as String changes will not be incorporated to 5.10 any longer.
Comment 5 Sharath Dwaral 2013-07-19 13:39:14 EDT
# subscription-manager list --available 
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Multi-Attribute (multi-entitlement only) (8 cores, 4GB)
SKU:               non-stacked-8core4ram-multiattr
Pool ID:           8a90f8333feace49013feacfbf1d03ea
Quantity:          5       <<<<<<<<<<<<<<<<<<
Service Level:     Premium
Service Type:      Level 3
Multi-Entitlement: Yes
Ends:              07/16/2014
System Type:       Physical

No change on CLI

Marking Verified
Comment 8 errata-xmlrpc 2013-09-30 19:09:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.