Bug 964054 - gluster volume status fails
gluster volume status fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
amainkar
:
Depends On:
Blocks: 964059
  Show dependency treegraph
 
Reported: 2013-05-17 03:22 EDT by Pranith Kumar K
Modified: 2015-04-20 07:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 964059 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:35:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-05-17 03:22:30 EDT
Description of problem:
When remove-brick start is executed with a brick from another peer. Volume status fails on the local machine.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a 2x1 volume with bricks on two different machines m1, m2. Start the volume.
2. on m1 execute remove-brick start with brick on m2.
3. execute gluster volume status on m1. It fails with following message.
Commit failed on localhost. Please check the log file for more details.

  
Actual results:


Expected results:
volume status should pass.

Additional info:
Comment 2 Rachana Patel 2013-06-27 03:46:49 EDT
verified with 3.4.0.11rhs-1.el6rhs.x86_64, working as per expectation so changing status to verified
Comment 3 Scott Haines 2013-09-23 18:35:35 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.