Bug 964059 - gluster volume status fails
gluster volume status fails
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 964054
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 03:31 EDT by Pranith Kumar K
Modified: 2014-03-21 18:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 964054
Environment:
Last Closed: 2013-07-24 13:14:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-05-17 03:31:37 EDT
+++ This bug was initially created as a clone of Bug #964054 +++

Description of problem:
When remove-brick start is executed with a brick from another peer. Volume status fails on the local machine.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a 2x1 volume with bricks on two different machines m1, m2. Start the volume.
2. on m1 execute remove-brick start with brick on m2.
3. execute gluster volume status on m1. It fails with following message.
Commit failed on localhost. Please check the log file for more details.

  
Actual results:


Expected results:
volume status should pass.

Additional info:
Comment 1 Anand Avati 2013-05-17 03:33:19 EDT
REVIEW: http://review.gluster.org/5030 (mgmt/glusterd: Set task op at the time of task-id set) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-06-06 06:57:02 EDT
COMMIT: http://review.gluster.org/5030 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit d68fbc3f817831a676d60de7be5b095967aadc7a
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu May 16 18:13:10 2013 +0530

    mgmt/glusterd: Set task op at the time of task-id set
    
    Problem:
    If a remove-brick start is executed on m1 with brick from m2
    on local subvolume no rebalance process is launched. Because of
    this volinfo->rebal.op is not set. This leads to volume status
    failures.
    
    Fix:
    Set rebal.op even when the reblance process is not started.
    
    Change-Id: I71c7e6f09353be14c1e8edca3c8685ebfdf226d6
    BUG: 964059
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5030
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Note You need to log in before you can comment on or make changes to this bug.