Bug 964056 - No check for already enabled collections in scl enable <collection>+ <command>
No check for already enabled collections in scl enable <collection>+ <command>
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scl-utils (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Zeleny
Lukas Zachar
:
Depends On:
Blocks: 964058 964061
  Show dependency treegraph
 
Reported: 2013-05-17 03:23 EDT by Lukas Zachar
Modified: 2013-09-30 18:05 EDT (History)
1 user (show)

See Also:
Fixed In Version: scl-utils-20120927-8.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 964058 964061 (view as bug list)
Environment:
Last Closed: 2013-09-30 18:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zachar 2013-05-17 03:23:46 EDT
Description of problem:

It is possible to enable collection repeatedly when it is specified multiple times for 'scl enable' command .

Version-Release number of selected component (if applicable):
scl-utils-20120927-2.el5

How reproducible:
always

Steps to Reproduce:
1. scl enable MockA MockB MockA 'echo $PATH; echo $X_SCLS'
2.
3.
  
Actual results:
/opt/rh/MockA/root/bin:/opt/rh/MockB/root/bin:/opt/rh/MockA/root/bin
X_SCLS=MockA MockB

Expected results:
/opt/rh/MockB/root/bin:/opt/rh/MockA/root/bin
X_SCLS=MockA MockB

Additional info:
Comment 1 RHEL Product and Program Management 2013-05-17 03:29:59 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 errata-xmlrpc 2013-09-30 18:05:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1303.html

Note You need to log in before you can comment on or make changes to this bug.