Bug 964058 - No check for already enabled collections in scl enable <collection>+ <command>
Summary: No check for already enabled collections in scl enable <collection>+ <command>
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scl-utils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jan Zeleny
QA Contact: Lukas Zachar
URL:
Whiteboard:
Keywords: ZStream
Depends On: 964056 964061
Blocks: 976551
TreeView+ depends on / blocked
 
Reported: 2013-05-17 07:31 UTC by Lukas Zachar
Modified: 2013-11-21 06:07 UTC (History)
2 users (show)

(edit)
* Previously, when enabling collections, a check whether a collection was enabled was performed. However, independently of the result the collection was always enabled. Consequently, if a single collection had been stated multiple times in the command line, it would be enabled multiple times. In the case of some destructive enable scriptlets, this might have led to some undetermined behavior. This update runs the enable scriptlet only if the collection has not been enabled before, and attempts to enable a collection multiple times in one environment will be ignored.
Clone Of: 964056
(edit)
Last Closed: 2013-11-21 06:07:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1554 normal SHIPPED_LIVE scl-utils bug fix update 2013-11-20 21:40:27 UTC

Description Lukas Zachar 2013-05-17 07:31:35 UTC
+++ This bug was initially created as a clone of Bug #964056 +++

Description of problem:

It is possible to enable collection repeatedly when it is specified multiple times for 'scl enable' command .

Version-Release number of selected component (if applicable):
scl-utils-20120927-2.el6

How reproducible:
always

Steps to Reproduce:
1. scl enable MockA MockB MockA 'echo $PATH; echo $X_SCLS'
2.
3.
  
Actual results:
/opt/rh/MockA/root/bin:/opt/rh/MockB/root/bin:/opt/rh/MockA/root/bin
X_SCLS=MockA MockB

Expected results:
/opt/rh/MockB/root/bin:/opt/rh/MockA/root/bin
X_SCLS=MockA MockB

Additional info:

--- Additional comment from RHEL Product and Program Management on 2013-05-17 03:29:59 EDT ---

This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 7 errata-xmlrpc 2013-11-21 06:07:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1554.html


Note You need to log in before you can comment on or make changes to this bug.