Bug 964411 - history uses wrong encoding to show utf8 logs
history uses wrong encoding to show utf8 logs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
Depends On: 966722
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 05:14 EDT by Igor Gnatenko
Modified: 2013-08-05 20:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: empathy-3.8.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 20:12:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 691085 None None None Never
GNOME Desktop 692746 None None None Never

  None (edit)
Description Igor Gnatenko 2013-05-18 05:14:11 EDT
Description of problem:
history uses wrong encoding to show utf8 logs.

Version-Release number of selected component (if applicable):
since 3.6.3
empathy-3.8.1-2.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Send e.g. "Привет" ("Hello" in Russian)
2. Open Previous conversations
  
Actual results:
The last entry is "Привет"

Expected results:
Last entry will be "Привет"

Additional info:
I have checked that my logs in ~/.local/share/TpLogger/ are in utf8. Then I
downgrade empathy up to 3.6.2 and restart gnome-session. This is fixed my
problem. I have checked several times and can confirm that with empathy 3.6.2
the bug is not reproducible, but reproducible since 3.6.3.

The problem here is that g_strescape changed its specifications over time -
from the UTF-8-compatible "double every backslash" to ASCII-only "escape
everything except 0x20 through 0x7E". Would it be right to invent a new
backslash-doubling function for empathy-log-window.c specifically? Not pretty,
but passing a 128-character exception string to g_strescape is even less so.

This commit created this bug: https://git.gnome.org/browse/empathy/commit/?h=gnome-3-6&id=1e7449f5a14e2f031389808206c9991f65d3ade7
Comment 1 Fedora Update System 2013-05-24 10:41:00 EDT
empathy-3.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/empathy-3.8.3-1.fc19
Comment 2 Fedora Update System 2013-05-24 15:49:05 EDT
Package empathy-3.8.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing empathy-3.8.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9093/empathy-3.8.3-1.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-05-25 23:44:40 EDT
empathy-3.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Igor Gnatenko 2013-06-26 11:06:04 EDT
Add patch as downstream (there will be no new releases in 3.8 branch)
https://git.gnome.org/browse/empathy/commit/?id=6bace22f3ffb9695870267e2a59858b3feeaa83e
Comment 5 Fedora Update System 2013-08-01 15:09:42 EDT
empathy-3.8.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/empathy-3.8.3-2.fc19
Comment 6 Fedora Update System 2013-08-02 17:59:25 EDT
Package empathy-3.8.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing empathy-3.8.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14109/empathy-3.8.3-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-08-05 20:12:30 EDT
empathy-3.8.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.