Bug 966722 - Include a UTF-8 safe escaping function
Include a UTF-8 safe escaping function
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 964411
  Show dependency treegraph
 
Reported: 2013-05-23 14:44 EDT by Igor Gnatenko
Modified: 2013-06-02 09:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 09:45:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 89548 None None None Never

  None (edit)
Description Igor Gnatenko 2013-05-23 14:44:36 EDT
Description of problem:
g_strescape() is useless since it mangles UTF-8. We should
include a less aggressive escaping function.

Version-Release number of selected component (if applicable):
2.38

Actual results:
g_strescape not correctly working with UTF8 strings

Expected results:
Implemented g_utf8_strescape

Additional info:
Of this bug depends encoding problems in empathy.

Work is being done in GNOME BZ, but I need help from other developers.
Comment 1 Kalev Lember 2013-06-02 09:45:39 EDT
Closing the ticket; Empathy has a fix for the escaping issue and the glib new API addition is being tracked upstream.

Note You need to log in before you can comment on or make changes to this bug.