Bug 964590 - Left click on touchpad logs out session
Left click on touchpad logs out session
Status: CLOSED DUPLICATE of bug 962721
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 01:31 EDT by hxkhltr
Modified: 2013-05-19 19:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-19 19:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hxkhltr 2013-05-19 01:31:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:High


Steps to Reproduce:
1.Update system
2.left click on touchpad
3.
  
Actual results:
logs out session


Expected results:
Normal left click functionality


Additional info:
issue is not kernel specific
Comment 1 Rex Dieter 2013-05-19 07:22:39 EDT
Do you get a logout notification?

If not, I suspect a session/X crash instead... which may be evident from your ~/.xsession-errors log contents.
Comment 2 hxkhltr 2013-05-19 08:46:30 EDT
(In reply to comment #1)
> Do you get a logout notification?
> 
> If not, I suspect a session/X crash instead... which may be evident from
> your ~/.xsession-errors log contents.

I do not get a logout notification. 

.xsession-errors :

GNOME_KEYRING_CONTROL=/run/user/hx/keyring-ysBRBe
GNOME_KEYRING_CONTROL=/run/user/hx/keyring-ysBRBe
SSH_AUTH_SOCK=/run/user/hx/keyring-ysBRBe/ssh
GNOME_KEYRING_CONTROL=/run/user/hx/keyring-ysBRBe
GNOME_KEYRING_CONTROL=/run/user/hx/keyring-ysBRBe
SSH_AUTH_SOCK=/run/user/hx/keyring-ysBRBe/ssh
GPG_AGENT_INFO=/run/user/hx/keyring-ysBRBe/gpg:0:1
Initializing tracker-miner-fs...
Tracker-Message: Setting up monitor for changes to config file:'/home/hx/.config/tracker/tracker-miner-fs.cfg'
Initializing tracker-store...
Tracker-Message: Setting up monitor for changes to config file:'/home/hx/.config/tracker/tracker-store.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/hx/.config/tracker/tracker-store.cfg'
Starting log:
  File:'/home/hx/.local/share/tracker/tracker-miner-fs.log'
Starting log:
  File:'/home/hx/.local/share/tracker/tracker-store.log'
Failed to play sound: File or data not found
** Message: applet now removed from the notification area
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
** Message: Stopping applet secret agent because GNOME Shell appeared
** Message: applet now embedded in the notification area
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
No bp log location saved, using default.
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:001] Using Gtk2 toolkit
[000:019] Starting client channel.
[000:020] Warning(clientchannel.cc:436): Unreadable or no port file.  Could not initiate GoogleTalkPlugin connection
[000:021] Warning(clientchannel.cc:411): Could not initiate GoogleTalkPlugin connection
[000:022] GoogleTalkPlugin not running. Starting new process...
[000:022] Warning(optionsfile.cc:47): Load: Could not open file, err=2
[000:022] Warning(pluginutils.cc:243): Failed to get GoogleTalkPlugin path. Trying default.
[000:025] Started GoogleTalkPlugin, path=/opt/google/talkplugin/GoogleTalkPlugin
[000:025] Waiting for GoogleTalkPlugin to start...
[001:105] Attempting to connect to GoogleTalkPlugin...
[001:106] Read port file, port=56959
[001:115] Initiated connection to GoogleTalkPlugin
[001:247] Socket connection established
[001:247] ScheduleOnlineCheck: Online check in 5000ms
[001:306] Got cookie response, socket is authorized
[001:306] AUTHORIZED; socket handshake complete
[006:319] HandleOnlineCheck: Starting check
[006:319] HandleOnlineCheck: OK; current state: 3
Comment 3 Kevin Kofler 2013-05-19 18:50:06 EDT
> ** Message: Stopping applet secret agent because GNOME Shell appeared

That's a GNOME session. Reassigning to gnome-shell.
Comment 4 Kevin Kofler 2013-05-19 19:03:59 EDT
Actually, this is probably bug #962721, fixed by today's xorg-x11-drv-synaptics update.

*** This bug has been marked as a duplicate of bug 962721 ***

Note You need to log in before you can comment on or make changes to this bug.