Bug 962721 - Xorg killed when clicking using hard button on touchpad xorg-x11-drv-synaptics-1.6.3-3.fc17.x86_64
Xorg killed when clicking using hard button on touchpad xorg-x11-drv-synaptic...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 963888 964590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 06:20 EDT by Adhidarma Hadiwinoto
Modified: 2013-05-19 19:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.6.3-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 22:33:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (28.38 KB, text/plain)
2013-05-15 04:40 EDT, Adhidarma Hadiwinoto
no flags Details
/var/log/Xorg.0.log.old (31.86 KB, text/plain)
2013-05-15 04:41 EDT, Adhidarma Hadiwinoto
no flags Details
evemu-describe result (872 bytes, text/plain)
2013-05-15 05:02 EDT, Adhidarma Hadiwinoto
no flags Details
evemu-record result (29.96 KB, text/plain)
2013-05-15 05:04 EDT, Adhidarma Hadiwinoto
no flags Details

  None (edit)
Description Adhidarma Hadiwinoto 2013-05-14 06:20:18 EDT
Description of problem:

xorg-x11-drv-synaptics-1.6.3-3.fc17.x86_64 has a fatal bug.

Doing mouse click with hard button on touchpad (not by tapping) always crash my xorg (gnome shell and gnome login).

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.6.3-3.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Update to xorg-x11-drv-synaptics-1.6.3-3.fc17.x86_64 
2. Click using hard button on touchpad, not by tapping on touchpad
  
Actual results:
xorg will crash

Expected results:
xorg still running

Additional info:
My hardware is Acer Ultrabook S3.

Downgrading to xorg-x11-drv-synaptics-1.6.0-1.fc17.x86_64 fixes the problem.

lspci result:
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
00:14.0 USB Controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB Controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
02:00.0 Network controller: Atheros Communications Inc. Device 0034 (rev 01)
Comment 1 JYundt 2013-05-14 15:01:45 EDT
I'm having the exact same problem on my HP Folio 13 (Fedora 17 i686 PAE):

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
09:00.0 USB Controller: Fresco Logic Device 1009 (rev 02)
Comment 2 Peter Hutterer 2013-05-14 18:02:42 EDT
can I have an Xorg.log please, and an evemu recording of the button event. Thanks.
Comment 3 Adhidarma Hadiwinoto 2013-05-15 04:40:53 EDT
Created attachment 748144 [details]
/var/log/Xorg.0.log
Comment 4 Adhidarma Hadiwinoto 2013-05-15 04:41:35 EDT
Created attachment 748145 [details]
/var/log/Xorg.0.log.old
Comment 5 Adhidarma Hadiwinoto 2013-05-15 04:44:17 EDT
Peter, I've attached Xorg.log.

I'll try to understand evemu first. If I succeed, I'll post evemu recording that you request.
Comment 6 Peter Hutterer 2013-05-15 04:52:12 EDT
weird, neither of the logs has a backtrace. do you have log with one included?

the .log.old should usually include some more shutdown messages, that they're missing could hint of a unresolved symbol. disable your display manager

   sudo systemctl stop gdm.service

then log in on the tty and start X with xinit -- (install xterm). then press the button on the touchpad. if it crashes, you should see something on the terminal.

   sudo systemctl start gdm.service

will get you back to gdm
Comment 7 Adhidarma Hadiwinoto 2013-05-15 05:02:55 EDT
Created attachment 748155 [details]
evemu-describe result

result from:
sudo evemu-describe /dev/input/event4 > device.prop
Comment 8 Adhidarma Hadiwinoto 2013-05-15 05:04:47 EDT
Created attachment 748156 [details]
evemu-record result

result from:
sudo evemu-record /dev/input/event4 > device.event
Comment 9 Adhidarma Hadiwinoto 2013-05-15 05:07:13 EDT
I've attached evemu record. I replay that recorded events and it confirmed my xorg crash.
Comment 10 Adhidarma Hadiwinoto 2013-05-15 05:36:08 EDT
(In reply to comment #6)
> weird, neither of the logs has a backtrace. do you have log with one
> included?
> 
> the .log.old should usually include some more shutdown messages, that
> they're missing could hint of a unresolved symbol. disable your display
> manager
> 
>    sudo systemctl stop gdm.service
> 
> then log in on the tty and start X with xinit -- (install xterm). then press
> the button on the touchpad. if it crashes, you should see something on the
> terminal.
> 
>    sudo systemctl start gdm.service
> 
> will get you back to gdm

I've tried to stop gdm.service but my system complain that gdm.service is not loaded. So I try to mimic it by change my systemd default target as multi-user.target, boot the system and start xinit.

Button press on the touchpad on this xterm session also crash the xorg. No message displayed. The system just hang. I need to push power off button to restart my laptop.
Comment 11 Peter Hutterer 2013-05-15 18:27:55 EDT
Xorg: symbol lookup error: /usr/lib64/xorg/modules/input/synaptics_drv.so: undefined symbol: BUG_RETURN_VAL

Introduced by xorg-x11-drv-synaptics-1.6.3-3.fc17, BUG_RETURN_VAL isn't defined on server 1.12. Update will be out in a minute.
Comment 12 Fedora Update System 2013-05-15 18:39:14 EDT
xorg-x11-drv-synaptics-1.6.3-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.3-4.fc17
Comment 13 Adhidarma Hadiwinoto 2013-05-16 06:21:55 EDT
I've test xorg-x11-drv-synaptics-1.6.3-4.fc17 rpm from koji. I confirm that rpm has fix the problem and haven't found other problem.
Comment 14 Bill McGonigle 2013-05-16 12:20:35 EDT
Thanks.  -4 fixes an Xorg crash on my Thinkpad E430 from the previous 'stable' update.

As of now, my updates-testing mirror doesn't have -4; installed with:

  sudo rpm -Uhv http://kojipkgs.fedoraproject.org//packages/xorg-x11-drv-synaptics/1.6.3/4.fc17/x86_64/xorg-x11-drv-synaptics-1.6.3-4.fc17.x86_64.rpm
  sudo rpm -Uhv http://kojipkgs.fedoraproject.org//packages/xorg-x11-drv-synaptics/1.6.3/4.fc17/x86_64/xorg-x11-drv-synaptics-debuginfo-1.6.3-4.fc17.x86_64.rpm

And left positive karma at:
  https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.3-4.fc17

As an aside: no backtraces or errors (aside from the notice from kdm that Xorg went down) in any logs or dmesg, and abrt didn't notice this problem.  Is there something we can do to catch these sorts of problems with the Fedora toolset in the future?
Comment 15 inte 2013-05-16 14:59:27 EDT
*** Bug 963888 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2013-05-16 23:28:05 EDT
Package xorg-x11-drv-synaptics-1.6.3-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.3-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8394/xorg-x11-drv-synaptics-1.6.3-4.fc17
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-05-18 22:33:43 EDT
xorg-x11-drv-synaptics-1.6.3-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Kevin Kofler 2013-05-19 19:03:59 EDT
*** Bug 964590 has been marked as a duplicate of this bug. ***
Comment 19 Peter Hutterer 2013-05-19 19:22:28 EDT
(In reply to comment #14)
> As an aside: no backtraces or errors (aside from the notice from kdm that
> Xorg went down) in any logs or dmesg, and abrt didn't notice this problem. 
> Is there something we can do to catch these sorts of problems with the
> Fedora toolset in the future?

problem in this case was that a dynamically loaded driver was hitting an unresolved symbol. the error was printed to the console, but you'd have to start the server manually from the console to see it.

if this can be fixed, I suspect the hooks would be in glibc somewhere.

Note You need to log in before you can comment on or make changes to this bug.